summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-31 23:07:38 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-31 23:07:38 +0000
commit6929248548c44989599c6e512c160d8682c541fc (patch)
tree8e457ef32639835cdf6d13095aea552c55fa8721 /sys-apps
parentnew package net-misc/d4x (diff)
downloadgentoo-2-6929248548c44989599c6e512c160d8682c541fc.tar.gz
gentoo-2-6929248548c44989599c6e512c160d8682c541fc.tar.bz2
gentoo-2-6929248548c44989599c6e512c160d8682c541fc.zip
always use internal version of readline
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bash/ChangeLog9
-rw-r--r--sys-apps/bash/bash-2.05a-r3.ebuild (renamed from sys-apps/bash/bash-2.05a-r2.ebuild)33
-rw-r--r--sys-apps/bash/bash-2.05b-r2.ebuild (renamed from sys-apps/bash/bash-2.05b-r1.ebuild)21
-rw-r--r--sys-apps/bash/bash-2.05b.ebuild56
-rw-r--r--sys-apps/bash/files/digest-bash-2.05a-r3 (renamed from sys-apps/bash/files/digest-bash-2.05a-r2)0
-rw-r--r--sys-apps/bash/files/digest-bash-2.05b1
-rw-r--r--sys-apps/bash/files/digest-bash-2.05b-r2 (renamed from sys-apps/bash/files/digest-bash-2.05b-r1)0
7 files changed, 44 insertions, 76 deletions
diff --git a/sys-apps/bash/ChangeLog b/sys-apps/bash/ChangeLog
index 41a09868e262..19bd0e0ffbba 100644
--- a/sys-apps/bash/ChangeLog
+++ b/sys-apps/bash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/bash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/ChangeLog,v 1.8 2002/08/31 13:15:17 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/ChangeLog,v 1.9 2002/08/31 23:07:38 azarah Exp $
+
+*bash-2.05b-r2 (1 Sep 2002)
+*bash-2.05a-r3 (1 Sep 2002)
+
+ 1 Sep 2002; Martin Schlemmer <azarah@gentoo.org> bash-2.05a-r3 bash-2.05b-r2 :
+ Update to use internal readline. This fixes problems where bash stops
+ working if readline (external) is updated.
*bash-2.05b-r1 (30 Aug 2002)
diff --git a/sys-apps/bash/bash-2.05a-r2.ebuild b/sys-apps/bash/bash-2.05a-r3.ebuild
index 115ca96ce7b1..5b32014dc57b 100644
--- a/sys-apps/bash/bash-2.05a-r2.ebuild
+++ b/sys-apps/bash/bash-2.05a-r3.ebuild
@@ -1,21 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a-r2.ebuild,v 1.11 2002/08/30 12:06:17 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a-r3.ebuild,v 1.1 2002/08/31 23:07:38 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
LICENSE="GPL-2"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-4.1-r2 )"
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
RDEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
+
cd ${S}
#enable non-interactive login shells; this patch allows your prompt
#to be preserved when you start X and closes bug #1579.
@@ -23,10 +25,17 @@ src_unpack() {
}
src_compile() {
+ local myconf=""
- local myconf
- [ "`use readline`" ] && myconf="--with-installed-readline"
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #[ "`use readline`" ] && myconf="--with-installed-readline"
+
[ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+
./configure --prefix=/ \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -36,25 +45,27 @@ src_compile() {
--without-gnu-malloc \
${myconf} || die
# bash 2.0.5 doesn't like -j>1
+
emake -j1 || die
}
src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
dodir /bin
mv ${D}/usr/bin/bash ${D}/bin
dosym bash /bin/sh
if [ -z "`use build`" ]
then
- doman doc/*.1
- if [ -z "`use readline`" ]
- then
- doman doc/*.3
- fi
+ doman doc/*.1 doc/*.3
dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
dodoc doc/FAQ doc/INTRO
else
rm -rf ${D}/usr
fi
}
+
diff --git a/sys-apps/bash/bash-2.05b-r1.ebuild b/sys-apps/bash/bash-2.05b-r2.ebuild
index 7443971f8eb8..1e289da26bfe 100644
--- a/sys-apps/bash/bash-2.05b-r1.ebuild
+++ b/sys-apps/bash/bash-2.05b-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05b-r1.ebuild,v 1.4 2002/08/31 13:15:17 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05b-r2.ebuild,v 1.1 2002/08/31 23:07:38 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
@@ -13,18 +13,25 @@ LICENSE="GPL-2"
KEYWORDS="x86 -ppc sparc sparc64"
DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-4.3 )
sys-devel/autoconf"
src_unpack() {
unpack ${A}
- patch -p0 < ${P}-gentoo.diff
+
+ patch -p0 < ${P}-gentoo.diff || die
}
src_compile() {
- local myconf
- use readline && myconf="--with-installed-readline"
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+
use nls || myconf="${myconf} --disable-nls"
econf \
@@ -47,9 +54,9 @@ src_install() {
use build \
&& rm -rf ${D}/usr \
|| ( \
- doman doc/*.1
- use readline || doman doc/*.3
+ doman doc/*.1 doc/*.3
dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
dodoc doc/FAQ doc/INTRO
)
}
+
diff --git a/sys-apps/bash/bash-2.05b.ebuild b/sys-apps/bash/bash-2.05b.ebuild
deleted file mode 100644
index 487963666dd6..000000000000
--- a/sys-apps/bash/bash-2.05b.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05b.ebuild,v 1.4 2002/08/30 16:06:12 gerk Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The standard GNU Bourne again shell"
-SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 -ppc sparc sparc64"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-4.1-r2 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- #enable non-interactive login shells; this patch allows your prompt
- #to be preserved when you start X and closes bug #1579.
-# cat ${FILESDIR}/config-top.h.diff | patch -p0 -l || die
-}
-
-src_compile() {
-
- local myconf
- use readline && myconf="--with-installed-readline"
- use nls || myconf="${myconf} --disable-nls"
-
- econf \
- --disable-profiling \
- --with-curses \
- --without-gnu-malloc \
- ${myconf} || die
-
- make || die
-}
-
-src_install() {
-
- einstall || die
-
- dodir /bin
- mv ${D}/usr/bin/bash ${D}/bin
- dosym bash /bin/sh
-
- use build \
- && rm -rf ${D}/usr \
- || ( \
- doman doc/*.1
- use readline || doman doc/*.3
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
- dodoc doc/FAQ doc/INTRO
- )
-}
diff --git a/sys-apps/bash/files/digest-bash-2.05a-r2 b/sys-apps/bash/files/digest-bash-2.05a-r3
index 5dc9061017e7..5dc9061017e7 100644
--- a/sys-apps/bash/files/digest-bash-2.05a-r2
+++ b/sys-apps/bash/files/digest-bash-2.05a-r3
diff --git a/sys-apps/bash/files/digest-bash-2.05b b/sys-apps/bash/files/digest-bash-2.05b
deleted file mode 100644
index 7a6e2de100d2..000000000000
--- a/sys-apps/bash/files/digest-bash-2.05b
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
diff --git a/sys-apps/bash/files/digest-bash-2.05b-r1 b/sys-apps/bash/files/digest-bash-2.05b-r2
index db1bee2b82a8..db1bee2b82a8 100644
--- a/sys-apps/bash/files/digest-bash-2.05b-r1
+++ b/sys-apps/bash/files/digest-bash-2.05b-r2