summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-14 09:08:30 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-14 09:08:30 +0000
commit6d302766d5935ee0f52ac5c43d576f731bd58740 (patch)
tree53b77bb76163d622b3e814e28b97a975b804d95b /sys-apps
parentAdded ppc keyword (diff)
downloadgentoo-2-6d302766d5935ee0f52ac5c43d576f731bd58740.tar.gz
gentoo-2-6d302766d5935ee0f52ac5c43d576f731bd58740.tar.bz2
gentoo-2-6d302766d5935ee0f52ac5c43d576f731bd58740.zip
Version bump, security fix.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xinetd/ChangeLog7
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.71
-rw-r--r--sys-apps/xinetd/xinetd-2.3.7.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index 2d213cfd2cfb..76f012de57d8 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/xinetd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.5 2002/07/25 15:28:29 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.6 2002/08/14 09:08:30 aliz Exp $
+
+*xinetd-2.3.7 (14 Aug 2002)
+
+ 14 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> xinetd-2.3.7.ebuild :
+ Version bump, includes security fix.
*xinetd-2.3.5 (20 Jun 2002)
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.7 b/sys-apps/xinetd/files/digest-xinetd-2.3.7
new file mode 100644
index 000000000000..cc30cbb44ffe
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.7
@@ -0,0 +1 @@
+MD5 e9f6849a92ec7d48aa9f771fa2f94491 xinetd-2.3.7.tar.gz 284269
diff --git a/sys-apps/xinetd/xinetd-2.3.7.ebuild b/sys-apps/xinetd/xinetd-2.3.7.ebuild
new file mode 100644
index 000000000000..602596e6619e
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.7.ebuild,v 1.1 2002/08/14 09:08:30 aliz Exp $
+
+# NB: This ebuild introduces the /etc/xinetd.d includedir with a default
+# /etc/xinetd.conf file. Check your config files if you're upgrading
+# from an older ebuild version. You should browse /etc/xinetd.conf
+# and the files in /etc/xinetd.d. Everything is off by default with
+# access restricted to localhost.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="BSD"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+DEPEND="virtual/glibc tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="virtual/glibc sys-devel/perl"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+ use ipv6 && myconf="${myconf} --with-inet6"
+
+ econf --with-loadavg --host=${CHOST} ${myconf} || die
+
+ # Parallel make does not work
+ make || die
+}
+
+src_install() {
+
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe ${FILESDIR}/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/xinetd.conf xinetd.conf.default
+ dodoc AUDIT CHANGELOG README COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/etc.xinetd.d/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xinetd.rc6 xinetd
+ insinto /etc/conf.d ; newins ${FILESDIR}/xinetd.confd xinetd
+ insinto /etc ; doins ${FILESDIR}/xinetd.conf
+}
+