summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-08 11:30:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-08 11:30:12 +0000
commit75649b555fcd9a80bbcb3d720f0118961fc94265 (patch)
tree3b47dc254f142bf6b69655102e953f0bf66c4ba4 /sys-apps
parent[bump] dev-perl/Log-Log4perl-1.400.0 (diff)
downloadgentoo-2-75649b555fcd9a80bbcb3d720f0118961fc94265.tar.gz
gentoo-2-75649b555fcd9a80bbcb3d720f0118961fc94265.tar.bz2
gentoo-2-75649b555fcd9a80bbcb3d720f0118961fc94265.zip
Version bump; update live ebuild to use the git repository as a starting point, which makes it possible to share most of the ebuild between the two.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog9
-rw-r--r--sys-apps/hwids/hwids-20121208.ebuild47
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild31
3 files changed, 70 insertions, 17 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 35c99f672fdd..ee4838cb0d6c 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.50 2012/12/04 03:15:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.51 2012/12/08 11:30:12 flameeyes Exp $
+
+*hwids-20121208 (08 Dec 2012)
+
+ 08 Dec 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20121208.ebuild,
+ hwids-99999999.ebuild:
+ Version bump; update live ebuild to use the git repository as a starting
+ point, which makes it possible to share most of the ebuild between the two.
*hwids-20121203 (04 Dec 2012)
diff --git a/sys-apps/hwids/hwids-20121208.ebuild b/sys-apps/hwids/hwids-20121208.ebuild
new file mode 100644
index 000000000000..5314e1cbf0cd
--- /dev/null
+++ b/sys-apps/hwids/hwids-20121208.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121208.ebuild,v 1.1 2012/12/08 11:30:12 flameeyes Exp $
+
+EAPI=5
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+udev"
+
+DEPEND="udev? ( dev-lang/perl !=sys-fs/udev-196 )"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+src_compile() {
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+
+ if use udev; then
+ emake udev-hwdb
+ fi
+}
+
+src_install() {
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz} oui.txt iab.txt
+
+ dodoc README.md
+
+ if use udev; then
+ insinto "$(udev_get_udevdir)"/hwdb.d
+ doins udev/*.hwdb
+ fi
+}
+
+pkg_postinst() {
+ if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
+ udevadm hwdb --update
+ fi
+}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 71fdea6374dc..6cf1b6010d4f 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,48 +1,47 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.10 2012/12/02 17:50:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.11 2012/12/08 11:30:12 flameeyes Exp $
EAPI=5
-inherit udev
+inherit udev git-2
-DESCRIPTION="Hardware (PCI, USB) IDs databases"
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
+EGIT_REPO_URI="${HOMEPAGE}.git"
LICENSE="|| ( GPL-2 BSD ) public-domain"
SLOT="0"
KEYWORDS=""
IUSE="+udev"
-S=${WORKDIR}
-
-DEPEND="net-misc/wget
+DEPEND="net-misc/curl
udev? ( dev-lang/perl !=sys-fs/udev-196 )"
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
-src_compile() {
- wget http://pci-ids.ucw.cz/v2.2/pci.ids.gz http://www.linux-usb.org/usb.ids.gz http://standards.ieee.org/develop/regauth/oui/oui.txt || die
+src_prepare() {
+ emake fetch
+}
- local file
+src_compile() {
for file in {usb,pci}.ids; do
- zcat ${file}.gz > ${file} || die
+ gzip -c ${file} > ${file}.gz || die
done
if use udev; then
- local HWDB_URI="http://cgit.freedesktop.org/systemd/systemd/plain/hwdb"
- wget ${HWDB_URI}/20-acpi-vendor.hwdb || die
- wget ${HWDB_URI}/ids-update.pl -O ids-update-${PV}.pl || die
- perl ids-update-${PV}.pl &>/dev/null || die
+ emake udev-hwdb
fi
}
src_install() {
insinto /usr/share/misc
- doins {usb,pci}.ids{,.gz} oui.txt
+ doins {usb,pci}.ids{,.gz} oui.txt iab.txt
+
+ dodoc README.md
if use udev; then
insinto "$(udev_get_udevdir)"/hwdb.d
- doins *.hwdb
+ doins udev/*.hwdb
fi
}