summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-28 09:32:58 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-28 09:32:58 +0000
commit7e6ebb2475a1260d2c38c97febd60ff2eb0bc3af (patch)
tree2c0aff5446e0b619889993746f33358e7dbb4132 /sys-apps
parentre-keyword ~arm, tested on armv7, cubieboard2 (diff)
downloadgentoo-2-7e6ebb2475a1260d2c38c97febd60ff2eb0bc3af.tar.gz
gentoo-2-7e6ebb2475a1260d2c38c97febd60ff2eb0bc3af.tar.bz2
gentoo-2-7e6ebb2475a1260d2c38c97febd60ff2eb0bc3af.zip
Version bump. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/util-linux-2.24.2.ebuild (renamed from sys-apps/util-linux/util-linux-2.24.1-r1.ebuild)97
-rw-r--r--sys-apps/util-linux/util-linux-2.24.ebuild144
3 files changed, 68 insertions, 181 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index dbff15b37fe0..6b28545c5bbf 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.459 2014/05/14 18:13:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.460 2014/05/28 09:32:58 polynomial-c Exp $
+
+*util-linux-2.24.2 (28 May 2014)
+
+ 28 May 2014; Lars Wendler <polynomial-c@gentoo.org> -util-linux-2.24.ebuild,
+ -util-linux-2.24.1-r1.ebuild, +util-linux-2.24.2.ebuild:
+ Version bump. Removed old.
14 May 2014; Samuli Suominen <ssuominen@gentoo.org>
util-linux-2.24.1-r2.ebuild:
diff --git a/sys-apps/util-linux/util-linux-2.24.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.24.2.ebuild
index 0182b9b1970a..914ee963bd0d 100644
--- a/sys-apps/util-linux/util-linux-2.24.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.24.2.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.24.1-r1.ebuild,v 1.2 2014/03/14 15:59:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.24.2.ebuild,v 1.1 2014/05/28 09:32:58 polynomial-c Exp $
EAPI="4"
-PYTHON_COMPAT=( python2_7 python3_{2,3} )
+PYTHON_COMPAT=( python2_7 python3_{2,3,4} )
-inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 python-single-r1
+inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 \
+ python-single-r1 multilib-minimal
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
@@ -28,7 +29,7 @@ IUSE="bash-completion caps +cramfs cytune fdformat ncurses nls pam python selinu
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r5
+ !<sys-apps/sysvinit-2.88-r7
!sys-block/eject
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
@@ -38,9 +39,13 @@ RDEPEND="!sys-process/schedutils
ncurses? ( >=sys-libs/ncurses-5.2-r2 )
pam? ( sys-libs/pam )
python? ( ${PYTHON_DEPS} )
- selinux? ( sys-libs/libselinux )
+ selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
slang? ( sys-libs/slang )
- udev? ( virtual/udev )"
+ udev? ( virtual/udev )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140406-r2
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
@@ -60,74 +65,94 @@ src_prepare() {
po/update-potfiles
eautoreconf
fi
- epatch "${FILESDIR}"/${PN}-2.24-skip-last-tests.patch #491742
find tests/ -name bigyear -delete #489794
elibtoolize
}
lfs_fallocate_test() {
# Make sure we can use fallocate with LFS #300307
- cat <<-EOF > "${T}"/fallocate.c
+ cat <<-EOF > "${T}"/fallocate.${ABI}.c
#define _GNU_SOURCE
#include <fcntl.h>
main() { return fallocate(0, 0, 0, 0); }
EOF
append-lfs-flags
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.c -o /dev/null >/dev/null 2>&1 \
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
|| export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.c
+ rm -f "${T}"/fallocate.${ABI}.c
}
-src_configure() {
+multilib_src_configure() {
lfs_fallocate_test
- export ac_cv_header_security_pam_misc_h=$(usex pam) #485486
+ export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
+ ECONF_SOURCE=${S} \
econf \
--docdir="/usr/share/doc/${PF}" \
--enable-fs-paths-extra=/usr/sbin:/bin:/usr/bin \
- $(use_enable nls) \
+ $(multilib_native_use_enable nls) \
--enable-agetty \
--with-bashcompletiondir="$(get_bashcompdir)" \
- $(use_enable bash-completion) \
- $(use_enable caps setpriv) \
- $(use_enable cramfs) \
- $(use_enable cytune) \
- $(use_enable fdformat) \
- --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
+ $(multilib_native_use_enable bash-completion) \
+ $(multilib_native_use_enable caps setpriv) \
+ $(multilib_native_use_enable cramfs) \
+ $(multilib_native_use_enable cytune) \
+ $(multilib_native_use_enable fdformat) \
+ --with-ncurses=$(multilib_native_usex ncurses $(usex unicode auto yes) no) \
--disable-kill \
- --disable-last \
--disable-login \
- $(use_enable tty-helpers mesg) \
+ $(multilib_native_use_enable tty-helpers mesg) \
--disable-nologin \
--enable-partx \
- $(use_with python) \
+ $(multilib_native_use_with python) \
--enable-raw \
--enable-rename \
--disable-reset \
--enable-schedutils \
--disable-su \
- $(use_enable tty-helpers wall) \
- $(use_enable tty-helpers write) \
- $(use_enable suid makeinstall-chown) \
- $(use_enable suid makeinstall-setuid) \
+ $(multilib_native_use_enable tty-helpers wall) \
+ $(multilib_native_use_enable tty-helpers write) \
+ $(multilib_native_use_enable suid makeinstall-chown) \
+ $(multilib_native_use_enable suid makeinstall-setuid) \
$(use_with selinux) \
- $(use_with slang) \
+ $(multilib_native_use_with slang) \
$(use_enable static-libs static) \
- $(use_with udev) \
+ $(multilib_native_use_with udev) \
$(tc-has-tls || echo --disable-tls)
}
-src_test() {
- emake check
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ # build libraries only
+ emake -f Makefile -f - mylibs \
+ <<< 'mylibs: $(usrlib_exec_LTLIBRARIES) $(pkgconfig_DATA)'
+ fi
}
-src_install() {
- default
- dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}
+multilib_src_test() {
+ multilib_is_native_abi && emake check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake DESTDIR="${D}" install-usrlib_execLTLIBRARIES \
+ install-pkgconfigDATA install-uuidincHEADERS \
+ install-nodist_blkidincHEADERS install-nodist_mountincHEADERS
+ fi
- use python && python_optimize
+ if multilib_is_native_abi; then
+ # need the libs in /
+ gen_usr_ldscript -a blkid mount uuid
- # need the libs in /
- gen_usr_ldscript -a blkid mount uuid
+ use python && python_optimize
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}
# e2fsprogs-libs didnt install .la files, and .pc work fine
prune_libtool_files
diff --git a/sys-apps/util-linux/util-linux-2.24.ebuild b/sys-apps/util-linux/util-linux-2.24.ebuild
deleted file mode 100644
index 794773e4fbec..000000000000
--- a/sys-apps/util-linux/util-linux-2.24.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.24.ebuild,v 1.8 2014/03/14 15:59:41 vapier Exp $
-
-EAPI="4"
-
-PYTHON_COMPAT=( python2_7 python3_{2,3} )
-
-inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 python-single-r1
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-2 autotools
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
- SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-
-LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
-SLOT="0"
-IUSE="bash-completion caps +cramfs cytune fdformat ncurses nls pam python selinux slang static-libs +suid test tty-helpers udev unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r5
- !sys-block/eject
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- !<app-shells/bash-completion-1.3-r2
- caps? ( sys-libs/libcap-ng )
- cramfs? ( sys-libs/zlib )
- ncurses? ( >=sys-libs/ncurses-5.2-r2 )
- pam? ( sys-libs/pam )
- python? ( ${PYTHON_DEPS} )
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )
- udev? ( virtual/udev )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( sys-devel/bc )
- virtual/os-headers"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- if [[ ${PV} == 9999 ]] ; then
- po/update-potfiles
- eautoreconf
- fi
- epatch "${FILESDIR}"/${PN}-2.24-skip-last-tests.patch #491742
- find tests/ -name bigyear -delete #489794
- elibtoolize
-}
-
-lfs_fallocate_test() {
- # Make sure we can use fallocate with LFS #300307
- cat <<-EOF > "${T}"/fallocate.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
- EOF
- append-lfs-flags
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.c -o /dev/null >/dev/null 2>&1 \
- || export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.c
-}
-
-src_configure() {
- lfs_fallocate_test
- export ac_cv_header_security_pam_misc_h=$(usex pam) #485486
- econf \
- --enable-fs-paths-extra=/usr/sbin:/bin:/usr/bin \
- $(use_enable nls) \
- --enable-agetty \
- --with-bashcompletiondir="$(get_bashcompdir)" \
- $(use_enable bash-completion) \
- $(use_enable caps setpriv) \
- $(use_enable cramfs) \
- $(use_enable cytune) \
- $(use_enable fdformat) \
- --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
- --disable-kill \
- --disable-last \
- --disable-login \
- $(use_enable tty-helpers mesg) \
- --disable-nologin \
- --enable-partx \
- $(use_with python) \
- --enable-raw \
- --enable-rename \
- --disable-reset \
- --enable-schedutils \
- --disable-su \
- $(use_enable tty-helpers wall) \
- $(use_enable tty-helpers write) \
- $(use_enable suid makeinstall-chown) \
- $(use_enable suid makeinstall-setuid) \
- $(use_with selinux) \
- $(use_with slang) \
- $(use_enable static-libs static) \
- $(use_with udev) \
- $(tc-has-tls || echo --disable-tls)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
- dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}
-
- use python && python_optimize
-
- # need the libs in /
- gen_usr_ldscript -a blkid mount uuid
-
- # e2fsprogs-libs didnt install .la files, and .pc work fine
- prune_libtool_files
-}
-
-pkg_postinst() {
- if ! use tty-helpers; then
- elog "The mesg/wall/write tools have been disabled due to USE=-tty-helpers."
- fi
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "The agetty util now clears the terminal by default. You"
- elog "might want to add --noclear to your /etc/inittab lines."
- fi
-}