summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 18:54:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 18:54:05 +0000
commit82d6064f9070024f55bfe3bdce76ca244b20c7b5 (patch)
tree849a30a75dd8827f8dc55fc57ef1a36a3a42f15c /sys-apps
parentUpdate HOMEPAGE and SRC_URI, fixing bug #415609 by df <demmamussabebonk@gmail... (diff)
downloadgentoo-2-82d6064f9070024f55bfe3bdce76ca244b20c7b5.tar.gz
gentoo-2-82d6064f9070024f55bfe3bdce76ca244b20c7b5.tar.bz2
gentoo-2-82d6064f9070024f55bfe3bdce76ca244b20c7b5.zip
Bump, with no difference in database, but updated to use github.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20120512.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 609c8b321c81..e0b57f63455f 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.8 2012/05/10 05:00:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.9 2012/05/12 18:54:05 flameeyes Exp $
+
+*hwids-20120512 (12 May 2012)
+
+ 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20120512.ebuild:
+ Bump, with no difference in database, but updated to use github.
*hwids-20120507 (10 May 2012)
diff --git a/sys-apps/hwids/hwids-20120512.ebuild b/sys-apps/hwids/hwids-20120512.ebuild
new file mode 100644
index 000000000000..9b7ba3f6acc5
--- /dev/null
+++ b/sys-apps/hwids/hwids-20120512.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20120512.ebuild,v 1.1 2012/05/12 18:54:05 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="https://github.com/Flameeyes/hwids"
+SRC_URI="https://github.com/Flameeyes/hwids/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S="${WORKDIR}"
+
+src_compile() {
+ cd "${S}"/Flameeyes-hwids-*
+
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+}
+
+src_install() {
+ cd "${S}"/Flameeyes-hwids-*
+
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+
+ dodoc README.md
+}