summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-04 12:33:41 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-04 12:33:41 +0000
commit8875271d9687e56f2d1b9520c095d9cdbd6b792c (patch)
tree9be73d1aab2d2004ef47abc96a8a0fbd382da114 /sys-apps
parentRemove deprecated hal support wrt #349050. (diff)
downloadgentoo-2-8875271d9687e56f2d1b9520c095d9cdbd6b792c.tar.gz
gentoo-2-8875271d9687e56f2d1b9520c095d9cdbd6b792c.tar.bz2
gentoo-2-8875271d9687e56f2d1b9520c095d9cdbd6b792c.zip
Respect compiler and linker, remove uneeded QA_ restriction, remove redundant phase
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86+/ChangeLog10
-rw-r--r--sys-apps/memtest86+/memtest86+-4.10-r1.ebuild67
2 files changed, 75 insertions, 2 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index 8be5c5b6728a..aaa9860c3e3d 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86+
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.58 2010/06/24 01:02:15 spock Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.59 2011/01/04 12:33:41 jlec Exp $
+
+*memtest86+-4.10-r1 (04 Jan 2011)
+
+ 04 Jan 2011; Justin Lecher <jlec@gentoo.org> +memtest86+-4.10-r1.ebuild:
+ Respect compiler and linker, remove uneeded QA_ restriction, remove redundant
+ phase
*memtest86+-4.10 (24 Jun 2010)
diff --git a/sys-apps/memtest86+/memtest86+-4.10-r1.ebuild b/sys-apps/memtest86+/memtest86+-4.10-r1.ebuild
new file mode 100644
index 000000000000..9e50977009c4
--- /dev/null
+++ b/sys-apps/memtest86+/memtest86+-4.10-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-4.10-r1.ebuild,v 1.1 2011/01/04 12:33:41 jlec Exp $
+
+EAPI="3"
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="Memory tester based on memtest86"
+HOMEPAGE="http://www.memtest.org/"
+SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="floppy serial"
+
+RESTRICT="test"
+
+RDEPEND="floppy? ( >=sys-boot/grub-0.95 sys-fs/mtools )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.10-hardcoded_cc.patch
+
+ sed -i -e 's/$(LD) -s /$(LD) /' Makefile || die
+ sed -i -e 's,0x10000,0x100000,' memtest.lds || die
+
+ if use serial ; then
+ sed -i -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' config.h || die
+ fi
+
+ tc-export CC AS LD
+}
+
+src_install() {
+ insinto /boot/memtest86plus
+ newins memtest.bin memtest || die
+ newins memtest memtest.netbsd || die
+ dosym memtest /boot/memtest86plus/memtest.bin
+ dodoc README README.build-process
+
+ if use floppy ; then
+ dobin "${FILESDIR}"/make-memtest86+-boot-floppy
+ doman "${FILESDIR}"/make-memtest86+-boot-floppy.1
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "memtest has been installed in /boot/memtest86plus/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+ einfo " - For grub: (replace '?' with correct numbers for your boot partition)"
+ einfo " > title=Memtest86Plus"
+ einfo " > root (hd?,?)"
+ einfo " > kernel /boot/memtest86plus/memtest"
+ einfo " or try this if you get grub error 28:"
+ einfo " > title=Memtest86Plus"
+ einfo " > root (hd?,?)"
+ einfo " > kernel --type=netbsd /boot/memtest86plus/memtest.netbsd"
+ einfo
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86plus/memtest"
+ einfo " > label = Memtest86Plus"
+ echo
+}