summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-04-22 19:54:16 +0000
committerStefan Jones <cretin@gentoo.org>2003-04-22 19:54:16 +0000
commit8df5a728320574209e8e5d6fbacfd369d62422fe (patch)
tree7ec99655f8d98a8cb25a19e703aca426b2254a3e /sys-apps
parentfix a digest issue (diff)
downloadgentoo-2-8df5a728320574209e8e5d6fbacfd369d62422fe.tar.gz
gentoo-2-8df5a728320574209e8e5d6fbacfd369d62422fe.tar.bz2
gentoo-2-8df5a728320574209e8e5d6fbacfd369d62422fe.zip
Errno fix, Bug 19302
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gpart/ChangeLog4
-rw-r--r--sys-apps/gpart/files/gpart-0.1h-errno.diff21
-rw-r--r--sys-apps/gpart/gpart-0.1h.ebuild3
3 files changed, 27 insertions, 1 deletions
diff --git a/sys-apps/gpart/ChangeLog b/sys-apps/gpart/ChangeLog
index ab109568ae38..05935123593e 100644
--- a/sys-apps/gpart/ChangeLog
+++ b/sys-apps/gpart/ChangeLog
@@ -1,8 +1,10 @@
# ChangeLog sys-app/gpart
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/ChangeLog,v 1.2 2003/04/22 10:17:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/ChangeLog,v 1.3 2003/04/22 19:54:16 cretin Exp $
*gpart-0.1h (09 Feb 2003)
+ 22 Apr 2003; Stefan Jones <cretin@gentoo.org> gpart-0.1h.ebuild gpart-0.1h-errno.diff :
+ Added errno patch to fix compile on nwer glibc, bug #19302
15 Feb 2003: Seth Chandler <sethbc@gentoo.org> gpart-0.1h.ebuild:
added gpart to portage...
diff --git a/sys-apps/gpart/files/gpart-0.1h-errno.diff b/sys-apps/gpart/files/gpart-0.1h-errno.diff
new file mode 100644
index 000000000000..f62c523281f3
--- /dev/null
+++ b/sys-apps/gpart/files/gpart-0.1h-errno.diff
@@ -0,0 +1,21 @@
+--- gpart-0.1h/src/l64seek.c 2000-12-13 23:54:11.000000000 +0100
++++ gpart-0.1h-working/src/l64seek.c 2003-04-14 18:02:51.000000000 +0200
+@@ -15,7 +15,7 @@
+ */
+
+ #include "l64seek.h"
+-
++#include <errno.h>
+
+ #define OSTACKLEN 16
+ static struct
+--- gpart-0.1h/src/disku.c 2001-02-07 20:04:07.000000000 +0100
++++ gpart-0.1h-working/src/disku.c 2003-04-14 18:02:46.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <string.h>
+ #include <sys/ioctl.h>
+ #include "gpart.h"
++#include <errno.h>
+
+ #if defined(__linux__)
+ #include <sys/mount.h>
diff --git a/sys-apps/gpart/gpart-0.1h.ebuild b/sys-apps/gpart/gpart-0.1h.ebuild
index ac64f4c8af3a..f8cf409b9bd5 100644
--- a/sys-apps/gpart/gpart-0.1h.ebuild
+++ b/sys-apps/gpart/gpart-0.1h.ebuild
@@ -10,8 +10,11 @@ KEYWORDS="~x86"
RDEPEND="virtual/glibc"
DEPEND="${RDEPEND}"
+inherit eutils
+
src_unpack() {
unpack ${A}
+ cd ${S} ; epatch ${FILESDIR}/${P}-errno.diff
}
src_compile() {