summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 16:58:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 16:58:06 +0000
commita55016d073d91f058c0d9d5b0a7335d01ccba30b (patch)
treea812fac798c96705625d1287edb2639e84d079a5 /sys-apps
parentunmask missing amd64/x86 instruction sets (diff)
downloadgentoo-2-a55016d073d91f058c0d9d5b0a7335d01ccba30b.tar.gz
gentoo-2-a55016d073d91f058c0d9d5b0a7335d01ccba30b.tar.bz2
gentoo-2-a55016d073d91f058c0d9d5b0a7335d01ccba30b.zip
Version bump; new version now installs a library as well as the daemon, and requires some patching. New init script forces a different pidfile location and uses /run directly instead of /var/run.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/haveged/ChangeLog10
-rw-r--r--sys-apps/haveged/files/haveged-1.7-build.patch13
-rw-r--r--sys-apps/haveged/files/haveged-init.d.317
-rw-r--r--sys-apps/haveged/haveged-1.7.ebuild39
4 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/haveged/ChangeLog b/sys-apps/haveged/ChangeLog
index a0614d06e3eb..e00917518f18 100644
--- a/sys-apps/haveged/ChangeLog
+++ b/sys-apps/haveged/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/haveged
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/ChangeLog,v 1.24 2013/01/06 17:50:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/ChangeLog,v 1.25 2013/01/25 16:58:06 flameeyes Exp $
+
+*haveged-1.7 (25 Jan 2013)
+
+ 25 Jan 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/haveged-1.7-build.patch, +files/haveged-init.d.3, +haveged-1.7.ebuild:
+ Version bump; new version now installs a library as well as the daemon, and
+ requires some patching. New init script forces a different pidfile location
+ and uses /run directly instead of /var/run.
*haveged-1.6 (06 Jan 2013)
diff --git a/sys-apps/haveged/files/haveged-1.7-build.patch b/sys-apps/haveged/files/haveged-1.7-build.patch
new file mode 100644
index 000000000000..c32d1927e1f2
--- /dev/null
+++ b/sys-apps/haveged/files/haveged-1.7-build.patch
@@ -0,0 +1,13 @@
+Index: haveged-1.7/src/Makefile.am
+===================================================================
+--- haveged-1.7.orig/src/Makefile.am
++++ haveged-1.7/src/Makefile.am
+@@ -27,7 +27,7 @@ pkginclude_HEADERS = havege.h
+
+ haveged_SOURCES = haveged.c haveged.h
+
+-haveged_LDADD = @HA_LDFLAGS@ $(top_builddir)/src/libhavege.la
++haveged_LDADD = @HA_LDFLAGS@ libhavege.la
+ ##libtool_end##
+
+ MAINTAINERCLEANFILES = Makefile.in
diff --git a/sys-apps/haveged/files/haveged-init.d.3 b/sys-apps/haveged/files/haveged-init.d.3
new file mode 100644
index 000000000000..d43447d118f3
--- /dev/null
+++ b/sys-apps/haveged/files/haveged-init.d.3
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/files/haveged-init.d.3,v 1.1 2013/01/25 16:58:06 flameeyes Exp $
+
+pidfile=/run/${SVCNAME}.pid
+
+command="/usr/sbin/${SVCNAME}"
+command_args="-r 0 ${HAVEGED_OPTS} -p ${pidfile}"
+
+depend() {
+ need localmount
+ use logger
+ provide entropy
+}
+
+# vim:ft=gentoo-init-d:
diff --git a/sys-apps/haveged/haveged-1.7.ebuild b/sys-apps/haveged/haveged-1.7.ebuild
new file mode 100644
index 000000000000..3ce91f020d42
--- /dev/null
+++ b/sys-apps/haveged/haveged-1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/haveged-1.7.ebuild,v 1.1 2013/01/25 16:58:06 flameeyes Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
+HOMEPAGE="http://www.issihosts.com/haveged/"
+SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/openrc-0.11.8"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --bindir=/usr/sbin --enable-nistest \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ rm -rf "${D}"/usr/lib*/*.la
+
+ # Install gentoo ones instead
+ newinitd "${FILESDIR}"/haveged-init.d.3 haveged
+ newconfd "${FILESDIR}"/haveged-conf.d haveged
+}