summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-26 23:13:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-26 23:13:24 +0000
commita9250ff363f85f63f6c39229ac6fc99b1718a451 (patch)
tree39dfbb9448eb427c04e919833ff2f4f226a5a4aa /sys-apps
parentclosed bug #61251, added some dep., added possibility to compile tinylogic st... (diff)
downloadgentoo-2-a9250ff363f85f63f6c39229ac6fc99b1718a451.tar.gz
gentoo-2-a9250ff363f85f63f6c39229ac6fc99b1718a451.tar.bz2
gentoo-2-a9250ff363f85f63f6c39229ac6fc99b1718a451.zip
Add patch to fix display on 64bit systems.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/procps/ChangeLog8
-rw-r--r--sys-apps/procps/files/3.2.4-64bit-display.patch34
-rw-r--r--sys-apps/procps/files/digest-procps-3.2.4-r2 (renamed from sys-apps/procps/files/digest-procps-3.2.4-r1)0
-rw-r--r--sys-apps/procps/procps-3.2.4-r2.ebuild (renamed from sys-apps/procps/procps-3.2.4-r1.ebuild)6
4 files changed, 45 insertions, 3 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index fd2886016b3a..dc4912ac73f3 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/procps
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.98 2005/01/18 05:43:42 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.99 2005/01/26 23:13:24 vapier Exp $
+
+*procps-3.2.4-r2 (26 Jan 2005)
+
+ 26 Jan 2005; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to fix display on 64bit systems. Also make sure we dont
+ pointlessly run ldconfig.
18 Jan 2005; Joshua Kinard <kumba@gentoo.org> procps-3.2.4-r1.ebuild:
Marked stable on mips.
diff --git a/sys-apps/procps/files/3.2.4-64bit-display.patch b/sys-apps/procps/files/3.2.4-64bit-display.patch
new file mode 100644
index 000000000000..aca21f6de8f5
--- /dev/null
+++ b/sys-apps/procps/files/3.2.4-64bit-display.patch
@@ -0,0 +1,34 @@
+Index: proc/escape.c
+===================================================================
+RCS file: /cvsroot/procps/procps/proc/escape.c,v
+retrieving revision 1.5
+retrieving revision 1.6
+diff -u -r1.5 -r1.6
+--- proc/escape.c 4 Nov 2004 20:50:59 -0000 1.5
++++ proc/escape.c 5 Jan 2005 21:11:21 -0000 1.6
+@@ -159,7 +159,7 @@
+ // escape an argv or environment string array
+ //
+ // bytes arg means sizeof(buf)
+-int escape_strlist(char *restrict dst, const char *restrict const *restrict src, size_t bytes, size_t *cells){
++int escape_strlist(char *restrict dst, const char *restrict const *restrict src, size_t bytes, int *cells){
+ size_t i = 0;
+
+ for(;;){
+Index: proc/escape.h
+===================================================================
+RCS file: /cvsroot/procps/procps/proc/escape.h,v
+retrieving revision 1.4
+retrieving revision 1.5
+diff -u -r1.4 -r1.5
+--- proc/escape.h 4 Nov 2004 20:50:59 -0000 1.4
++++ proc/escape.h 5 Jan 2005 21:11:21 -0000 1.5
+@@ -12,7 +12,7 @@
+ #define ESC_BRACKETS 0x2 // if using cmd, put '[' and ']' around it
+ #define ESC_DEFUNCT 0x4 // mark zombies with " <defunct>"
+
+-extern int escape_strlist(char *restrict dst, const char *restrict const *restrict src, size_t n, size_t *cells);
++extern int escape_strlist(char *restrict dst, const char *restrict const *restrict src, size_t n, int *cells);
+ extern int escape_str(char *restrict dst, const char *restrict src, int bufsize, int *maxcells);
+ extern int escape_command(char *restrict const outbuf, const proc_t *restrict const pp, int bytes, int *cells, unsigned flags);
+
diff --git a/sys-apps/procps/files/digest-procps-3.2.4-r1 b/sys-apps/procps/files/digest-procps-3.2.4-r2
index 2bf5f1226db4..2bf5f1226db4 100644
--- a/sys-apps/procps/files/digest-procps-3.2.4-r1
+++ b/sys-apps/procps/files/digest-procps-3.2.4-r2
diff --git a/sys-apps/procps/procps-3.2.4-r1.ebuild b/sys-apps/procps/procps-3.2.4-r2.ebuild
index ea013de61a7b..5d1a777cbe1a 100644
--- a/sys-apps/procps/procps-3.2.4-r1.ebuild
+++ b/sys-apps/procps/procps-3.2.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.2.4-r1.ebuild,v 1.2 2005/01/18 05:43:42 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.2.4-r2.ebuild,v 1.1 2005/01/26 23:13:24 vapier Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -21,6 +21,8 @@ src_unpack() {
# Upstream patch to support newer linux #77301
epatch "${FILESDIR}"/${PV}-linux26-slab.patch
+ # Upstream patch to fix display on 64bit systems
+ epatch "${FILESDIR}"/${PV}-64bit-display.patch
# Clean up the makefile
# firstly we want to control stripping
@@ -50,7 +52,7 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die "install failed"
+ make install ldconfig="true" DESTDIR="${D}" || die "install failed"
insinto /usr/include/proc
doins proc/*.h || die "doins include"