summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-30 11:50:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-30 11:50:44 +0000
commitadc40982ff1259330a61c396f96ee03e79729c30 (patch)
treefe5cccc8e90d3a863728c2355351a7c3a2c3e316 /sys-apps
parentCleanup (diff)
downloadgentoo-2-adc40982ff1259330a61c396f96ee03e79729c30.tar.gz
gentoo-2-adc40982ff1259330a61c396f96ee03e79729c30.tar.bz2
gentoo-2-adc40982ff1259330a61c396f96ee03e79729c30.zip
Update
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/findutils-4.1-r5.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/findutils/findutils-4.1-r5.ebuild b/sys-apps/findutils/findutils-4.1-r5.ebuild
new file mode 100644
index 000000000000..baa12db694db
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1-r5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1-r5.ebuild,v 1.1 2001/04/30 11:50:44 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU utilities to find files"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/findutils/${A}
+ ftp://prep.ai.mit.edu/gnu/findutils/${A}"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ echo "Applying Patch..."
+ #using sed to apply minor patches to files
+ cd ${S}
+
+ cd find
+ cp fstype.c fstype.c.orig
+ sed -e "33d" -e "34d" fstype.c.orig > fstype.c
+ cp parser.c parser.c.orig
+ sed -e "55d" parser.c.orig > parser.c
+ cp pred.c pred.c.orig
+ sed -e '29i\' -e '#define FNM_CASEFOLD (1<<4)' pred.c.orig > pred.c
+ cd ${S}/lib
+ cp nextelem.c nextelem.c.orig
+ sed -e "35d" nextelem.c.orig > nextelem.c
+ cd ${S}/xargs
+ cp xargs.c xargs.c.orig
+ sed -e "63d" -e "64d" xargs.c.orig > xargs.c
+}
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+
+ # do not use pmake recursive
+
+ if [ -z "`use static`" ]
+ then
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS
+ else
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info libexecdir=${D}/usr/lib/find \
+ LOCATE_DB=${D}/var/lib/misc/locatedb install
+ dosed "s:TMPDIR=/usr/tmp:TMPDIR=/tmp:" usr/bin/updatedb
+
+ rm -fr ${D}/usr/var
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -fr ${D}/usr/share/man ${D}/usr/share/info
+ fi
+
+}
+