summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-01-12 14:54:54 +0000
committerMarinus Schraal <foser@gentoo.org>2005-01-12 14:54:54 +0000
commitb58c2d9a7c2219c32ef781e052479a79ed8a7036 (patch)
tree06bc6015f3c35cc67d4d628662e416bf7ce72123 /sys-apps
parentVersion bump. Previous patches were included. Maintainer crypto added to meta... (diff)
downloadgentoo-2-b58c2d9a7c2219c32ef781e052479a79ed8a7036.tar.gz
gentoo-2-b58c2d9a7c2219c32ef781e052479a79ed8a7036.tar.bz2
gentoo-2-b58c2d9a7c2219c32ef781e052479a79ed8a7036.zip
update patch & fix src_uri in 0.4.2
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog8
-rw-r--r--sys-apps/hal/files/hal-0.4.4-iso_label.patch37
-rw-r--r--sys-apps/hal/files/hal-0.4.4-iso_label_selection.patch48
-rw-r--r--sys-apps/hal/hal-0.4.2-r1.ebuild4
-rw-r--r--sys-apps/hal/hal-0.4.4-r1.ebuild4
5 files changed, 59 insertions, 42 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 71b1a0f7088d..8780d69a9e2b 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.22 2005/01/11 23:58:03 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.23 2005/01/12 14:54:54 foser Exp $
+
+ 12 Jan 2005; foser <foser@gentoo.org> hal-0.4.4-r1.ebuild :
+ Change the iso label patch for a somewhat cleaner one
+
+ 12 Jan 2005; foser <foser@gentoo.org> hal-0.4.2-r1.ebuild :
+ Fix SRC_URI (#77478) thnx to Gudleik Rasch for noticing
11 Jan 2005; John Mylchreest <johnm@gentoo.org> hal-0.2.98-r1.ebuild,
hal-0.4.1-r1.ebuild, hal-0.4.2-r1.ebuild, hal-0.4.4-r1.ebuild:
diff --git a/sys-apps/hal/files/hal-0.4.4-iso_label.patch b/sys-apps/hal/files/hal-0.4.4-iso_label.patch
deleted file mode 100644
index 027bd6d86af9..000000000000
--- a/sys-apps/hal/files/hal-0.4.4-iso_label.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- hal-0.4.4/hald/linux/volume_id/volume_id.c 2005-01-07 04:25:58.000000000 +0100
-+++ hal-0.4.4.patched/hald/linux/volume_id/volume_id.c 2005-01-09 19:26:22.000000000 +0100
-@@ -1239,15 +1239,20 @@
- } __attribute__((__packed__)) hs;
- } __attribute__((__packed__)) *is;
-
-+ char vd_primary_label[32];
-+
- is = (union iso_super_block *)
- get_buffer(id, off + ISO_SUPERBLOCK_OFFSET, 0x200);
- if (is == NULL)
- return -1;
-
-+ memcpy (vd_primary_label, is->iso.volume_id, 32);
-+
- if (strncmp(is->iso.id, "CD001", 5) == 0) {
- int vd_offset;
-- int i;
-+ int i, j;
- __u8 found_svd;
-+ char tmp_label[32];
-
- found_svd = 0;
- vd_offset = ISO_VD_OFFSET;
-@@ -1264,7 +1269,11 @@
- vd_offset += ISO_SECTOR_SIZE;
- }
-
-- if (!found_svd) {
-+ j = 0;
-+ for (i = 0; i+2 <= 32; i+=2)
-+ tmp_label[j++] = is->iso.volume_id[i+1];
-+
-+ if (!found_svd || !strncmp(tmp_label, vd_primary_label, 16)) {
- is = (union iso_super_block *)
- get_buffer(id, off + ISO_SUPERBLOCK_OFFSET, 0x200);
- if (is == NULL)
diff --git a/sys-apps/hal/files/hal-0.4.4-iso_label_selection.patch b/sys-apps/hal/files/hal-0.4.4-iso_label_selection.patch
new file mode 100644
index 000000000000..42204c396dd1
--- /dev/null
+++ b/sys-apps/hal/files/hal-0.4.4-iso_label_selection.patch
@@ -0,0 +1,48 @@
+diff -uNr hal-0.4.4.orig/hald/linux/volume_id/volume_id.c hal-0.4.4/hald/linux/volume_id/volume_id.c
+--- hal-0.4.4.orig/hald/linux/volume_id/volume_id.c 2005-01-07 16:25:58.000000000 +1300
++++ hal-0.4.4/hald/linux/volume_id/volume_id.c 2005-01-12 13:19:06.930597976 +1300
+@@ -1245,10 +1245,14 @@
+ return -1;
+
+ if (strncmp(is->iso.id, "CD001", 5) == 0) {
++ char root_label[VOLUME_ID_LABEL_SIZE+1];
+ int vd_offset;
+ int i;
+ __u8 found_svd;
+
++ memset(root_label, 0, sizeof(root_label));
++ strncpy(root_label, is->iso.volume_id, sizeof(root_label)-1);
++
+ found_svd = 0;
+ vd_offset = ISO_VD_OFFSET;
+ for (i = 0; i < ISO_VD_MAX; i++) {
+@@ -1258,22 +1262,19 @@
+ break;
+ if (is->iso.type == ISO_VD_SUPPLEMENTARY) {
+ dbg("found ISO supplementary VD at offset 0x%x", off + vd_offset);
++ set_label_raw(id, is->iso.volume_id, 32);
++ set_label_unicode16(id, is->iso.volume_id, BE, 32);
+ found_svd = 1;
+ break;
+ }
+ vd_offset += ISO_SECTOR_SIZE;
+ }
+
+- if (!found_svd) {
+- is = (union iso_super_block *)
+- get_buffer(id, off + ISO_SUPERBLOCK_OFFSET, 0x200);
+- if (is == NULL)
+- return -1;
+- set_label_raw(id, is->iso.volume_id, 32);
+- set_label_string(id, is->iso.volume_id, 32);
+- } else {
+- set_label_raw(id, is->iso.volume_id, 32);
+- set_label_unicode16(id, is->iso.volume_id, BE, 32);
++ if (!found_svd ||
++ (found_svd && !strncmp(root_label, id->label, 16)))
++ {
++ set_label_raw(id, root_label, 32);
++ set_label_string(id, root_label, 32);
+ }
+ goto found;
+ }
diff --git a/sys-apps/hal/hal-0.4.2-r1.ebuild b/sys-apps/hal/hal-0.4.2-r1.ebuild
index 752d49676842..f4ff29a90e1e 100644
--- a/sys-apps/hal/hal-0.4.2-r1.ebuild
+++ b/sys-apps/hal/hal-0.4.2-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.2-r1.ebuild,v 1.4 2005/01/12 14:22:15 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.2-r1.ebuild,v 1.5 2005/01/12 14:54:54 foser Exp $
inherit eutils python
DESCRIPTION="Hardware Abstraction Layer"
HOMEPAGE="http://www.freedesktop.org/Software/hal"
-SRC_URI="http://freedesktop.org/~david/${P}.tar.gz"
+SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.0 )"
SLOT="0"
diff --git a/sys-apps/hal/hal-0.4.4-r1.ebuild b/sys-apps/hal/hal-0.4.4-r1.ebuild
index cd314720e16f..7c15759cbe97 100644
--- a/sys-apps/hal/hal-0.4.4-r1.ebuild
+++ b/sys-apps/hal/hal-0.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.4-r1.ebuild,v 1.3 2005/01/12 14:22:15 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.4-r1.ebuild,v 1.4 2005/01/12 14:54:54 foser Exp $
inherit eutils python
@@ -41,7 +41,7 @@ src_unpack() {
# support IDE zip drives as floppy
epatch ${FILESDIR}/${P}-check_ide_floppy_for_zip_fdi.patch
# fix joliet label (#77140)
- epatch ${FILESDIR}/${P}-iso_label.patch
+ epatch ${FILESDIR}/${P}-iso_label_selection.patch
# fix fat on large volumes
epatch ${FILESDIR}/${P}-volume_id_fat.patch