summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-22 12:06:18 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-22 12:06:18 +0000
commitbc42c9317361919695e0d79441dc5de4ff31e7c9 (patch)
tree71af12bdebb78e8c1ba36c459cb66b62848ef2a1 /sys-apps
parentAdded to ~ppc (diff)
downloadgentoo-2-bc42c9317361919695e0d79441dc5de4ff31e7c9.tar.gz
gentoo-2-bc42c9317361919695e0d79441dc5de4ff31e7c9.tar.bz2
gentoo-2-bc42c9317361919695e0d79441dc5de4ff31e7c9.zip
Properly install 32bit sandbox on amd64 2004.3
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-2.0.51-r10.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51-r11.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51-r12.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51-r13.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51-r14.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51-r15.ebuild4
-rw-r--r--sys-apps/portage/portage-2.0.51.16.ebuild4
7 files changed, 14 insertions, 14 deletions
diff --git a/sys-apps/portage/portage-2.0.51-r10.ebuild b/sys-apps/portage/portage-2.0.51-r10.ebuild
index 459bdf83518b..a241643c29e7 100644
--- a/sys-apps/portage/portage-2.0.51-r10.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.9 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.10 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -148,7 +148,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51-r11.ebuild b/sys-apps/portage/portage-2.0.51-r11.ebuild
index 5644f9fe4d16..5847ffe27eb5 100644
--- a/sys-apps/portage/portage-2.0.51-r11.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.6 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.7 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -148,7 +148,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51-r12.ebuild b/sys-apps/portage/portage-2.0.51-r12.ebuild
index 36bc941a4432..40499cbf79da 100644
--- a/sys-apps/portage/portage-2.0.51-r12.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.6 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.7 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -148,7 +148,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51-r13.ebuild b/sys-apps/portage/portage-2.0.51-r13.ebuild
index 2d799aff1ab9..b55b85930a04 100644
--- a/sys-apps/portage/portage-2.0.51-r13.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r13.ebuild,v 1.4 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r13.ebuild,v 1.5 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -148,7 +148,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51-r14.ebuild b/sys-apps/portage/portage-2.0.51-r14.ebuild
index 5084d8062dec..5a7311f17a11 100644
--- a/sys-apps/portage/portage-2.0.51-r14.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r14.ebuild,v 1.5 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r14.ebuild,v 1.6 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -180,7 +180,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51-r15.ebuild b/sys-apps/portage/portage-2.0.51-r15.ebuild
index 37389d78c420..87bbe88f64d4 100644
--- a/sys-apps/portage/portage-2.0.51-r15.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r15.ebuild,v 1.4 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r15.ebuild,v 1.5 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -150,7 +150,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"
diff --git a/sys-apps/portage/portage-2.0.51.16.ebuild b/sys-apps/portage/portage-2.0.51.16.ebuild
index 8024be1c4665..573238c04e84 100644
--- a/sys-apps/portage/portage-2.0.51.16.ebuild
+++ b/sys-apps/portage/portage-2.0.51.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51.16.ebuild,v 1.2 2005/02/18 11:43:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51.16.ebuild,v 1.3 2005/02/22 12:06:18 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -154,7 +154,7 @@ src_install() {
doins sandbox.bashrc
ABI="${OABI}"
- elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
+ elif [ "${ARCH}" == "amd64" ] && ! has_multilib_profile; then
check_multilib
make DESTDIR="${D}" HAVE_64BIT_ARCH="${MULTILIB}" install || \
die "Failed to install sandbox"