summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-10-06 20:56:08 +0000
committerZac Medico <zmedico@gentoo.org>2009-10-06 20:56:08 +0000
commitbc53d33c76e0ed0220b8c9ac14419f19ed7a7596 (patch)
tree0f064e56a31c7b787e367f125e0bcbeaf21bc5c3 /sys-apps
parent06 Oct 2009; Zac Medico <zmedico@gentoo.org> portage-2.2_rc44.ebuild: (diff)
downloadgentoo-2-bc53d33c76e0ed0220b8c9ac14419f19ed7a7596.tar.gz
gentoo-2-bc53d33c76e0ed0220b8c9ac14419f19ed7a7596.tar.bz2
gentoo-2-bc53d33c76e0ed0220b8c9ac14419f19ed7a7596.zip
Remove unnecessary ebuilds.
(Portage version: 2.2_rc44/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog6
-rw-r--r--sys-apps/portage/portage-2.2_rc39.ebuild326
-rw-r--r--sys-apps/portage/portage-2.2_rc40.ebuild326
-rw-r--r--sys-apps/portage/portage-2.2_rc43.ebuild338
4 files changed, 5 insertions, 991 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 29556abc9db3..ec66e6efcccc 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.636 2009/10/06 20:53:39 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.637 2009/10/06 20:56:08 zmedico Exp $
+
+ 06 Oct 2009; Zac Medico <zmedico@gentoo.org> -portage-2.2_rc39.ebuild,
+ -portage-2.2_rc40.ebuild, -portage-2.2_rc43.ebuild:
+ Remove unnecessary ebuilds.
06 Oct 2009; Zac Medico <zmedico@gentoo.org> portage-2.2_rc44.ebuild:
Optimize python deps in order to avoid pulling in python3 when possible.
diff --git a/sys-apps/portage/portage-2.2_rc39.ebuild b/sys-apps/portage/portage-2.2_rc39.ebuild
deleted file mode 100644
index 2025ff17e18f..000000000000
--- a/sys-apps/portage/portage-2.2_rc39.ebuild
+++ /dev/null
@@ -1,326 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2_rc39.ebuild,v 1.2 2009/09/29 06:08:43 ulm Exp $
-
-inherit eutils multilib python
-
-DESCRIPTION="Portage is the package management and distribution system for Gentoo"
-HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-PROVIDE="virtual/portage"
-SLOT="0"
-IUSE="build doc epydoc selinux linguas_pl"
-
-python_dep=">=dev-lang/python-2.5 <dev-lang/python-3.0"
-
-DEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5 )
- doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
- epydoc? ( >=dev-python/epydoc-2.0 )"
-RDEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5
- >=app-shells/bash-3.2_p17
- >=app-admin/eselect-1.2 )
- elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
- elibc_glibc? ( >=sys-apps/sandbox-1.6 )
- elibc_uclibc? ( >=sys-apps/sandbox-1.6 )
- >=app-misc/pax-utils-0.1.17
- selinux? ( sys-libs/libselinux )"
-PDEPEND="
- !build? (
- >=net-misc/rsync-2.6.4
- userland_GNU? ( >=sys-apps/coreutils-6.4 )
- )"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# rsync-2.6.4 rdep is for the --filter option #167668
-
-SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
-
-prefix_src_archives() {
- local x y
- for x in ${@}; do
- for y in ${SRC_ARCHIVES}; do
- echo ${y}/${x}
- done
- done
-}
-
-PV_PL="2.1.2"
-PATCHVER_PL=""
-TARBALL_PV=2.2_rc35
-SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
- $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)
- linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
- $(prefix_src_archives ${PN}-man-pl-${PV_PL}.tar.bz2) )"
-
-PATCHVER=$PV
-if [ -n "${PATCHVER}" ]; then
- SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PATCHVER}.patch.bz2
- $(prefix_src_archives ${PN}-${PATCHVER}.patch.bz2)"
-fi
-
-S="${WORKDIR}"/${PN}-${TARBALL_PV}
-S_PL="${WORKDIR}"/${PN}-${PV_PL}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [ -n "${PATCHVER}" ]; then
- cd "${S}"
- epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
- fi
- einfo "Setting portage.VERSION to ${PVR} ..."
- sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage/__init__.py || \
- die "Failed to patch portage.VERSION"
-}
-
-src_compile() {
-
- if use doc; then
- cd "${S}"/doc
- touch fragment/date
- make xhtml xhtml-nochunks || die "failed to make docs"
- fi
-
- if use epydoc; then
- einfo "Generating api docs"
- mkdir "${WORKDIR}"/api
- local my_modules epydoc_opts=""
- # A name collision between the portage.dbapi class and the
- # module with the same name triggers an epydoc crash unless
- # portage.dbapi is excluded from introspection.
- ROOT=/ has_version '>=dev-python/epydoc-3_pre0' && \
- epydoc_opts='--exclude-introspect portage\.dbapi'
- my_modules="$(find "${S}/pym" -name "*.py" \
- | sed -e 's:/__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
- -e 's:/:.:g' | sort)" || die "error listing modules"
- PYTHONPATH="${S}/pym:${PYTHONPATH}" epydoc -o "${WORKDIR}"/api \
- -qqqqq --no-frames --show-imports $epydoc_opts \
- --name "${PN}" --url "${HOMEPAGE}" \
- ${my_modules} || die "epydoc failed"
- fi
-}
-
-src_test() {
- ./pym/portage/tests/runTests || \
- die "test(s) failed"
-}
-
-src_install() {
- local libdir=$(get_libdir)
- local portage_base="/usr/${libdir}/portage"
- local portage_share_config=/usr/share/portage/config
-
- cd "${S}"/cnf
- insinto /etc
- doins etc-update.conf dispatch-conf.conf
-
- dodir "${portage_share_config}"
- insinto "${portage_share_config}"
- doins "${S}/cnf/"{sets.conf,make.globals}
- if [ -f "make.conf.${ARCH}".diff ]; then
- patch make.conf "make.conf.${ARCH}".diff || \
- die "Failed to patch make.conf.example"
- newins make.conf make.conf.example
- else
- eerror ""
- eerror "Portage does not have an arch-specific configuration for this arch."
- eerror "Please notify the arch maintainer about this issue. Using generic."
- eerror ""
- newins make.conf make.conf.example
- fi
-
- dosym ..${portage_share_config}/make.globals /etc/make.globals
-
- insinto /etc/logrotate.d
- doins "${S}"/cnf/logrotate.d/elog-save-summary
-
- # BSD and OSX need a sed wrapper so that find/xargs work properly
- if use userland_GNU; then
- rm "${S}"/bin/ebuild-helpers/sed || die "Failed to remove sed wrapper"
- fi
-
- local x symlinks
- for x in $(find "$S"/bin -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- exeinto $portage_base/$x || die "exeinto failed"
- cd "$S"/$x || die "cd failed"
- doexe $(find . -mindepth 1 -maxdepth 1 -type f ! -type l) || \
- die "doexe failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- for x in $(find "$S"/pym -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- insinto $portage_base/$x || die "insinto failed"
- cd "$S"/$x || die "cd failed"
- doins *.py || die "doins failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- # Symlinks to directories cause up/downgrade issues and the use of these
- # modules outside of portage is probably negligible.
- for x in "${D}${portage_base}/pym/"{cache,elog_modules} ; do
- [ ! -L "${x}" ] && continue
- die "symlink to directory will cause upgrade/downgrade issues: '${x}'"
- done
-
- exeinto ${portage_base}/pym/portage/tests
- doexe "${S}"/pym/portage/tests/runTests
-
- doman "${S}"/man/*.[0-9]
- if use linguas_pl; then
- doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
- doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
- fi
-
- dodoc "${S}"/{ChangeLog,NEWS,RELEASE-NOTES}
- use doc && dohtml -r "${S}"/doc/*
- use epydoc && dohtml -r "${WORKDIR}"/api
-
- dodir /usr/bin
- for x in ebuild egencache emerge portageq repoman ; do
- dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
- done
-
- dodir /usr/sbin
- local my_syms="archive-conf
- dispatch-conf
- emaint
- emerge-webrsync
- env-update
- etc-update
- fixpackages
- quickpkg
- regenworld"
- local x
- for x in ${my_syms}; do
- dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
- done
- dosym env-update /usr/sbin/update-env
- dosym etc-update /usr/sbin/update-etc
-
- dodir /etc/portage
- keepdir /etc/portage
-}
-
-pkg_preinst() {
- if ! use build && ! has_version dev-python/pycrypto && \
- has_version '>=dev-lang/python-2.5' ; then
- if ! built_with_use '>=dev-lang/python-2.5' ssl ; then
- ewarn "If you are an ebuild developer and you plan to commit ebuilds"
- ewarn "with this system then please install dev-python/pycrypto or"
- ewarn "enable the ssl USE flag for >=dev-lang/python-2.5 in order"
- ewarn "to enable RMD160 hash support."
- ewarn "See bug #198398 for more information."
- fi
- fi
- if [ -f "${ROOT}/etc/make.globals" ]; then
- rm "${ROOT}/etc/make.globals"
- fi
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- MINOR_UPGRADE=$?
-
- has_version "<=${CATEGORY}/${PN}-2.2_pre5"
- WORLD_MIGRATION_UPGRADE=$?
-
- # If portage-2.1.6 is installed and the preserved_libs_registry exists,
- # assume that the NEEDED.ELF.2 files have already been generated.
- has_version "<=${CATEGORY}/${PN}-2.2_pre7" && \
- ! ( [ -e "$ROOT"var/lib/portage/preserved_libs_registry ] && \
- has_version ">=${CATEGORY}/${PN}-2.1.6_rc" )
- NEEDED_REBUILD_UPGRADE=$?
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- ADD_SYSTEM_TO_WORLD=$?
-
- if [ $ADD_SYSTEM_TO_WORLD != 0 -a "$ROOT" != / ] && \
- ! has_version "${CATEGORY}/${PN}" ; then
- # building stage 1
- ADD_SYSTEM_TO_WORLD=0
- fi
-
- [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
- REPO_LAYOUT_CONF_WARN=$?
-}
-
-pkg_postinst() {
- # Compile all source files recursively. Any orphans
- # will be identified and removed in postrm.
- python_mod_optimize /usr/$(get_libdir)/portage/pym
-
- if [ $ADD_SYSTEM_TO_WORLD = 0 ] && \
- [ ! -e "$ROOT"var/lib/portage/world_sets ] ; then
- einfo "adding @system to world_sets for backward compatibility"
- echo @system > "$ROOT"var/lib/portage/world_sets
- fi
-
- if [ $WORLD_MIGRATION_UPGRADE = 0 ] ; then
- einfo "moving set references from the worldfile into world_sets"
- cd "${ROOT}/var/lib/portage/"
- grep "^@" world >> world_sets
- sed -i -e '/^@/d' world
- fi
-
- if [ $NEEDED_REBUILD_UPGRADE = 0 ] ; then
- einfo "rebuilding NEEDED.ELF.2 files"
- for cpv in "${ROOT}/var/db/pkg"/*/*; do
- if [ -f "${cpv}/NEEDED" ]; then
- rm -f "${cpv}/NEEDED.ELF.2"
- while read line; do
- filename=${line% *}
- needed=${line#* }
- needed=${needed//+/++}
- needed=${needed//#/##}
- needed=${needed//%/%%}
- newline=$(scanelf -BF "%a;%F;%S;%r;${needed}" $filename)
- newline=${newline// - }
- echo "${newline:3}" >> "${cpv}/NEEDED.ELF.2"
- done < "${cpv}/NEEDED"
- fi
- done
- fi
-
- if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
- ewarn
- echo "If you want overlay eclasses to override eclasses from" \
- "other repos then see the portage(5) man page" \
- "for information about the new layout.conf and repos.conf" \
- "configuration files." \
- | fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
- ewarn
- fi
-
- einfo
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo
-
- if [ $MINOR_UPGRADE = 0 ] ; then
- elog "If you're upgrading from a pre-2.2 version of portage you might"
- elog "want to remerge world (emerge -e world) to take full advantage"
- elog "of some of the new features in 2.2."
- elog "This is not required however for portage to function properly."
- elog
- fi
-
- if [ -z "${PV/*_rc*}" ]; then
- elog "If you always want to use the latest development version of portage"
- elog "please read http://www.gentoo.org/proj/en/portage/doc/testing.xml"
- elog
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/portage/pym
-}
diff --git a/sys-apps/portage/portage-2.2_rc40.ebuild b/sys-apps/portage/portage-2.2_rc40.ebuild
deleted file mode 100644
index 8b7f8acbbfc1..000000000000
--- a/sys-apps/portage/portage-2.2_rc40.ebuild
+++ /dev/null
@@ -1,326 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2_rc40.ebuild,v 1.2 2009/09/29 06:08:43 ulm Exp $
-
-inherit eutils multilib python
-
-DESCRIPTION="Portage is the package management and distribution system for Gentoo"
-HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-PROVIDE="virtual/portage"
-SLOT="0"
-IUSE="build doc epydoc selinux linguas_pl"
-
-python_dep=">=dev-lang/python-2.5 <dev-lang/python-3.0"
-
-DEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5 )
- doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
- epydoc? ( >=dev-python/epydoc-2.0 )"
-RDEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5
- >=app-shells/bash-3.2_p17
- >=app-admin/eselect-1.2 )
- elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
- elibc_glibc? ( >=sys-apps/sandbox-1.6 )
- elibc_uclibc? ( >=sys-apps/sandbox-1.6 )
- >=app-misc/pax-utils-0.1.17
- selinux? ( sys-libs/libselinux )"
-PDEPEND="
- !build? (
- >=net-misc/rsync-2.6.4
- userland_GNU? ( >=sys-apps/coreutils-6.4 )
- )"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# rsync-2.6.4 rdep is for the --filter option #167668
-
-SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
-
-prefix_src_archives() {
- local x y
- for x in ${@}; do
- for y in ${SRC_ARCHIVES}; do
- echo ${y}/${x}
- done
- done
-}
-
-PV_PL="2.1.2"
-PATCHVER_PL=""
-TARBALL_PV=2.2_rc35
-SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
- $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)
- linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
- $(prefix_src_archives ${PN}-man-pl-${PV_PL}.tar.bz2) )"
-
-PATCHVER=$PV
-if [ -n "${PATCHVER}" ]; then
- SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PATCHVER}.patch.bz2
- $(prefix_src_archives ${PN}-${PATCHVER}.patch.bz2)"
-fi
-
-S="${WORKDIR}"/${PN}-${TARBALL_PV}
-S_PL="${WORKDIR}"/${PN}-${PV_PL}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [ -n "${PATCHVER}" ]; then
- cd "${S}"
- epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
- fi
- einfo "Setting portage.VERSION to ${PVR} ..."
- sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage/__init__.py || \
- die "Failed to patch portage.VERSION"
-}
-
-src_compile() {
-
- if use doc; then
- cd "${S}"/doc
- touch fragment/date
- make xhtml xhtml-nochunks || die "failed to make docs"
- fi
-
- if use epydoc; then
- einfo "Generating api docs"
- mkdir "${WORKDIR}"/api
- local my_modules epydoc_opts=""
- # A name collision between the portage.dbapi class and the
- # module with the same name triggers an epydoc crash unless
- # portage.dbapi is excluded from introspection.
- ROOT=/ has_version '>=dev-python/epydoc-3_pre0' && \
- epydoc_opts='--exclude-introspect portage\.dbapi'
- my_modules="$(find "${S}/pym" -name "*.py" \
- | sed -e 's:/__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
- -e 's:/:.:g' | sort)" || die "error listing modules"
- PYTHONPATH="${S}/pym:${PYTHONPATH}" epydoc -o "${WORKDIR}"/api \
- -qqqqq --no-frames --show-imports $epydoc_opts \
- --name "${PN}" --url "${HOMEPAGE}" \
- ${my_modules} || die "epydoc failed"
- fi
-}
-
-src_test() {
- ./pym/portage/tests/runTests || \
- die "test(s) failed"
-}
-
-src_install() {
- local libdir=$(get_libdir)
- local portage_base="/usr/${libdir}/portage"
- local portage_share_config=/usr/share/portage/config
-
- cd "${S}"/cnf
- insinto /etc
- doins etc-update.conf dispatch-conf.conf
-
- dodir "${portage_share_config}"
- insinto "${portage_share_config}"
- doins "${S}/cnf/"{sets.conf,make.globals}
- if [ -f "make.conf.${ARCH}".diff ]; then
- patch make.conf "make.conf.${ARCH}".diff || \
- die "Failed to patch make.conf.example"
- newins make.conf make.conf.example
- else
- eerror ""
- eerror "Portage does not have an arch-specific configuration for this arch."
- eerror "Please notify the arch maintainer about this issue. Using generic."
- eerror ""
- newins make.conf make.conf.example
- fi
-
- dosym ..${portage_share_config}/make.globals /etc/make.globals
-
- insinto /etc/logrotate.d
- doins "${S}"/cnf/logrotate.d/elog-save-summary
-
- # BSD and OSX need a sed wrapper so that find/xargs work properly
- if use userland_GNU; then
- rm "${S}"/bin/ebuild-helpers/sed || die "Failed to remove sed wrapper"
- fi
-
- local x symlinks
- for x in $(find "$S"/bin -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- exeinto $portage_base/$x || die "exeinto failed"
- cd "$S"/$x || die "cd failed"
- doexe $(find . -mindepth 1 -maxdepth 1 -type f ! -type l) || \
- die "doexe failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- for x in $(find "$S"/pym -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- insinto $portage_base/$x || die "insinto failed"
- cd "$S"/$x || die "cd failed"
- doins *.py || die "doins failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- # Symlinks to directories cause up/downgrade issues and the use of these
- # modules outside of portage is probably negligible.
- for x in "${D}${portage_base}/pym/"{cache,elog_modules} ; do
- [ ! -L "${x}" ] && continue
- die "symlink to directory will cause upgrade/downgrade issues: '${x}'"
- done
-
- exeinto ${portage_base}/pym/portage/tests
- doexe "${S}"/pym/portage/tests/runTests
-
- doman "${S}"/man/*.[0-9]
- if use linguas_pl; then
- doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
- doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
- fi
-
- dodoc "${S}"/{ChangeLog,NEWS,RELEASE-NOTES}
- use doc && dohtml -r "${S}"/doc/*
- use epydoc && dohtml -r "${WORKDIR}"/api
-
- dodir /usr/bin
- for x in ebuild egencache emerge portageq repoman ; do
- dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
- done
-
- dodir /usr/sbin
- local my_syms="archive-conf
- dispatch-conf
- emaint
- emerge-webrsync
- env-update
- etc-update
- fixpackages
- quickpkg
- regenworld"
- local x
- for x in ${my_syms}; do
- dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
- done
- dosym env-update /usr/sbin/update-env
- dosym etc-update /usr/sbin/update-etc
-
- dodir /etc/portage
- keepdir /etc/portage
-}
-
-pkg_preinst() {
- if ! use build && ! has_version dev-python/pycrypto && \
- has_version '>=dev-lang/python-2.5' ; then
- if ! built_with_use '>=dev-lang/python-2.5' ssl ; then
- ewarn "If you are an ebuild developer and you plan to commit ebuilds"
- ewarn "with this system then please install dev-python/pycrypto or"
- ewarn "enable the ssl USE flag for >=dev-lang/python-2.5 in order"
- ewarn "to enable RMD160 hash support."
- ewarn "See bug #198398 for more information."
- fi
- fi
- if [ -f "${ROOT}/etc/make.globals" ]; then
- rm "${ROOT}/etc/make.globals"
- fi
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- MINOR_UPGRADE=$?
-
- has_version "<=${CATEGORY}/${PN}-2.2_pre5"
- WORLD_MIGRATION_UPGRADE=$?
-
- # If portage-2.1.6 is installed and the preserved_libs_registry exists,
- # assume that the NEEDED.ELF.2 files have already been generated.
- has_version "<=${CATEGORY}/${PN}-2.2_pre7" && \
- ! ( [ -e "$ROOT"var/lib/portage/preserved_libs_registry ] && \
- has_version ">=${CATEGORY}/${PN}-2.1.6_rc" )
- NEEDED_REBUILD_UPGRADE=$?
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- ADD_SYSTEM_TO_WORLD=$?
-
- if [ $ADD_SYSTEM_TO_WORLD != 0 -a "$ROOT" != / ] && \
- ! has_version "${CATEGORY}/${PN}" ; then
- # building stage 1
- ADD_SYSTEM_TO_WORLD=0
- fi
-
- [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
- REPO_LAYOUT_CONF_WARN=$?
-}
-
-pkg_postinst() {
- # Compile all source files recursively. Any orphans
- # will be identified and removed in postrm.
- python_mod_optimize /usr/$(get_libdir)/portage/pym
-
- if [ $ADD_SYSTEM_TO_WORLD = 0 ] && \
- [ ! -e "$ROOT"var/lib/portage/world_sets ] ; then
- einfo "adding @system to world_sets for backward compatibility"
- echo @system > "$ROOT"var/lib/portage/world_sets
- fi
-
- if [ $WORLD_MIGRATION_UPGRADE = 0 ] ; then
- einfo "moving set references from the worldfile into world_sets"
- cd "${ROOT}/var/lib/portage/"
- grep "^@" world >> world_sets
- sed -i -e '/^@/d' world
- fi
-
- if [ $NEEDED_REBUILD_UPGRADE = 0 ] ; then
- einfo "rebuilding NEEDED.ELF.2 files"
- for cpv in "${ROOT}/var/db/pkg"/*/*; do
- if [ -f "${cpv}/NEEDED" ]; then
- rm -f "${cpv}/NEEDED.ELF.2"
- while read line; do
- filename=${line% *}
- needed=${line#* }
- needed=${needed//+/++}
- needed=${needed//#/##}
- needed=${needed//%/%%}
- newline=$(scanelf -BF "%a;%F;%S;%r;${needed}" $filename)
- newline=${newline// - }
- echo "${newline:3}" >> "${cpv}/NEEDED.ELF.2"
- done < "${cpv}/NEEDED"
- fi
- done
- fi
-
- if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
- ewarn
- echo "If you want overlay eclasses to override eclasses from" \
- "other repos then see the portage(5) man page" \
- "for information about the new layout.conf and repos.conf" \
- "configuration files." \
- | fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
- ewarn
- fi
-
- einfo
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo
-
- if [ $MINOR_UPGRADE = 0 ] ; then
- elog "If you're upgrading from a pre-2.2 version of portage you might"
- elog "want to remerge world (emerge -e world) to take full advantage"
- elog "of some of the new features in 2.2."
- elog "This is not required however for portage to function properly."
- elog
- fi
-
- if [ -z "${PV/*_rc*}" ]; then
- elog "If you always want to use the latest development version of portage"
- elog "please read http://www.gentoo.org/proj/en/portage/doc/testing.xml"
- elog
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/portage/pym
-}
diff --git a/sys-apps/portage/portage-2.2_rc43.ebuild b/sys-apps/portage/portage-2.2_rc43.ebuild
deleted file mode 100644
index 0cf9a478e04a..000000000000
--- a/sys-apps/portage/portage-2.2_rc43.ebuild
+++ /dev/null
@@ -1,338 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2_rc43.ebuild,v 1.1 2009/10/04 00:14:52 zmedico Exp $
-
-# Require EAPI 2 since we now require at least python-2.6 (for python 3
-# syntax support) which also requires EAPI 2.
-EAPI=2
-inherit eutils multilib python
-
-DESCRIPTION="Portage is the package management and distribution system for Gentoo"
-HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-PROVIDE="virtual/portage"
-SLOT="0"
-IUSE="build doc epydoc linguas_pl python3 selinux"
-
-python_dep="python3? ( =dev-lang/python-3* )
- !python3? ( >=dev-lang/python-2.6 )"
-
-# the pysqlite blocker is for bug #282760
-DEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5 )
- doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
- epydoc? ( >=dev-python/epydoc-2.0 !<=dev-python/pysqlite-2.4.1 )"
-RDEPEND="${python_dep}
- !build? ( >=sys-apps/sed-4.0.5
- >=app-shells/bash-3.2_p17
- >=app-admin/eselect-1.2 )
- elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
- elibc_glibc? ( >=sys-apps/sandbox-1.6 )
- elibc_uclibc? ( >=sys-apps/sandbox-1.6 )
- >=app-misc/pax-utils-0.1.17
- selinux? ( sys-libs/libselinux )"
-PDEPEND="
- !build? (
- >=net-misc/rsync-2.6.4
- userland_GNU? ( >=sys-apps/coreutils-6.4 )
- )"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# rsync-2.6.4 rdep is for the --filter option #167668
-
-SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
-
-prefix_src_archives() {
- local x y
- for x in ${@}; do
- for y in ${SRC_ARCHIVES}; do
- echo ${y}/${x}
- done
- done
-}
-
-PV_PL="2.1.2"
-PATCHVER_PL=""
-TARBALL_PV=2.2_rc43
-SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
- $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)
- linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
- $(prefix_src_archives ${PN}-man-pl-${PV_PL}.tar.bz2) )"
-
-PATCHVER=
-if [ -n "${PATCHVER}" ]; then
- SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PATCHVER}.patch.bz2
- $(prefix_src_archives ${PN}-${PATCHVER}.patch.bz2)"
-fi
-
-S="${WORKDIR}"/${PN}-${TARBALL_PV}
-S_PL="${WORKDIR}"/${PN}-${PV_PL}
-
-pkg_setup() {
- if [[ $(python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x2060000 and "good" or "bad")') != good ]] ; then
- die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see \`eselect python --help\`)."
- fi
-}
-
-src_prepare() {
- if [ -n "${PATCHVER}" ] ; then
- epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
- fi
- einfo "Setting portage.VERSION to ${PVR} ..."
- sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage/__init__.py || \
- die "Failed to patch portage.VERSION"
-
- if use python3; then
- sed -e '1s/\(^#!.*\)python\(.*$\)/\1python3\2/' -i $(find -perm /111 -type f) || die "Conversion of shebangs failed"
- fi
-}
-
-src_compile() {
- if use doc; then
- cd "${S}"/doc
- touch fragment/date
- make xhtml xhtml-nochunks || die "failed to make docs"
- fi
-
- if use epydoc; then
- einfo "Generating api docs"
- mkdir "${WORKDIR}"/api
- local my_modules epydoc_opts=""
- # A name collision between the portage.dbapi class and the
- # module with the same name triggers an epydoc crash unless
- # portage.dbapi is excluded from introspection.
- ROOT=/ has_version '>=dev-python/epydoc-3_pre0' && \
- epydoc_opts='--exclude-introspect portage\.dbapi'
- my_modules="$(find "${S}/pym" -name "*.py" \
- | sed -e 's:/__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
- -e 's:/:.:g' | sort)" || die "error listing modules"
- PYTHONPATH=${S}/pym:${PYTHONPATH:+:}${PYTHONPATH} \
- epydoc -o "${WORKDIR}"/api \
- -qqqqq --no-frames --show-imports $epydoc_opts \
- --name "${PN}" --url "${HOMEPAGE}" \
- ${my_modules} || die "epydoc failed"
- fi
-}
-
-src_test() {
- PYTHONPATH=${S}/pym:${PYTHONPATH:+:}${PYTHONPATH} \
- ./pym/portage/tests/runTests || die "test(s) failed"
-}
-
-src_install() {
- local libdir=$(get_libdir)
- local portage_base="/usr/${libdir}/portage"
- local portage_share_config=/usr/share/portage/config
-
- cd "${S}"/cnf
- insinto /etc
- doins etc-update.conf dispatch-conf.conf
-
- dodir "${portage_share_config}"
- insinto "${portage_share_config}"
- doins "${S}/cnf/"{sets.conf,make.globals}
- if [ -f "make.conf.${ARCH}".diff ]; then
- patch make.conf "make.conf.${ARCH}".diff || \
- die "Failed to patch make.conf.example"
- newins make.conf make.conf.example
- else
- eerror ""
- eerror "Portage does not have an arch-specific configuration for this arch."
- eerror "Please notify the arch maintainer about this issue. Using generic."
- eerror ""
- newins make.conf make.conf.example
- fi
-
- dosym ..${portage_share_config}/make.globals /etc/make.globals
-
- insinto /etc/logrotate.d
- doins "${S}"/cnf/logrotate.d/elog-save-summary
-
- # BSD and OSX need a sed wrapper so that find/xargs work properly
- if use userland_GNU; then
- rm "${S}"/bin/ebuild-helpers/sed || die "Failed to remove sed wrapper"
- fi
-
- local x symlinks
- for x in $(find "$S"/bin -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- exeinto $portage_base/$x || die "exeinto failed"
- cd "$S"/$x || die "cd failed"
- doexe $(find . -mindepth 1 -maxdepth 1 -type f ! -type l) || \
- die "doexe failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- for x in $(find "$S"/pym -type d) ; do
- x=${x#$S/}
- dodir $portage_base/$x || die "dodir failed"
- insinto $portage_base/$x || die "insinto failed"
- cd "$S"/$x || die "cd failed"
- doins *.py || die "doins failed"
- symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
- if [ -n "$symlinks" ] ; then
- cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
- fi
- done
-
- # Symlinks to directories cause up/downgrade issues and the use of these
- # modules outside of portage is probably negligible.
- for x in "${D}${portage_base}/pym/"{cache,elog_modules} ; do
- [ ! -L "${x}" ] && continue
- die "symlink to directory will cause upgrade/downgrade issues: '${x}'"
- done
-
- exeinto ${portage_base}/pym/portage/tests
- doexe "${S}"/pym/portage/tests/runTests
-
- doman "${S}"/man/*.[0-9]
- if use linguas_pl; then
- doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
- doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
- fi
-
- dodoc "${S}"/{ChangeLog,NEWS,RELEASE-NOTES}
- use doc && dohtml -r "${S}"/doc/*
- use epydoc && dohtml -r "${WORKDIR}"/api
-
- dodir /usr/bin
- for x in ebuild egencache emerge portageq repoman ; do
- dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
- done
-
- dodir /usr/sbin
- local my_syms="archive-conf
- dispatch-conf
- emaint
- emerge-webrsync
- env-update
- etc-update
- fixpackages
- quickpkg
- regenworld"
- local x
- for x in ${my_syms}; do
- dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
- done
- dosym env-update /usr/sbin/update-env
- dosym etc-update /usr/sbin/update-etc
-
- dodir /etc/portage
- keepdir /etc/portage
-}
-
-pkg_preinst() {
- if ! use build && ! has_version dev-python/pycrypto && \
- has_version '>=dev-lang/python-2.5' ; then
- if ! built_with_use '>=dev-lang/python-2.5' ssl ; then
- ewarn "If you are an ebuild developer and you plan to commit ebuilds"
- ewarn "with this system then please install dev-python/pycrypto or"
- ewarn "enable the ssl USE flag for >=dev-lang/python-2.5 in order"
- ewarn "to enable RMD160 hash support."
- ewarn "See bug #198398 for more information."
- fi
- fi
- if [ -f "${ROOT}/etc/make.globals" ]; then
- rm "${ROOT}/etc/make.globals"
- fi
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- MINOR_UPGRADE=$?
-
- has_version "<=${CATEGORY}/${PN}-2.2_pre5"
- WORLD_MIGRATION_UPGRADE=$?
-
- # If portage-2.1.6 is installed and the preserved_libs_registry exists,
- # assume that the NEEDED.ELF.2 files have already been generated.
- has_version "<=${CATEGORY}/${PN}-2.2_pre7" && \
- ! ( [ -e "$ROOT"var/lib/portage/preserved_libs_registry ] && \
- has_version ">=${CATEGORY}/${PN}-2.1.6_rc" )
- NEEDED_REBUILD_UPGRADE=$?
-
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- ADD_SYSTEM_TO_WORLD=$?
-
- if [ $ADD_SYSTEM_TO_WORLD != 0 -a "$ROOT" != / ] && \
- ! has_version "${CATEGORY}/${PN}" ; then
- # building stage 1
- ADD_SYSTEM_TO_WORLD=0
- fi
-
- [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
- REPO_LAYOUT_CONF_WARN=$?
-}
-
-pkg_postinst() {
- # Compile all source files recursively. Any orphans
- # will be identified and removed in postrm.
- python_mod_optimize /usr/$(get_libdir)/portage/pym
-
- if [ $ADD_SYSTEM_TO_WORLD = 0 ] && \
- [ ! -e "$ROOT"var/lib/portage/world_sets ] ; then
- einfo "adding @system to world_sets for backward compatibility"
- echo @system > "$ROOT"var/lib/portage/world_sets
- fi
-
- if [ $WORLD_MIGRATION_UPGRADE = 0 ] ; then
- einfo "moving set references from the worldfile into world_sets"
- cd "${ROOT}/var/lib/portage/"
- grep "^@" world >> world_sets
- sed -i -e '/^@/d' world
- fi
-
- if [ $NEEDED_REBUILD_UPGRADE = 0 ] ; then
- einfo "rebuilding NEEDED.ELF.2 files"
- for cpv in "${ROOT}/var/db/pkg"/*/*; do
- if [ -f "${cpv}/NEEDED" ]; then
- rm -f "${cpv}/NEEDED.ELF.2"
- while read line; do
- filename=${line% *}
- needed=${line#* }
- needed=${needed//+/++}
- needed=${needed//#/##}
- needed=${needed//%/%%}
- newline=$(scanelf -BF "%a;%F;%S;%r;${needed}" $filename)
- newline=${newline// - }
- echo "${newline:3}" >> "${cpv}/NEEDED.ELF.2"
- done < "${cpv}/NEEDED"
- fi
- done
- fi
-
- if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
- ewarn
- echo "If you want overlay eclasses to override eclasses from" \
- "other repos then see the portage(5) man page" \
- "for information about the new layout.conf and repos.conf" \
- "configuration files." \
- | fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
- ewarn
- fi
-
- einfo
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo
-
- if [ $MINOR_UPGRADE = 0 ] ; then
- elog "If you're upgrading from a pre-2.2 version of portage you might"
- elog "want to remerge world (emerge -e world) to take full advantage"
- elog "of some of the new features in 2.2."
- elog "This is not required however for portage to function properly."
- elog
- fi
-
- if [ -z "${PV/*_rc*}" ]; then
- elog "If you always want to use the latest development version of portage"
- elog "please read http://www.gentoo.org/proj/en/portage/doc/testing.xml"
- elog
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/portage/pym
-}