summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-17 04:06:21 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-17 04:06:21 +0000
commitc5ca684810396dc4952459308d79c8e25b173123 (patch)
tree49b611fe87ce6cd5da92fce567295567bee6abdf /sys-apps
parentInitial commit of jimtcl package. Required for newer openocd packages. Thanks... (diff)
downloadgentoo-2-c5ca684810396dc4952459308d79c8e25b173123.tar.gz
gentoo-2-c5ca684810396dc4952459308d79c8e25b173123.tar.bz2
gentoo-2-c5ca684810396dc4952459308d79c8e25b173123.zip
Add warning for users with buggy btrfs setups #353907 by Zac Medico.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog5
-rw-r--r--sys-apps/coreutils/coreutils-8.10.ebuild13
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index e9f9bb92d677..bc38786ae819 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.320 2011/02/19 21:50:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.321 2011/03/17 04:06:21 vapier Exp $
+
+ 17 Mar 2011; Mike Frysinger <vapier@gentoo.org> coreutils-8.10.ebuild:
+ Add warning for users with buggy btrfs setups #353907 by Zac Medico.
19 Feb 2011; Mike Frysinger <vapier@gentoo.org> coreutils-8.10.ebuild:
Add patch from upstream for sandbox/git misbehavior #355045 by Kyle Milz.
diff --git a/sys-apps/coreutils/coreutils-8.10.ebuild b/sys-apps/coreutils/coreutils-8.10.ebuild
index 0929c37ea8b6..192343e7373f 100644
--- a/sys-apps/coreutils/coreutils-8.10.ebuild
+++ b/sys-apps/coreutils/coreutils-8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-8.10.ebuild,v 1.2 2011/02/19 21:50:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-8.10.ebuild,v 1.3 2011/03/17 04:06:21 vapier Exp $
EAPI="3"
@@ -150,4 +150,15 @@ pkg_postinst() {
rm -f "${ROOT}/bin/dircolors"
fi
fi
+
+ # Help out users using experimental filesystems
+ if grep -qs btrfs "${ROOT}"/etc/fstab /proc/mounts ; then
+ case $(uname -r) in
+ 2.6.[12][0-9]|2.6.3[0-7]*)
+ ewarn "You are running a system with a buggy btrfs driver."
+ ewarn "Please upgrade your kernel to avoid silent corruption."
+ ewarn "See: https://bugs.gentoo.org/353907"
+ ;;
+ esac
+ fi
}