summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-06 23:30:43 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-06 23:30:43 +0000
commitc75487baa1404fd8aeaf9fc514f48879bc0897a0 (patch)
treee8bd80946bf4c95d4bd5e264ea27989c01b8fac1 /sys-apps
parentUnmask calligra-2.3.84 (released now) (diff)
downloadgentoo-2-c75487baa1404fd8aeaf9fc514f48879bc0897a0.tar.gz
gentoo-2-c75487baa1404fd8aeaf9fc514f48879bc0897a0.tar.bz2
gentoo-2-c75487baa1404fd8aeaf9fc514f48879bc0897a0.zip
Add patch from upstream which allows us to mount nfs shares w/out needing libtirpc or C library RPC symbols #379481 by Andriy Baranskyy.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog9
-rw-r--r--sys-apps/busybox/busybox-1.19.3-r1.ebuild283
-rw-r--r--sys-apps/busybox/files/busybox-1.19.3-kernel-nfs.patch121
3 files changed, 412 insertions, 1 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 1b74cca36c40..78ca0ae9e64f 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.287 2011/11/07 00:08:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.288 2011/12/06 23:30:43 vapier Exp $
+
+*busybox-1.19.3-r1 (06 Dec 2011)
+
+ 06 Dec 2011; Mike Frysinger <vapier@gentoo.org> +busybox-1.19.3-r1.ebuild,
+ +files/busybox-1.19.3-kernel-nfs.patch:
+ Add patch from upstream which allows us to mount nfs shares w/out needing
+ libtirpc or C library RPC symbols #379481 by Andriy Baranskyy.
*busybox-1.19.3 (07 Nov 2011)
diff --git a/sys-apps/busybox/busybox-1.19.3-r1.ebuild b/sys-apps/busybox/busybox-1.19.3-r1.ebuild
new file mode 100644
index 000000000000..4e5a5eaf11d0
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.19.3-r1.ebuild
@@ -0,0 +1,283 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.19.3-r1.ebuild,v 1.1 2011/12/06 23:30:43 vapier Exp $
+
+EAPI="3"
+inherit eutils flag-o-matic savedconfig toolchain-funcs
+
+################################################################################
+# BUSYBOX ALTERNATE CONFIG MINI-HOWTO
+#
+# Busybox can be modified in many different ways. Here's a few ways to do it:
+#
+# (1) Emerge busybox with FEATURES=keepwork so the work directory won't
+# get erased afterwards. Add a definition like ROOT=/my/root/path to the
+# start of the line if you're installing to somewhere else than the root
+# directory. This command will save the default configuration to
+# ${PORTAGE_CONFIGROOT} (or ${ROOT} if ${PORTAGE_CONFIGROOT} is not
+# defined), and it will tell you that it has done this. Note the location
+# where the config file was saved.
+#
+# FEATURES=keepwork USE=savedconfig emerge busybox
+#
+# (2) Go to the work directory and change the configuration of busybox using its
+# menuconfig feature.
+#
+# cd /var/tmp/portage/busybox*/work/busybox-*
+# make menuconfig
+#
+# (3) Save your configuration to the default location and copy it to the
+# one of the locations listed in /usr/portage/eclass/savedconfig.eclass
+#
+# (4) Emerge busybox with USE=savedconfig to use the configuration file you
+# just generated.
+#
+################################################################################
+#
+# (1) Alternatively skip the above steps and simply emerge busybox without
+# USE=savedconfig.
+#
+# (2) Edit the file it saves by hand. ${ROOT}"/etc/portage/savedconfig/${CATEGORY}/${PF}
+#
+# (3) Remerge busybox as using USE=savedconfig.
+#
+################################################################################
+
+#SNAPSHOT=20040726
+SNAPSHOT=""
+
+DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
+if [[ -n ${SNAPSHOT} ]] ; then
+ MY_P=${PN}
+ SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
+else
+ MY_P=${PN}-${PV/_/-}
+ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="ipv6 make-symlinks +mdev -pam selinux static elibc_glibc"
+RESTRICT="test"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( sys-libs/pam )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+busybox_config_option() {
+ case $1 in
+ y) sed -i -e "s:.*\<CONFIG_$2\>.*set:${new}:g" .config;;
+ n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
+ *) use $1 \
+ && busybox_config_option y $2 \
+ || busybox_config_option n $2
+ return 0
+ ;;
+ esac
+ einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
+}
+
+src_prepare() {
+ unset KBUILD_OUTPUT #88088
+ append-flags -fno-strict-aliasing #310413
+ use ppc64 && append-flags -mminimal-toc #130943
+
+ # patches go here!
+ epatch "${FILESDIR}"/busybox-1.19.0-bb.patch
+ epatch "${FILESDIR}"/busybox-${PV}-*.patch
+
+ # flag cleanup
+ sed -i -r \
+ -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
+ Makefile.flags || die
+ #sed -i '/bbsh/s:^//::' include/applets.h
+ sed -i '/^#error Aborting compilation./d' applets/applets.c || die
+ use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
+ sed -i \
+ -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
+ -e "/^AR\>/s:=.*:= $(tc-getAR):" \
+ -e "/^CC\>/s:=.*:= $(tc-getCC):" \
+ -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ Makefile || die
+ sed -i \
+ -e 's:-static-libgcc::' \
+ Makefile.flags || die
+}
+
+src_configure() {
+ # check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
+
+ restore_config .config
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ ewarn "Could not locate user configfile, so we will save a default one"
+ fi
+
+ # setup the config file
+ emake -j1 allyesconfig > /dev/null
+ # nommu forces a bunch of things off which we want on #387555
+ busybox_config_option n NOMMU
+ sed -i '/^#/d' .config
+ yes "" | emake -j1 oldconfig >/dev/null
+
+ # now turn off stuff we really don't want
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+ busybox_config_option n BUILD_AT_ONCE
+ busybox_config_option n BUILD_LIBBUSYBOX
+ busybox_config_option n MONOTONIC_SYSCALL
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y ASH
+ busybox_config_option n HUSH
+
+ # disable ipv6 applets
+ if ! use ipv6; then
+ busybox_config_option n FEATURE_IPV6
+ busybox_config_option n TRACEROUTE6
+ busybox_config_option n PING6
+ fi
+
+ if use static && use pam ; then
+ ewarn "You cannot have USE='static pam'. Assuming static is more important."
+ fi
+ use static \
+ && busybox_config_option n PAM \
+ || busybox_config_option pam PAM
+ busybox_config_option static STATIC
+
+ # all the debug options are compiler related, so punt them
+ busybox_config_option n DEBUG
+ busybox_config_option y NO_DEBUG_LIB
+ busybox_config_option n DMALLOC
+ busybox_config_option n EFENCE
+
+ busybox_config_option selinux SELINUX
+
+ # this opt only controls mounting with <linux-2.6.23
+ busybox_config_option n FEATURE_MOUNT_NFS
+
+ # default a bunch of uncommon options to off
+ local opt
+ for opt in \
+ ADD_SHELL \
+ BEEP BOOTCHARTD \
+ CRONTAB \
+ DC DEVFSD DNSD DPKG{,_DEB} \
+ FAKEIDENTD FBSPLASH FOLD FSCK_MINIX FTP{GET,PUT} \
+ FEATURE_DEVFS \
+ HOSTID HUSH \
+ INETD INOTIFYD IPCALC \
+ LASH LOCALE_SUPPORT LOGNAME LPD \
+ MAKEMIME MKFS_MINIX MSH \
+ OD \
+ RDEV READPROFILE REFORMIME REMOVE_SHELL RFKILL RUN_PARTS RUNSV{,DIR} \
+ SLATTACH SMEMCAP SULOGIN SV{,LOGD} \
+ TASKSET TCPSVD \
+ RPM RPM2CPIO \
+ UDPSVD UUDECODE UUENCODE
+ do
+ busybox_config_option n ${opt}
+ done
+
+ emake -j1 oldconfig > /dev/null
+}
+
+src_compile() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
+ emake V=1 busybox || die
+ if ! use static ; then
+ cp .config{,.bak}
+ mv busybox_unstripped{,.bak}
+ use pam && busybox_config_option n PAM
+ emake CONFIG_STATIC=y busybox || die
+ mv busybox_unstripped bb
+ mv busybox_unstripped{.bak,}
+ mv .config{.bak,}
+ fi
+}
+
+src_install() {
+ unset KBUILD_OUTPUT #88088
+ save_config .config
+
+ into /
+ newbin busybox_unstripped busybox || die
+ if use static ; then
+ dosym busybox /bin/bb || die
+ dosym bb /bin/busybox.static || die
+ else
+ dobin bb || die
+ fi
+ if use mdev ; then
+ dodir /$(get_libdir)/mdev/
+ use make-symlinks || dosym /bin/bb /sbin/mdev
+ cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf
+
+ exeinto /$(get_libdir)/mdev/
+ doexe "${FILESDIR}"/mdev/* || die
+
+ newinitd "${FILESDIR}"/mdev.rc.1 mdev || die
+ fi
+
+ # bundle up the symlink files for use later
+ emake DESTDIR="${ED}" install || die
+ rm _install/bin/busybox
+ tar cf busybox-links.tar -C _install . || : #;die
+ insinto /usr/share/${PN}
+ doins busybox-links.tar || die
+ newins .config ${PF}.config || die
+
+ dodoc AUTHORS README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab depmod.pl *.conf *.script undeb unrpm
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ dodoc $(find . -type f)
+}
+
+pkg_preinst() {
+ if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is really what you want."
+ die "silly options will destroy your system"
+ fi
+
+ if use make-symlinks ; then
+ mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use make-symlinks ; then
+ cd "${T}" || die
+ mkdir _install
+ tar xf busybox-links.tar -C _install || die
+ cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ fi
+
+ elog "This ebuild has support for user defined configs"
+ elog "Please read this ebuild for more details and re-emerge as needed"
+ elog "if you want to add or remove functionality for ${PN}"
+}
diff --git a/sys-apps/busybox/files/busybox-1.19.3-kernel-nfs.patch b/sys-apps/busybox/files/busybox-1.19.3-kernel-nfs.patch
new file mode 100644
index 000000000000..708940086833
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.19.3-kernel-nfs.patch
@@ -0,0 +1,121 @@
+From a86e02492d7700ce8cb4108f53646dfb025c2dff Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Thu, 10 Nov 2011 16:53:35 +0100
+Subject: [PATCH] mount: make FEATURE_MOUNT_NFS not needed for Linux 2.6.23+
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ util-linux/Config.src | 11 ++++++++---
+ util-linux/mount.c | 47 +++++++++++++++++++++++++++++++++++++++++------
+ 2 files changed, 49 insertions(+), 9 deletions(-)
+
+diff --git a/util-linux/Config.src b/util-linux/Config.src
+index 888bc8f..57a52ce 100644
+--- a/util-linux/Config.src
++++ b/util-linux/Config.src
+@@ -485,13 +485,18 @@ config FEATURE_MOUNT_LABEL
+ This also enables label or uuid support for swapon.
+
+ config FEATURE_MOUNT_NFS
+- bool "Support mounting NFS file systems"
+- default y
++ bool "Support mounting NFS file systems on Linux < 2.6.23"
++ default n
+ depends on MOUNT
+ select FEATURE_HAVE_RPC
+ select FEATURE_SYSLOG
+ help
+- Enable mounting of NFS file systems.
++ Enable mounting of NFS file systems on Linux kernels prior
++ to version 2.6.23. Note that in this case mounting of NFS
++ over IPv6 will not be possible.
++
++ Note that this option links in RPC support from libc,
++ which is rather large (~10 kbytes on uclibc).
+
+ config FEATURE_MOUNT_CIFS
+ bool "Support mounting CIFS/SMB file systems"
+diff --git a/util-linux/mount.c b/util-linux/mount.c
+index 1dd4c0c..7ae1981 100644
+--- a/util-linux/mount.c
++++ b/util-linux/mount.c
+@@ -1144,7 +1144,7 @@ static NOINLINE int nfsmount(struct mntent *mp, long vfsflags, char *filteropts)
+ pathname = s + 1;
+ *s = '\0';
+ /* Ignore all but first hostname in replicated mounts
+- until they can be fully supported. (mack@sgi.com) */
++ * until they can be fully supported. (mack@sgi.com) */
+ s = strchr(hostname, ',');
+ if (s) {
+ *s = '\0';
+@@ -1683,7 +1683,6 @@ static NOINLINE int nfsmount(struct mntent *mp, long vfsflags, char *filteropts)
+
+ /* Perform actual mount */
+ do_mount:
+- mp->mnt_type = (char*)"nfs";
+ retval = mount_it_now(mp, vfsflags, (char*)&data);
+ goto ret;
+
+@@ -1708,8 +1707,43 @@ static NOINLINE int nfsmount(struct mntent *mp, long vfsflags, char *filteropts)
+
+ #else // !ENABLE_FEATURE_MOUNT_NFS
+
+-// Never called. Call should be optimized out.
+-int nfsmount(struct mntent *mp, long vfsflags, char *filteropts);
++/* Linux 2.6.23+ supports nfs mounts with options passed as a string.
++ * For older kernels, you must build busybox with ENABLE_FEATURE_MOUNT_NFS.
++ * (However, note that then you lose any chances that NFS over IPv6 would work).
++ */
++static int nfsmount(struct mntent *mp, long vfsflags, char *filteropts)
++{
++ len_and_sockaddr *lsa;
++ char *opts;
++ char *end;
++ char *dotted;
++ int ret;
++
++# if ENABLE_FEATURE_IPV6
++ end = strchr(mp->mnt_fsname, ']');
++ if (end && end[1] == ':')
++ end++;
++ else
++# endif
++ /* mount_main() guarantees that ':' is there */
++ end = strchr(mp->mnt_fsname, ':');
++
++ *end = '\0';
++ lsa = xdotted2sockaddr(mp->mnt_fsname, /*port:*/ 0);
++ *end = ':';
++ dotted = xmalloc_sockaddr2dotted_noport(&lsa->u.sa);
++ if (ENABLE_FEATURE_CLEAN_UP) free(lsa);
++ opts = xasprintf("%s%saddr=%s",
++ filteropts ? filteropts : "",
++ filteropts ? "," : "",
++ dotted
++ );
++ if (ENABLE_FEATURE_CLEAN_UP) free(dotted);
++ ret = mount_it_now(mp, vfsflags, opts);
++ if (ENABLE_FEATURE_CLEAN_UP) free(opts);
++
++ return ret;
++}
+
+ #endif // !ENABLE_FEATURE_MOUNT_NFS
+
+@@ -1800,10 +1834,11 @@ static int singlemount(struct mntent *mp, int ignore_busy)
+ }
+
+ // Might this be an NFS filesystem?
+- if (ENABLE_FEATURE_MOUNT_NFS
+- && (!mp->mnt_type || strcmp(mp->mnt_type, "nfs") == 0)
++ if ((!mp->mnt_type || strncmp(mp->mnt_type, "nfs", 3) == 0)
+ && strchr(mp->mnt_fsname, ':') != NULL
+ ) {
++ if (!mp->mnt_type)
++ mp->mnt_type = (char*)"nfs";
+ rc = nfsmount(mp, vfsflags, filteropts);
+ goto report_error;
+ }
+--
+1.7.6.1
+