summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-20 09:32:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-20 09:32:42 +0000
commitcdb53810a27b4a676838461336ddaa50e3eb0637 (patch)
tree726bb46d4d45e4c37da4af38ab660a5e7b3080aa /sys-apps
parentConvert from modprobe install to softdep wrt #396147 by Gustavo Sverzut Barbieri (diff)
downloadgentoo-2-cdb53810a27b4a676838461336ddaa50e3eb0637.tar.gz
gentoo-2-cdb53810a27b4a676838461336ddaa50e3eb0637.tar.bz2
gentoo-2-cdb53810a27b4a676838461336ddaa50e3eb0637.zip
Convert from modprobe install to softdep wrt #396147 by Gustavo Sverzut Barbieri
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/module-init-tools/ChangeLog9
-rw-r--r--sys-apps/module-init-tools/module-init-tools-3.16-r2.ebuild101
2 files changed, 109 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index 91f1fb3fac6f..509af9c67b8e 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.183 2012/02/04 00:33:38 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.184 2012/10/20 09:32:42 ssuominen Exp $
+
+*module-init-tools-3.16-r2 (20 Oct 2012)
+
+ 20 Oct 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +module-init-tools-3.16-r2.ebuild:
+ Convert from modprobe install to softdep wrt #396147 by Gustavo Sverzut
+ Barbieri
04 Feb 2012; William Hubbs <williamh@gentoo.org>
module-init-tools-3.16-r1.ebuild:
diff --git a/sys-apps/module-init-tools/module-init-tools-3.16-r2.ebuild b/sys-apps/module-init-tools/module-init-tools-3.16-r2.ebuild
new file mode 100644
index 000000000000..8d65c53190aa
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-3.16-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-3.16-r2.ebuild,v 1.1 2012/10/20 09:32:42 ssuominen Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="tools for managing linux kernel modules"
+HOMEPAGE="http://modules.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/utils/kernel/module-init-tools/${P}.tar.bz2
+ mirror://gentoo/${P}-man.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+RESTRICT="test"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}
+ !<sys-apps/baselayout-2.0.1
+ !sys-apps/kmod
+ !sys-apps/modutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ touch *.5 *.8 # dont regen manpages
+}
+
+src_compile() {
+ mkdir build && cd build #290207
+ use static && append-ldflags -static
+ ECONF_SOURCE=.. \
+ econf \
+ --prefix=/ \
+ --enable-zlib \
+ --enable-zlib-dynamic \
+ --disable-static-utils
+ emake || die
+}
+
+src_test() {
+ # this manually runs configure and stuff, so ignore it
+ ./tests/runtests -v || die
+}
+
+src_install() {
+ emake -C build install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ into /
+ newsbin "${FILESDIR}"/update-modules-3.5.sh update-modules || die
+ doman "${FILESDIR}"/update-modules.8 || die
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ softdep uhci_hcd pre: ehci_hcd
+ softdep ohci_hcd pre: ehci_hcd
+ EOF
+
+ insinto /etc/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf || die #260139
+}
+
+pkg_postinst() {
+ # cheat to keep users happy
+ if grep -qs modules-update "${ROOT}"/etc/init.d/modules ; then
+ sed -i 's:modules-update:update-modules:' "${ROOT}"/etc/init.d/modules
+ fi
+
+ # For files that were upgraded but not renamed via their ebuild to
+ # have a proper .conf extension, rename them so etc-update tools can
+ # take care of things. #274942
+ local i f cfg
+ eshopts_push -s nullglob
+ for f in "${ROOT}"etc/modprobe.d/* ; do
+ # The .conf files need no upgrading unless a non-.conf exists,
+ # so skip this until later ...
+ [[ ${f} == *.conf ]] && continue
+ # If a .conf doesn't exist, then a package needs updating, or
+ # the user created it, or it's orphaned. Either way, we don't
+ # really know, so leave it alone.
+ [[ ! -f ${f}.conf ]] && continue
+
+ i=0
+ while :; do
+ cfg=$(printf "%s/._cfg%04d_%s.conf" "${f%/*}" ${i} "${f##*/}")
+ [[ ! -e ${cfg} ]] && break
+ ((i++))
+ done
+ elog "Updating ${f}; please run 'etc-update'"
+ mv "${f}.conf" "${cfg}"
+ mv "${f}" "${f}.conf"
+ done
+ # Whine about any non-.conf files that are left
+ for f in "${ROOT}"etc/modprobe.d/* ; do
+ [[ ${f} == *.conf ]] && continue
+ ewarn "The '${f}' file needs to be upgraded to end with a '.conf'."
+ ewarn "Either upgrade the package that owns it, or manually rename it."
+ done
+ eshopts_pop
+}