summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-12 04:45:19 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-12 04:45:19 +0000
commitce7550351c6d9e8ded37f5ffcdce5de4a4bd2352 (patch)
treeb1e05a9e156b5a322fdfd022ae7556ad71bf9589 /sys-apps
parentdefine SYSCONFDIR, bug #265718. (diff)
downloadgentoo-2-ce7550351c6d9e8ded37f5ffcdce5de4a4bd2352.tar.gz
gentoo-2-ce7550351c6d9e8ded37f5ffcdce5de4a4bd2352.tar.bz2
gentoo-2-ce7550351c6d9e8ded37f5ffcdce5de4a4bd2352.zip
revision bump to force installation of a new init script that is compatible with openrc-0.4.3. Stable users need not upgrade but can without issues
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kexec-tools/ChangeLog10
-rwxr-xr-xsys-apps/kexec-tools/files/kexec.init4
-rw-r--r--sys-apps/kexec-tools/kexec-tools-1.101-r4.ebuild41
-rw-r--r--sys-apps/kexec-tools/kexec-tools-1.101-r7.ebuild42
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.0-r2.ebuild37
5 files changed, 48 insertions, 86 deletions
diff --git a/sys-apps/kexec-tools/ChangeLog b/sys-apps/kexec-tools/ChangeLog
index 11eae5611022..3e03fdeafdb4 100644
--- a/sys-apps/kexec-tools/ChangeLog
+++ b/sys-apps/kexec-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/kexec-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.28 2009/03/22 16:26:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.29 2009/04/12 04:45:19 darkside Exp $
+
+*kexec-tools-2.0.0-r2 (12 Apr 2009)
+
+ 12 Apr 2009; Jeremy Olexa <darkside@gentoo.org> files/kexec.init,
+ -kexec-tools-1.101-r4.ebuild, -kexec-tools-1.101-r7.ebuild,
+ +kexec-tools-2.0.0-r2.ebuild:
+ revision bump to force installation of a new init script that is compatible
+ with openrc-0.4.3. Stable users need not upgrade but can without issues
22 Mar 2009; Markus Meier <maekke@gentoo.org> kexec-tools-2.0.0-r1.ebuild:
amd64/x86 stable, bug #260092
diff --git a/sys-apps/kexec-tools/files/kexec.init b/sys-apps/kexec-tools/files/kexec.init
index 21b045cedc97..63aeaf92cf41 100755
--- a/sys-apps/kexec-tools/files/kexec.init
+++ b/sys-apps/kexec-tools/files/kexec.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/files/kexec.init,v 1.13 2008/12/18 01:06:32 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/files/kexec.init,v 1.14 2009/04/12 04:45:19 darkside Exp $
depend() {
need localmount
@@ -83,7 +83,7 @@ stop() {
[ "${LOAD_DURING_SHUTDOWN:-yes}" != "yes" ] && return 0
ebegin "Configuring kexec"
- if [ "${RC_SOFTLEVEL:-${SOFTLEVEL:-${RC_RUNLEVEL:-${RUNLEVEL}}}}" != "reboot" ]; then
+ if [ "`/sbin/runlevel|/bin/cut -c 3`" != "6" ]; then
einfo "Not rebooting, so disabling"
kexec -u
return 0
diff --git a/sys-apps/kexec-tools/kexec-tools-1.101-r4.ebuild b/sys-apps/kexec-tools/kexec-tools-1.101-r4.ebuild
deleted file mode 100644
index 2692336faf3c..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-1.101-r4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-1.101-r4.ebuild,v 1.2 2008/03/11 21:29:02 genstef Exp $
-
-inherit eutils
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="http://www.xmission.com/~ebiederm/files/kexec/"
-SRC_URI="http://www.xmission.com/~ebiederm/files/kexec/${P}.tar.gz
- http://lse.sourceforge.net/kdump/patches/1.101-kdump10/kexec-tools-1.101-kdump10.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="zlib"
-DEPEND="zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${DISTDIR}"/kexec-tools-1.101-kdump10.patch
- epatch "${FILESDIR}"/${P}-LDFLAGS.patch
- epatch "${FILESDIR}"/${P}-ppc64.patch
- epatch "${FILESDIR}"/kexec-linux-headers.patch
- epatch "${FILESDIR}"/${P}-respect-LDFLAGS.patch
-}
-
-src_compile() {
- econf $(use_with zlib) || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- doman kexec/kexec.8
- dodoc News AUTHORS TODO
-
- newinitd "${FILESDIR}"/kexec.init kexec
- newconfd "${FILESDIR}"/kexec.conf kexec
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-1.101-r7.ebuild b/sys-apps/kexec-tools/kexec-tools-1.101-r7.ebuild
deleted file mode 100644
index 62a0ee748e29..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-1.101-r7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-1.101-r7.ebuild,v 1.1 2009/01/22 13:59:21 darkside Exp $
-
-inherit eutils
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="http://www.xmission.com/~ebiederm/files/kexec/"
-SRC_URI="http://www.xmission.com/~ebiederm/files/kexec/${P}.tar.gz
- http://lse.sourceforge.net/kdump/patches/1.101-kdump10/kexec-tools-1.101-kdump10.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zlib"
-DEPEND="zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${DISTDIR}"/kexec-tools-1.101-kdump10.patch
- epatch "${FILESDIR}"/${P}-LDFLAGS.patch
- epatch "${FILESDIR}"/${P}-ppc64.patch
- epatch "${FILESDIR}"/kexec-linux-headers.patch
- epatch "${FILESDIR}"/${P}-respect-LDFLAGS.patch
-}
-
-src_compile() {
- econf $(use_with zlib) || die "econf failed"
- sed -i -e 's/=-Wall/+=-Wall/' Makefile.conf || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- doman kexec/kexec.8
- dodoc News AUTHORS TODO
-
- newinitd "${FILESDIR}"/kexec.init kexec
- newconfd "${FILESDIR}"/kexec.conf kexec
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.0-r2.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..73015d4cb713
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-2.0.0-r2.ebuild,v 1.1 2009/04/12 04:45:19 darkside Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools"
+SRC_URI="mirror://kernel/linux/kernel/people/horms/kexec-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xen zlib"
+DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ epatch "${FILESDIR}/${P}-respect-LDFLAGS.patch"
+}
+
+src_configure() {
+ econf $(use_with zlib) $(use_with xen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doman kexec/kexec.8
+ dodoc News AUTHORS TODO
+
+ newinitd "${FILESDIR}"/kexec.init kexec || die
+ newconfd "${FILESDIR}"/kexec.conf kexec || die
+}