summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-31 20:16:24 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-31 20:16:24 +0000
commitd5ae2d3690ca2f137e471034ff60b84ece4a2dec (patch)
tree67213aef4d32ae37de49fc89831c710fcb1e841e /sys-apps
parentupdate ccp4 blocker #260533 (diff)
downloadgentoo-2-d5ae2d3690ca2f137e471034ff60b84ece4a2dec.tar.gz
gentoo-2-d5ae2d3690ca2f137e471034ff60b84ece4a2dec.tar.bz2
gentoo-2-d5ae2d3690ca2f137e471034ff60b84ece4a2dec.zip
Version bump.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-7.2.ebuild116
2 files changed, 122 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index d1abd378ea3e..5d22fca6b2ad 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.243 2009/03/12 13:15:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.244 2009/03/31 20:16:24 vapier Exp $
+
+*coreutils-7.2 (31 Mar 2009)
+
+ 31 Mar 2009; Mike Frysinger <vapier@gentoo.org> +coreutils-7.2.ebuild:
+ Version bump.
12 Mar 2009; Mike Frysinger <vapier@gentoo.org> coreutils-7.1.ebuild:
Fix some test failures #259876 by Ryan Hill.
diff --git a/sys-apps/coreutils/coreutils-7.2.ebuild b/sys-apps/coreutils/coreutils-7.2.ebuild
new file mode 100644
index 000000000000..3e621573ae09
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-7.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.2.ebuild,v 1.1 2009/03/31 20:16:24 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+PATCH_VER="1"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.gz
+ mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl caps nls selinux static vanilla xattr"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ nls? ( >=sys-devel/gettext-0.15 )
+ !<sys-apps/util-linux-2.13
+ !sys-apps/stat
+ !net-mail/base64
+ !sys-apps/mktemp
+ !<app-forensics/tct-1.18-r1
+ !<net-fs/netatalk-2.0.3-r4
+ !<sci-chemistry/ccp4-6.1.1
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use vanilla ; then
+ EPATCH_SUFFIX="patch" \
+ PATCHDIR="${WORKDIR}/patch" \
+ EPATCH_EXCLUDE="001_all_coreutils-gen-progress-bar.patch" \
+ epatch
+ fi
+
+ # Since we've patched many .c files, the make process will try to
+ # re-build the manpages by running `./bin --help`. When doing a
+ # cross-compile, we can't do that since 'bin' isn't a native bin.
+ # Also, it's not like we changed the usage on any of these things,
+ # so let's just update the timestamps and skip the help2man step.
+ set -- man/*.x
+ tc-is-cross-compiler && touch ${@/%x/1}
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ # kill/uptime - procps
+ # groups/su - shadow
+ # hostname - net-tools
+ econf \
+ --enable-install-program="arch" \
+ --enable-no-install-program="groups,hostname,kill,su,uptime" \
+ --enable-largefile \
+ $(use_enable caps libcap) \
+ $(use_enable nls) \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ || die "econf"
+ emake || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ #export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ emake -j1 -k check || die "make check failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS || die
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ cd "${D}"/usr/bin
+ dodir /bin
+ # move critical binaries into /bin (required by FHS)
+ local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
+ mkdir mknod mv pwd rm rmdir stty sync true uname"
+ mv ${fhs} ../../bin/ || die "could not move fhs bins"
+ # move critical binaries into /bin (common scripts)
+ local com="basename chroot cut dir dirname du env expr head mkfifo
+ mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"
+ mv ${com} ../../bin/ || die "could not move common bins"
+ # create a symlink for uname in /usr/bin/ since autotools require it
+ local x
+ for x in ${com} uname ; do
+ dosym /bin/${x} /usr/bin/${x} || die
+ done
+ else
+ # For now, drop the man pages, collides with the ones of the system.
+ rm -rf "${D}"/usr/share/man
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Make sure you run 'hash -r' in your active shells"
+}