summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-12-10 00:50:04 +0000
committerZac Medico <zmedico@gentoo.org>2011-12-10 00:50:04 +0000
commitfc17b0ec2955088356a27868c89b63b3c7206e32 (patch)
treed513e72553737354a0f2926646e6e1a3ba4f7149 /sys-apps
parentVersion bump, bug #387433 tracks changes. (diff)
downloadgentoo-2-fc17b0ec2955088356a27868c89b63b3c7206e32.tar.gz
gentoo-2-fc17b0ec2955088356a27868c89b63b3c7206e32.tar.bz2
gentoo-2-fc17b0ec2955088356a27868c89b63b3c7206e32.zip
Add USE=xattr and corresponding deps.
(Portage version: 2.2.0_alpha79_p44/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog5
-rw-r--r--sys-apps/portage/portage-9999.ebuild15
2 files changed, 17 insertions, 3 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 957e45214900..5d3d735bce93 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.923 2011/12/09 20:29:45 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.924 2011/12/10 00:50:04 zmedico Exp $
+
+ 10 Dec 2011; Zac Medico <zmedico@gentoo.org> portage-9999.ebuild:
+ Add USE=xattr and corresponding deps.
09 Dec 2011; Zac Medico <zmedico@gentoo.org> portage-9999.ebuild:
Adjust SYNC in make.globals for prefix installs.
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index e24eb0079cdb..581c5248d41d 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.37 2011/12/09 20:29:45 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.38 2011/12/10 00:50:04 zmedico Exp $
EAPI=3
inherit git-2 eutils multilib python
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="build doc epydoc +ipc python2 python3 selinux"
+IUSE="build doc epydoc +ipc python2 python3 selinux xattr"
# Import of the io module in python-2.6 raises ImportError for the
# thread module if threading is disabled.
@@ -27,6 +27,10 @@ DEPEND="${python_dep}
doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
epydoc? ( >=dev-python/epydoc-2.0 !<=dev-python/pysqlite-2.4.1 )"
# Require sandbox-2.2 for bug #288863.
+# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
+# quite slow, so it's not considered in the dependencies as an alternative to
+# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so
+# for now, don't pull in xattr deps for other kernels.
RDEPEND="${python_dep}
!build? ( >=sys-apps/sed-4.0.5
>=app-shells/bash-3.2_p17
@@ -35,6 +39,7 @@ RDEPEND="${python_dep}
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
>=app-misc/pax-utils-0.1.17
+ xattr? ( kernel_linux? ( || ( >=dev-lang/python-3.3_pre20110902 dev-python/pyxattr ) ) )
selinux? ( || ( >=sys-libs/libselinux-2.0.94[python] <sys-libs/libselinux-2.0.94 ) )
!<app-shells/bash-3.2_p17
!<app-admin/logrotate-3.8.0"
@@ -118,6 +123,12 @@ src_prepare() {
die "failed to patch AbstractEbuildProcess.py"
fi
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
if use python3; then
einfo "Converting shebangs for python3..."
python_convert_shebangs -r 3 .