summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-09-06 20:49:29 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-09-06 20:49:29 +0000
commit87c39f15858444d0fb0094541e874d076f7f5cf1 (patch)
tree3d1b01d0b1f2591eeba52ce0dee0d8077eb20fe6 /sys-auth/consolekit/files
parentFix problem with env.d generation. If you see errors about some vars during u... (diff)
downloadgentoo-2-87c39f15858444d0fb0094541e874d076f7f5cf1.tar.gz
gentoo-2-87c39f15858444d0fb0094541e874d076f7f5cf1.tar.bz2
gentoo-2-87c39f15858444d0fb0094541e874d076f7f5cf1.zip
remove old version. got Jon to make a website for it.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-auth/consolekit/files')
-rw-r--r--sys-auth/consolekit/files/consolekit-0.2.0-gdk-to-x11.patch98
-rw-r--r--sys-auth/consolekit/files/consolekit-0.2.0-pam-lib-fix.patch33
-rw-r--r--sys-auth/consolekit/files/digest-consolekit-0.2.0-r13
3 files changed, 0 insertions, 134 deletions
diff --git a/sys-auth/consolekit/files/consolekit-0.2.0-gdk-to-x11.patch b/sys-auth/consolekit/files/consolekit-0.2.0-gdk-to-x11.patch
deleted file mode 100644
index 4cc0c334309e..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.2.0-gdk-to-x11.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From: William Jon McCann <mccann@jhu.edu>
-Date: Mon, 26 Mar 2007 18:39:44 +0000 (-0400)
-Subject: use xlib directly instead of via gdk
-X-Git-Url: http://gitweb.freedesktop.org/?p=ConsoleKit.git;a=commitdiff;h=a2b51f00af2143a90138c6ce1df1e7e9b4ec8afa
-
-use xlib directly instead of via gdk
----
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -34,7 +34,7 @@ AM_GLIB_GNU_GETTEXT
-
- DBUS_REQUIRED_VERSION=0.30
- GLIB_REQUIRED_VERSION=2.7.0
--GDK_REQUIRED_VERSION=2.8.0
-+X11_REQUIRED_VERSION=1.0.0
-
- AC_CHECK_HEADERS(unistd.h)
- AC_CHECK_HEADERS(paths.h)
-@@ -51,7 +51,8 @@ PKG_CHECK_MODULES(LIBDBUS,
- dbus-1 >= $DBUS_REQUIRED_VERSION
- )
- PKG_CHECK_MODULES(TOOLS,
-- gdk-2.0 >= $GDK_REQUIRED_VERSION
-+ x11 >= $X11_REQUIRED_VERSION
-+ glib-2.0 >= $GLIB_REQUIRED_VERSION
- )
-
- AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
---- a/tools/linux/ck-get-x11-server-pid.c
-+++ b/tools/linux/ck-get-x11-server-pid.c
-@@ -29,15 +29,17 @@
- #include <sys/types.h>
- #include <sys/socket.h>
-
--#include <gdk/gdk.h>
--#include <gdk/gdkx.h>
-+#include <X11/Xlib.h>
-+#include <glib.h>
-
- static void
- print_peer_pid (int fd)
- {
- #ifdef SO_PEERCRED
- struct ucred cr;
-- int cr_len = sizeof (cr);
-+ socklen_t cr_len;
-+
-+ cr_len = sizeof (cr);
-
- if (getsockopt (fd, SOL_SOCKET, SO_PEERCRED, &cr, &cr_len) == 0 && cr_len == sizeof (cr)) {
- /* paranoia check for peer running as root */
-@@ -53,18 +55,41 @@ print_peer_pid (int fd)
- #endif
- }
-
-+static Display *
-+display_init (int *argc, char ***argv)
-+{
-+ const char *display_name;
-+ Display *xdisplay;
-+
-+ display_name = g_getenv ("DISPLAY");
-+
-+ if (display_name == NULL) {
-+ g_warning ("DISPLAY is not set");
-+ exit (1);
-+ }
-+
-+ xdisplay = XOpenDisplay (display_name);
-+ if (xdisplay == NULL) {
-+ g_warning ("cannot open display: %s", display_name ? display_name : "");
-+ exit (1);
-+ }
-+
-+ return xdisplay;
-+}
-+
- int
- main (int argc,
- char **argv)
- {
-- int fd;
-- int ret;
-+ int fd;
-+ int ret;
-+ Display *xdisplay;
-
- ret = 1;
-
-- gdk_init (&argc, &argv);
-+ xdisplay = display_init (&argc, &argv);
-
-- fd = ConnectionNumber (GDK_DISPLAY());
-+ fd = ConnectionNumber (xdisplay);
-
- if (fd > 0) {
- ret = 0;
diff --git a/sys-auth/consolekit/files/consolekit-0.2.0-pam-lib-fix.patch b/sys-auth/consolekit/files/consolekit-0.2.0-pam-lib-fix.patch
deleted file mode 100644
index d939e77a726b..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.2.0-pam-lib-fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nur ConsoleKit-0.2.0/configure.ac ConsoleKit-0.2.0-fixed/configure.ac
---- ConsoleKit-0.2.0/configure.ac 2007-03-14 19:21:25.000000000 -0400
-+++ ConsoleKit-0.2.0-fixed/configure.ac 2007-03-29 10:26:36.000000000 -0400
-@@ -12,6 +12,8 @@
-
- AM_MAINTAINER_MODE
-
-+AC_DISABLE_STATIC
-+
- AC_ISC_POSIX
- AC_PROG_CC
- AC_STDC_HEADERS
-@@ -199,7 +201,7 @@
- if ! test -z "$with_slibdir"; then
- SLIBDIR="$with_slibdir"
- else
-- SLIBDIR="$libdir"
-+ SLIBDIR="/lib"
- fi
- AC_SUBST(SLIBDIR)
-
-diff -Nur ConsoleKit-0.2.0/pam-ck-connector/Makefile.am ConsoleKit-0.2.0-fixed/pam-ck-connector/Makefile.am
---- ConsoleKit-0.2.0/pam-ck-connector/Makefile.am 2007-03-13 02:58:10.000000000 -0400
-+++ ConsoleKit-0.2.0-fixed/pam-ck-connector/Makefile.am 2007-03-28 17:57:05.000000000 -0400
-@@ -7,7 +7,7 @@
- -I$(top_builddir)/libck-connector \
- $(NULL)
-
--pamlibdir = /lib/security
-+pamlibdir = $(SLIBDIR)/security
-
- pamlib_LTLIBRARIES = \
- pam_ck_connector.la \
diff --git a/sys-auth/consolekit/files/digest-consolekit-0.2.0-r1 b/sys-auth/consolekit/files/digest-consolekit-0.2.0-r1
deleted file mode 100644
index e800a7875833..000000000000
--- a/sys-auth/consolekit/files/digest-consolekit-0.2.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e1ffc51b71e955a8703bcf31ff505f50 ConsoleKit-0.2.0.tar.gz 438833
-RMD160 c23bd6ec03602b7d8c35a821e03d4069e62886de ConsoleKit-0.2.0.tar.gz 438833
-SHA256 f2f0d902190de61eaff0776620b0c6564fa3a52c3f84fd574aef74ae30383664 ConsoleKit-0.2.0.tar.gz 438833