summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-09-12 19:46:19 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-09-12 19:46:19 +0000
commitdc813a6d5cf9b33e1d33046141b092eb1fc7edd9 (patch)
tree13380b4b5868e8fcfbf3c4623835081a7b2721f6 /sys-auth/consolekit
parentwork around parallel-build issues and use the upstream makefiles for more (bu... (diff)
downloadgentoo-2-dc813a6d5cf9b33e1d33046141b092eb1fc7edd9.tar.gz
gentoo-2-dc813a6d5cf9b33e1d33046141b092eb1fc7edd9.tar.bz2
gentoo-2-dc813a6d5cf9b33e1d33046141b092eb1fc7edd9.zip
Use the (correct) pid file to control ConsoleKit start/stop. Also, do a blank -r2 bump so users get the new init script.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/ChangeLog10
-rw-r--r--sys-auth/consolekit/consolekit-0.3.0-r2.ebuild (renamed from sys-auth/consolekit/consolekit-0.3.0-r1.ebuild)2
-rw-r--r--sys-auth/consolekit/files/consolekit-0.1.rc8
3 files changed, 15 insertions, 5 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 08dcbbc6b467..77810e778a47 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.48 2009/06/11 23:00:00 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.49 2009/09/12 19:46:18 nirbheek Exp $
+
+*consolekit-0.3.0-r2 (12 Sep 2009)
+
+ 12 Sep 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ files/consolekit-0.1.rc, -consolekit-0.3.0-r1.ebuild,
+ +consolekit-0.3.0-r2.ebuild:
+ Use the (correct) pid file to control ConsoleKit start/stop. Also, do a
+ blank -r2 bump so users get the new init script.
12 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org>
consolekit-0.3.0-r1.ebuild:
diff --git a/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild b/sys-auth/consolekit/consolekit-0.3.0-r2.ebuild
index ed7a8d4a90b6..824cd4ece4ab 100644
--- a/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild
+++ b/sys-auth/consolekit/consolekit-0.3.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild,v 1.3 2009/06/11 23:00:00 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.3.0-r2.ebuild,v 1.1 2009/09/12 19:46:18 nirbheek Exp $
EAPI="2"
diff --git a/sys-auth/consolekit/files/consolekit-0.1.rc b/sys-auth/consolekit/files/consolekit-0.1.rc
index e2db136ff731..d469b46343ef 100644
--- a/sys-auth/consolekit/files/consolekit-0.1.rc
+++ b/sys-auth/consolekit/files/consolekit-0.1.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/files/consolekit-0.1.rc,v 1.1 2007/03/24 17:09:06 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/files/consolekit-0.1.rc,v 1.2 2009/09/12 19:46:19 nirbheek Exp $
depend() {
need dbus
@@ -11,12 +11,14 @@ depend() {
start() {
ebegin "Starting ConsoleKit daemon"
- start-stop-daemon --start -q --exec /usr/sbin/console-kit-daemon --
+ start-stop-daemon --start -q \
+ --pidfile /var/run/ConsoleKit/pid \
+ --exec /usr/sbin/console-kit-daemon --
eend $?
}
stop() {
ebegin "Stopping ConsoleKit daemon"
- start-stop-daemon --stop -q --pidfile /var/run/consolekit.pid
+ start-stop-daemon --stop -q --pidfile /var/run/ConsoleKit/pid
eend $?
}