summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-12 04:41:02 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-12 04:41:02 +0000
commit5f3490fe8f8e5460e32496af5373e18b1a557beb (patch)
tree843a8d9fa79f9d33b858941a379ce32b1a178697 /sys-auth/keystone/keystone-9999.ebuild
parentDrop unused patches too. (diff)
downloadgentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.tar.gz
gentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.tar.bz2
gentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.zip
fully distutils-r1 compliant and sqlalchemy sucks
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth/keystone/keystone-9999.ebuild')
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index e7d91aca79f8..22ff07b1f113 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.8 2013/04/11 07:17:05 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.9 2013/09/12 04:41:02 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -34,18 +34,18 @@ RDEPEND="${DEPEND}
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/python-daemon
+ dev-python/python-daemon[${PYTHON_USEDEP}]
>=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
dev-python/routes[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
- <=dev-python/sqlalchemy-0.7.9[sqlite] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
- <=dev-python/sqlalchemy-0.7.9[mysql] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
- <=dev-python/sqlalchemy-0.7.9[postgres] )
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator