summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-09-14 10:54:25 +0000
committerHanno Böck <hanno@gentoo.org>2008-09-14 10:54:25 +0000
commit3d9e014e3aaec9b0736d7a4f0a10f70f404ecb67 (patch)
tree9d72885dcd9370badd27e71b0c99b71724511f0a /sys-auth/pam_mount
parentlibhx bump (diff)
downloadgentoo-2-3d9e014e3aaec9b0736d7a4f0a10f70f404ecb67.tar.gz
gentoo-2-3d9e014e3aaec9b0736d7a4f0a10f70f404ecb67.tar.bz2
gentoo-2-3d9e014e3aaec9b0736d7a4f0a10f70f404ecb67.zip
pam_mount bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 i686)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.48.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 2aafb7f87700..6151e1d5777f 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.21 2008/09/09 00:07:42 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.22 2008/09/14 10:54:25 hanno Exp $
+
+*pam_mount-0.48 (14 Sep 2008)
+
+ 14 Sep 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.48.ebuild:
+ Version bump.
*pam_mount-0.47 (09 Sep 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.48.ebuild b/sys-auth/pam_mount/pam_mount-0.48.ebuild
new file mode 100644
index 000000000000..6b0416122220
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.48.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.48.ebuild,v 1.1 2008/09/14 10:54:25 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}