summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 15:11:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 15:11:52 +0000
commit5630dd257ceaaa7b3fc76bf790382ffe8e6c6313 (patch)
treec6494d6b0b0527a2928634491e3eb15192e0db14 /sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild
parentStable on alpha. (diff)
downloadgentoo-2-5630dd257ceaaa7b3fc76bf790382ffe8e6c6313.tar.gz
gentoo-2-5630dd257ceaaa7b3fc76bf790382ffe8e6c6313.tar.bz2
gentoo-2-5630dd257ceaaa7b3fc76bf790382ffe8e6c6313.zip
Moved from sys-libs/pam_ssh_agent to sys-auth/pam_ssh_agent.
Diffstat (limited to 'sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild')
-rw-r--r--sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild b/sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild
new file mode 100644
index 000000000000..1ee2af8cf053
--- /dev/null
+++ b/sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild,v 1.1 2005/07/02 15:11:52 flameeyes Exp $
+
+inherit toolchain-funcs flag-o-matic eutils pam
+
+DESCRIPTION="PAM module that spawns a ssh-agent and adds identities using the password supplied at login"
+HOMEPAGE="http://pam-ssh-agent.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh-agent/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="net-misc/keychain
+ virtual/pam
+ dev-tcltk/expect"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-openpam.patch
+ sed -i -e "s:gcc:$(tc-getCC) \${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ append-flags -fPIC
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dopammod ${S}/pam_ssh_agent.so
+ dodoc README
+}