summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-22 13:57:20 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-22 13:57:20 +0000
commit144571edbc94f0c122b8ca8329bb1e8cb663d8a6 (patch)
treedc90631cda2bf225a720a59427545c6ad84b594a /sys-auth/pam_yubico/pam_yubico-2.13.ebuild
parenttested on ~x86 (diff)
downloadgentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.tar.gz
gentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.tar.bz2
gentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.zip
initial commit, deps are likely a bit more complex than this
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth/pam_yubico/pam_yubico-2.13.ebuild')
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/pam_yubico-2.13.ebuild b/sys-auth/pam_yubico/pam_yubico-2.13.ebuild
new file mode 100644
index 000000000000..66963deefdbc
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/pam_yubico-2.13.ebuild,v 1.1 2013/04/22 13:57:20 zerochaos Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://code.google.com/p/yubico-pam/"
+SRC_URI="http://yubico-pam.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="virtual/pam
+ >=sys-auth/ykclient-2.4
+ >=sys-auth/ykpers-1.6"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/2.11-drop_privs.patch"
+ eautoreconf
+}
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README doc/*
+ prune_libtool_files
+}
+