summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-12 11:25:37 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-12 11:25:37 +0000
commit06ac71192dc94f6c8c055e20d5ef768b9415e92d (patch)
tree7e6d615ac7c3fbca6bc44fe143ec9f84ad3222f3 /sys-auth
parentAdding append-flags -D_GNU_SOURCE to make gamin compile with glibc-2.8. Fixes... (diff)
downloadgentoo-2-06ac71192dc94f6c8c055e20d5ef768b9415e92d.tar.gz
gentoo-2-06ac71192dc94f6c8c055e20d5ef768b9415e92d.tar.bz2
gentoo-2-06ac71192dc94f6c8c055e20d5ef768b9415e92d.zip
pam_mount bumped to cover upstream changed tarball
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.40-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index eefb629ff741..acf46e6a8afe 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.17 2008/06/11 19:36:15 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.18 2008/06/12 11:25:37 hanno Exp $
+
+*pam_mount-0.40-r1 (12 Jun 2008)
+
+ 12 Jun 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.40-r1.ebuild:
+ Bumping version because upstream changed tarball after release.
*pam_mount-0.40 (11 Jun 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.40-r1.ebuild b/sys-auth/pam_mount/pam_mount-0.40-r1.ebuild
new file mode 100644
index 000000000000..10a4158c4e1a
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.40-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.40-r1.ebuild,v 1.1 2008/06/12 11:25:37 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}