summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-12-02 22:33:21 +0000
committerHanno Böck <hanno@gentoo.org>2007-12-02 22:33:21 +0000
commit1402dd46a1c743ee79a0cbef42b2931d8a38d5de (patch)
tree96c7a0fb1bb12ad0ec2fc59448416932dfdf7b2d /sys-auth
parentAdd support for USE="ffmpeg fusion svg zlib" as proposed by Christian Ruppert... (diff)
downloadgentoo-2-1402dd46a1c743ee79a0cbef42b2931d8a38d5de.tar.gz
gentoo-2-1402dd46a1c743ee79a0cbef42b2931d8a38d5de.tar.bz2
gentoo-2-1402dd46a1c743ee79a0cbef42b2931d8a38d5de.zip
pam_mount bump
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/files/digest-pam_mount-0.313
-rw-r--r--sys-auth/pam_mount/pam_mount-0.31.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 9d76ceae470f..603871afa6ca 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.9 2007/10/06 19:07:02 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.10 2007/12/02 22:33:21 hanno Exp $
+
+*pam_mount-0.31 (02 Dec 2007)
+
+ 02 Dec 2007; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.31.ebuild:
+ Version bump.
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
pam_mount-0.29.ebuild:
diff --git a/sys-auth/pam_mount/files/digest-pam_mount-0.31 b/sys-auth/pam_mount/files/digest-pam_mount-0.31
new file mode 100644
index 000000000000..0798285518d3
--- /dev/null
+++ b/sys-auth/pam_mount/files/digest-pam_mount-0.31
@@ -0,0 +1,3 @@
+MD5 2e3d360998997a99225c8c0f0e02873b pam_mount-0.31.tar.bz2 298711
+RMD160 f5396654ba02eef1b0c10cbb50592963aa246b39 pam_mount-0.31.tar.bz2 298711
+SHA256 a47df7c65f784491d8ebaeade4c7565a8683a66356b837a0325882261c3e9ca9 pam_mount-0.31.tar.bz2 298711
diff --git a/sys-auth/pam_mount/pam_mount-0.31.ebuild b/sys-auth/pam_mount/pam_mount-0.31.ebuild
new file mode 100644
index 000000000000..5eb85f0b7d8b
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.31.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.31.ebuild,v 1.1 2007/12/02 22:33:21 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ sys-libs/libhx
+ dev-libs/libxml2"
+RDEPEND="$DEPEND
+ crypt? ( || ( >=sys-fs/cryptsetup-1.0.5 sys-fs/cryptsetup-luks ) )
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}