summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-09-08 23:13:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-09-08 23:13:40 +0000
commit3260e18d4f6b11b2de6dc77573f97513e8286928 (patch)
tree9745d5a1adbb4fae51ed31bcbee5a8ac68735fa7 /sys-auth
parentVersion bump. Remove old ebuilds (diff)
downloadgentoo-2-3260e18d4f6b11b2de6dc77573f97513e8286928.tar.gz
gentoo-2-3260e18d4f6b11b2de6dc77573f97513e8286928.tar.bz2
gentoo-2-3260e18d4f6b11b2de6dc77573f97513e8286928.zip
Bug #335772: Disable always-enabled DEBUG option (my previous commit failed).
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libnss-mysql/ChangeLog9
-rw-r--r--sys-auth/libnss-mysql/files/libnss-mysql-1.5_p20060915-no-automagic-debug.diff14
-rw-r--r--sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild46
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-auth/libnss-mysql/ChangeLog b/sys-auth/libnss-mysql/ChangeLog
index e2894fbcf34c..f00b24dd755e 100644
--- a/sys-auth/libnss-mysql/ChangeLog
+++ b/sys-auth/libnss-mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/libnss-mysql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.14 2010/02/23 12:43:44 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.15 2010/09/08 23:13:40 robbat2 Exp $
+
+*libnss-mysql-1.5_p20060915-r1 (08 Sep 2010)
+
+ 08 Sep 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +libnss-mysql-1.5_p20060915-r1.ebuild,
+ +files/libnss-mysql-1.5_p20060915-no-automagic-debug.diff:
+ Bug #335772: Disable always-enabled DEBUG option.
*libnss-mysql-1.5_p20060915 (23 Feb 2010)
diff --git a/sys-auth/libnss-mysql/files/libnss-mysql-1.5_p20060915-no-automagic-debug.diff b/sys-auth/libnss-mysql/files/libnss-mysql-1.5_p20060915-no-automagic-debug.diff
new file mode 100644
index 000000000000..292ae9e19476
--- /dev/null
+++ b/sys-auth/libnss-mysql/files/libnss-mysql-1.5_p20060915-no-automagic-debug.diff
@@ -0,0 +1,14 @@
+diff -NuarwPbB libnss-mysql.orig/configure.in libnss-mysql/configure.in
+--- libnss-mysql.orig/configure.in 2005-09-04 03:34:00.000000000 +0000
++++ libnss-mysql/configure.in 2010-09-08 18:12:24.577317098 +0000
+@@ -38,7 +38,9 @@
+ AC_ARG_WITH(mysql,
+ [ --with-mysql=DIR Location of your MySQL installation])
+ AC_ARG_ENABLE(debug,
+- [ --enable-debug Enable debug (see DEBUGGING)],
++ [ --enable-debug Enable debug (see DEBUGGING)])
++
++AS_IF([test "x$enable_debug" = "xyes"],
+ [AC_DEFINE([DEBUG], 1, [Enable debug])])
+
+ case "$target_os" in
diff --git a/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild
new file mode 100644
index 000000000000..795ce46a20f5
--- /dev/null
+++ b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild,v 1.1 2010/09/08 23:13:40 robbat2 Exp $
+
+EAPI=2
+
+inherit eutils multilib autotools
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DESCRIPTION="NSS MySQL Library."
+HOMEPAGE="http://libnss-mysql.sourceforge.net/"
+SRC_URI="http://libnss-mysql.sourceforge.net/snapshot/${PN}-${PV/1.5_p/}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="virtual/mysql"
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-automagic-debug.diff
+ eautoconf
+}
+
+src_configure() {
+ # authentication libraries don't belong into usr,
+ # please don't change this
+ econf --libdir="/$(get_libdir)" \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${D}" -name '*.la' -delete
+
+ newdoc sample/README README.sample
+ dodoc AUTHORS DEBUGGING FAQ INSTALL NEWS README THANKS \
+ TODO UPGRADING ChangeLog
+
+ for subdir in sample/{linux,freebsd,complex,minimal} ; do
+ docinto "${subdir}"
+ dodoc "${subdir}/"{*.sql,*.cfg}
+ done
+}