summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-10-18 15:40:51 +0000
committerIan Delaney <idella4@gentoo.org>2013-10-18 15:40:51 +0000
commit9ba6e9e403b0f2d0ff47286a87b94331b23bbba4 (patch)
tree1e5da80ffbcf3e70cfd5c806dabf20b69fa9c9c0 /sys-auth
parentVersion bump wrt bug #488438. (diff)
downloadgentoo-2-9ba6e9e403b0f2d0ff47286a87b94331b23bbba4.tar.gz
gentoo-2-9ba6e9e403b0f2d0ff47286a87b94331b23bbba4.tar.bz2
gentoo-2-9ba6e9e403b0f2d0ff47286a87b94331b23bbba4.zip
test suite dep added, test phase code corrected, re-invoked
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog5
-rw-r--r--sys-auth/keystone/keystone-2013.1.3-r3.ebuild60
2 files changed, 33 insertions, 32 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index fa5438f079f0..27261fd9818b 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.36 2013/10/07 14:51:48 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.37 2013/10/18 15:40:51 idella4 Exp $
+
+ 18 Oct 2013; Ian Delaney <idella4@gentoo.org> keystone-2013.1.3-r3.ebuild:
+ test suite dep added, test phase code corrected, re-invoked
07 Oct 2013; Ian Delaney <idella4@gentoo.org> keystone-2013.1.3-r3.ebuild,
metadata.xml:
diff --git a/sys-auth/keystone/keystone-2013.1.3-r3.ebuild b/sys-auth/keystone/keystone-2013.1.3-r3.ebuild
index 7fdb5d5ee415..2c26bbda02bd 100644
--- a/sys-auth/keystone/keystone-2013.1.3-r3.ebuild
+++ b/sys-auth/keystone/keystone-2013.1.3-r3.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.3-r3.ebuild,v 1.3 2013/10/07 14:51:48 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.3-r3.ebuild,v 1.4 2013/10/18 15:40:51 idella4 Exp $
EAPI=5
-#test restricted becaues of bad requirements given (old webob for instance)
-RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -16,8 +14,7 @@ SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="grizzly"
KEYWORDS="~amd64 ~x86"
-IUSE="+sqlite mysql postgres ldap"
-#IUSE="+sqlite mysql postgres ldap test"
+IUSE="+sqlite mysql postgres ldap test"
REQUIRED_USE="|| ( mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
@@ -46,38 +43,39 @@ RDEPEND="${DEPEND}
<dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
- ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
-# test? ( dev-python/Babel
-# dev-python/decorator
-# dev-python/eventlet
-# dev-python/greenlet
-# dev-python/httplib2
-# dev-python/iso8601
-# dev-python/lxml
-# dev-python/netifaces
-# dev-python/nose
-# dev-python/nosexcover
-# dev-python/passlib
-# dev-python/paste
-# dev-python/pastedeploy
-# dev-python/python-pam
-# dev-python/repoze-lru
-# dev-python/routes
-# dev-python/sphinx
-# >=dev-python/sqlalchemy-migrate-0.7
-# dev-python/tempita
-# >=dev-python/webob-1.0.8
-# dev-python/webtest
-# )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ test? ( dev-python/Babel
+ dev-python/decorator
+ dev-python/eventlet
+ dev-python/greenlet
+ dev-python/httplib2
+ dev-python/iso8601
+ dev-python/lxml
+ dev-python/netifaces
+ dev-python/nose
+ dev-python/nosexcover
+ dev-python/passlib
+ dev-python/paste
+ dev-python/pastedeploy
+ dev-python/python-pam
+ dev-python/repoze-lru
+ dev-python/routes
+ dev-python/sphinx
+ >=dev-python/sqlalchemy-migrate-0.7
+ dev-python/tempita
+ >=dev-python/webob-1.0.8
+ dev-python/webtest
+ dev-python/python-memcached
+ )"
PATCHES=(
"${FILESDIR}/2013.1.3-CVE-2013-4222.patch"
"${FILESDIR}/keystone-cve-2013-4294-grizzly.patch"
)
# "${FILESDIR}/keystone-grizzly-2-CVE-2013-2157.patch"
#
-#python_test() {
-# "${PYTHON}" setup.py nosetests || die
-#}
+python_test() {
+ nosetests || die "testsuite failed under ${EPYTHON}"
+}
python_install() {
distutils-r1_python_install