summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-01-08 21:31:44 +0000
committerHanno Böck <hanno@gentoo.org>2009-01-08 21:31:44 +0000
commitb565c9d270ab75bcec2871cbb290707f8056cbb9 (patch)
tree93a168b1230022f925274761192b18885c00d717 /sys-auth
parentRemove old (diff)
downloadgentoo-2-b565c9d270ab75bcec2871cbb290707f8056cbb9.tar.gz
gentoo-2-b565c9d270ab75bcec2871cbb290707f8056cbb9.tar.bz2
gentoo-2-b565c9d270ab75bcec2871cbb290707f8056cbb9.zip
pam_mount bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog9
-rw-r--r--sys-auth/pam_mount/pam_mount-1.8.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index ac261d371ae4..35d701380f74 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.24 2008/12/17 21:59:48 hanno Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.25 2009/01/08 21:31:44 hanno Exp $
+
+*pam_mount-1.8 (08 Jan 2009)
+
+ 08 Jan 2009; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.8.ebuild:
+ Version bump.
*pam_mount-1.5 (17 Dec 2008)
diff --git a/sys-auth/pam_mount/pam_mount-1.8.ebuild b/sys-auth/pam_mount/pam_mount-1.8.ebuild
new file mode 100644
index 000000000000..138bc50eb340
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.8.ebuild,v 1.1 2009/01/08 21:31:44 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}