summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-05-07 19:25:22 +0000
committerHanno Böck <hanno@gentoo.org>2009-05-07 19:25:22 +0000
commitdd3743c7dfad07207cad3824874324c694152770 (patch)
tree943a7216c2b12f8ee29eb934629fc62b8283cf96 /sys-auth
parentversion bump; keyword amd64 (diff)
downloadgentoo-2-dd3743c7dfad07207cad3824874324c694152770.tar.gz
gentoo-2-dd3743c7dfad07207cad3824874324c694152770.tar.bz2
gentoo-2-dd3743c7dfad07207cad3824874324c694152770.zip
pam_mount bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-1.24.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index fb84cd624b87..7371fb2b540f 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.30 2009/04/06 15:43:24 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.31 2009/05/07 19:25:22 hanno Exp $
+
+*pam_mount-1.24 (07 May 2009)
+
+ 07 May 2009; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.24.ebuild:
+ Version bump.
*pam_mount-1.22 (06 Apr 2009)
diff --git a/sys-auth/pam_mount/pam_mount-1.24.ebuild b/sys-auth/pam_mount/pam_mount-1.24.ebuild
new file mode 100644
index 000000000000..e311df4d3d85
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.24.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.24.ebuild,v 1.1 2009/05/07 19:25:22 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.7
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.7
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}