summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-08-18 22:39:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-08-18 22:39:18 +0000
commite469ec7a30a854fc881957d1c3ac2eb10ababe3a (patch)
tree463a48d77fb91efd1301f804de9df4d471d53160 /sys-block/fio/fio-1.17.ebuild
parentAdded a new snapshot. This will also work with vdr-1.5.7 (diff)
downloadgentoo-2-e469ec7a30a854fc881957d1c3ac2eb10ababe3a.tar.gz
gentoo-2-e469ec7a30a854fc881957d1c3ac2eb10ababe3a.tar.bz2
gentoo-2-e469ec7a30a854fc881957d1c3ac2eb10ababe3a.zip
Initial Commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-block/fio/fio-1.17.ebuild')
-rw-r--r--sys-block/fio/fio-1.17.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/fio/fio-1.17.ebuild b/sys-block/fio/fio-1.17.ebuild
new file mode 100644
index 000000000000..bbe92b58effb
--- /dev/null
+++ b/sys-block/fio/fio-1.17.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-1.17.ebuild,v 1.1 2007/08/18 22:39:17 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+}