summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-11 02:53:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-11 02:53:05 +0000
commit8fea21554c78c1085290f85b0ee5f10978cf6b69 (patch)
tree0e4396f2b76e17f98a997a0f42d0027e03088729 /sys-block/partimage
parentAdded missing deps for dev-util/automoc and dev-util/pkgconfig. Thanks to Nik... (diff)
downloadgentoo-2-8fea21554c78c1085290f85b0ee5f10978cf6b69.tar.gz
gentoo-2-8fea21554c78c1085290f85b0ee5f10978cf6b69.tar.bz2
gentoo-2-8fea21554c78c1085290f85b0ee5f10978cf6b69.zip
Fix building with OpenSSL >= 1.0.0 wrt #326879 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/partimage')
-rw-r--r--sys-block/partimage/ChangeLog6
-rw-r--r--sys-block/partimage/files/partimage-0.6.8-openssl-1.patch24
-rw-r--r--sys-block/partimage/partimage-0.6.8.ebuild5
3 files changed, 32 insertions, 3 deletions
diff --git a/sys-block/partimage/ChangeLog b/sys-block/partimage/ChangeLog
index 6e20fe90c8ab..716c9caff044 100644
--- a/sys-block/partimage/ChangeLog
+++ b/sys-block/partimage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/partimage
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.43 2010/07/07 22:53:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.44 2010/07/11 02:53:05 ssuominen Exp $
+
+ 11 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ partimage-0.6.8.ebuild, +files/partimage-0.6.8-openssl-1.patch:
+ Fix building with OpenSSL >= 1.0.0 wrt #326879 by Diego E. Pettenò.
*partimage-0.6.8 (07 Jul 2010)
diff --git a/sys-block/partimage/files/partimage-0.6.8-openssl-1.patch b/sys-block/partimage/files/partimage-0.6.8-openssl-1.patch
new file mode 100644
index 000000000000..a4ebeb9aac60
--- /dev/null
+++ b/sys-block/partimage/files/partimage-0.6.8-openssl-1.patch
@@ -0,0 +1,24 @@
+http://bugs.gentoo.org/326879
+
+--- src/client/netclient.h
++++ src/client/netclient.h
+@@ -35,7 +35,7 @@
+ #ifdef HAVE_SSL
+ SSL_CTX * ctx;
+ X509 * server_cert;
+- SSL_METHOD * meth;
++ const SSL_METHOD * meth;
+ #endif
+ bool m_bUseSSL;
+ bool m_bMustLogin;
+--- src/server/netserver.h
++++ src/server/netserver.h
+@@ -41,7 +41,7 @@
+ #ifdef HAVE_SSL
+ SSL_CTX * ctx;
+ X509 * client_cert;
+- SSL_METHOD * meth;
++ const SSL_METHOD * meth;
+ int err;
+ #endif
+
diff --git a/sys-block/partimage/partimage-0.6.8.ebuild b/sys-block/partimage/partimage-0.6.8.ebuild
index aeef7465ac87..fb5f88b604d4 100644
--- a/sys-block/partimage/partimage-0.6.8.ebuild
+++ b/sys-block/partimage/partimage-0.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.8.ebuild,v 1.2 2010/07/07 22:58:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.8.ebuild,v 1.3 2010/07/11 02:53:05 ssuominen Exp $
EAPI=3
inherit autotools eutils flag-o-matic pam
@@ -32,7 +32,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/${P}-destdir.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
eautoreconf
}