summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 22:45:39 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 22:45:39 +0000
commit2b687db0592c2ee648dbae6580064404eee915ad (patch)
treeeac4de39f884b266530023ef5caafae632786a74 /sys-block/zram-init/zram-init-2.7-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-2b687db0592c2ee648dbae6580064404eee915ad.tar.gz
gentoo-2-2b687db0592c2ee648dbae6580064404eee915ad.tar.bz2
gentoo-2-2b687db0592c2ee648dbae6580064404eee915ad.zip
Imported from mv overlay, thanks to Martin Vaeth
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'sys-block/zram-init/zram-init-2.7-r1.ebuild')
-rw-r--r--sys-block/zram-init/zram-init-2.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-block/zram-init/zram-init-2.7-r1.ebuild b/sys-block/zram-init/zram-init-2.7-r1.ebuild
new file mode 100644
index 000000000000..66bc6b92eff2
--- /dev/null
+++ b/sys-block/zram-init/zram-init-2.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/zram-init/zram-init-2.7-r1.ebuild,v 1.1 2014/05/10 22:45:39 jauhien Exp $
+
+EAPI=5
+inherit eutils readme.gentoo systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ epatch_user
+}
+
+src_install() {
+ dosbin sbin/*
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}