summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-06-20 15:19:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-06-20 15:19:25 +0000
commit0db20236c11cefe700dded83b8125c610eabc474 (patch)
treea20957b7ad5e5c5b4c5cd2db8ab3a6c35ee9ef25 /sys-block
parentBump to new upstream snapshot, bug #372361 thank Dustin Polke for this job. (diff)
downloadgentoo-2-0db20236c11cefe700dded83b8125c610eabc474.tar.gz
gentoo-2-0db20236c11cefe700dded83b8125c610eabc474.tar.bz2
gentoo-2-0db20236c11cefe700dded83b8125c610eabc474.zip
[sys-block/tgt] Version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tgt/ChangeLog8
-rw-r--r--sys-block/tgt/tgt-1.0.17.ebuild (renamed from sys-block/tgt/tgt-1.0.13.ebuild)20
-rw-r--r--sys-block/tgt/tgt-1.0.9.ebuild51
3 files changed, 17 insertions, 62 deletions
diff --git a/sys-block/tgt/ChangeLog b/sys-block/tgt/ChangeLog
index 327dc64574aa..f324eb65b7b5 100644
--- a/sys-block/tgt/ChangeLog
+++ b/sys-block/tgt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/tgt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.11 2011/04/14 15:29:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.12 2011/06/20 15:19:25 alexxy Exp $
+
+*tgt-1.0.17 (20 Jun 2011)
+
+ 20 Jun 2011; Alexey Shvetsov <alexxy@gentoo.org> -tgt-1.0.9.ebuild,
+ -tgt-1.0.13.ebuild, +tgt-1.0.17.ebuild:
+ Version bump
*tgt-1.0.15 (14 Apr 2011)
diff --git a/sys-block/tgt/tgt-1.0.13.ebuild b/sys-block/tgt/tgt-1.0.17.ebuild
index c21dd40e57d6..a6b12e01d31e 100644
--- a/sys-block/tgt/tgt-1.0.13.ebuild
+++ b/sys-block/tgt/tgt-1.0.17.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.13.ebuild,v 1.1 2011/02/02 17:30:47 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.17.ebuild,v 1.1 2011/06/20 15:19:25 alexxy Exp $
-EAPI="4"
+EAPI=4
inherit flag-o-matic linux-info
@@ -16,12 +16,12 @@ KEYWORDS="~amd64 ~x86"
IUSE="ibmvio infiniband fcp fcoe"
DEPEND="dev-perl/config-general
- infiniband? (
- sys-infiniband/libibverbs
- sys-infiniband/librdmacm
- )"
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
RDEPEND="${DEPEND}
- sys-apps/sg3_utils"
+ sys-apps/sg3_utils"
pkg_setup() {
CONFIG_CHECK="~SCSI_TGT"
@@ -44,8 +44,8 @@ src_compile() {
src_install() {
emake install-programs install-scripts install-doc DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} \
- || die "install failed"
+ docdir=/usr/share/doc/${PF}
doinitd "${FILESDIR}/tgtd"
- dodir "/etc/tgt"
+ dodir /etc/tgt
+ keepdir /etc/tgt
}
diff --git a/sys-block/tgt/tgt-1.0.9.ebuild b/sys-block/tgt/tgt-1.0.9.ebuild
deleted file mode 100644
index c1dcab54b2a0..000000000000
--- a/sys-block/tgt/tgt-1.0.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.9.ebuild,v 1.3 2011/01/18 14:18:28 xarthisius Exp $
-
-EAPI="3"
-
-inherit flag-o-matic linux-info
-
-DESCRIPTION="Linux SCSI target framework (tgt)"
-HOMEPAGE="http://stgt.sourceforge.net"
-SRC_URI="http://stgt.sourceforge.net/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ibmvio infiniband fcp fcoe"
-
-DEPEND="dev-perl/config-general
- infiniband? (
- sys-infiniband/libibverbs
- sys-infiniband/librdmacm
- )"
-RDEPEND="${DEPEND}
- sys-apps/sg3_utils"
-
-pkg_setup() {
- CONFIG_CHECK="~SCSI_TGT"
- WARNING_SCSI_TGT="Your kernel needs CONFIG_SCSI_TGT"
- linux-info_pkg_setup
-}
-
-src_configure() {
- use ibmvio && myconf="${myconf} IBMVIO=1"
- use infiniband && myconf="${myconf} ISCSI_RDMA=1"
- use fcp && myconf="${myconf} FCP=1"
- use fcoe && myconf="${myconf} FCOE=1"
-
- sed -e 's:\($(CC)\):\1 $(LDFLAGS):' -i usr/Makefile || die "sed failed"
-}
-
-src_compile() {
- emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
-}
-
-src_install() {
- emake install-programs install-scripts install-doc DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} \
- || die "install failed"
- doinitd "${FILESDIR}/tgtd"
- dodir "/etc/tgt"
-}