summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-16 12:39:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-16 12:39:00 +0000
commit48a582b0071a3c48b32066a7c30755eecba13199 (patch)
tree77d8b38d85ed0dfcd7d9622033813d492d99e833 /sys-block
parentAdd linguas to IUSE as per bug #136953. (diff)
downloadgentoo-2-48a582b0071a3c48b32066a7c30755eecba13199.tar.gz
gentoo-2-48a582b0071a3c48b32066a7c30755eecba13199.tar.bz2
gentoo-2-48a582b0071a3c48b32066a7c30755eecba13199.zip
Update to 5.3.
(Portage version: 2.1)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/unieject/ChangeLog7
-rw-r--r--sys-block/unieject/files/digest-unieject-5.33
-rw-r--r--sys-block/unieject/unieject-5.3.ebuild80
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-block/unieject/ChangeLog b/sys-block/unieject/ChangeLog
index 80c6f5a8b027..f317ed0b81e9 100644
--- a/sys-block/unieject/ChangeLog
+++ b/sys-block/unieject/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/unieject
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.25 2006/06/15 12:52:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.26 2006/06/16 12:39:00 flameeyes Exp $
+
+*unieject-5.3 (16 Jun 2006)
+
+ 16 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> +unieject-5.3.ebuild:
+ Update to 5.3.
15 Jun 2006; Gustavo Zacarias <gustavoz@gentoo.org>
unieject-5.2-r1.ebuild:
diff --git a/sys-block/unieject/files/digest-unieject-5.3 b/sys-block/unieject/files/digest-unieject-5.3
new file mode 100644
index 000000000000..9ba27e16a510
--- /dev/null
+++ b/sys-block/unieject/files/digest-unieject-5.3
@@ -0,0 +1,3 @@
+MD5 4eeb14a1ce5135cd45220d22a4f1127d unieject-5.3.tar.bz2 318872
+RMD160 9adc50260db0fb0dbb316464bad47f3d5932176d unieject-5.3.tar.bz2 318872
+SHA256 0fbdb811f0053322497fb0616efd6f0323c941739fa3c5aabb9cdf1ed5521704 unieject-5.3.tar.bz2 318872
diff --git a/sys-block/unieject/unieject-5.3.ebuild b/sys-block/unieject/unieject-5.3.ebuild
new file mode 100644
index 000000000000..28f8b0e53397
--- /dev/null
+++ b/sys-block/unieject/unieject-5.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-5.3.ebuild,v 1.1 2006/06/16 12:39:00 flameeyes Exp $
+
+inherit libtool
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://dev.gentoo.org/~flameeyes/projects"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd"
+IUSE="nls pmount"
+
+RDEPEND=">=dev-libs/libcdio-0.75-r1
+ dev-libs/popt
+ >=dev-libs/confuse-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/sed"
+RDEPEND="${RDEPEND}
+ pmount? ( sys-apps/pmount )
+ !sys-apps/eject
+ !sys-block/eject-bsd"
+
+PROVIDE="virtual/eject"
+
+pkg_setup() {
+ use pmount && enewgroup plugdev
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # libcdio-0.75-r1 in Gentoo is fixed, so no need to ask 0.76 either on
+ # FreeBSD.
+ sed -i -e '/freebsd/s:libcdiomin="0\.76":libcdiomin="0.75":' \
+ ${S}/configure
+
+ elibtoolize
+}
+
+src_compile() {
+ use pmount && append-ldflags "-Wl,-z,now"
+
+ econf \
+ $(use_enable nls) \
+ --enable-lock-workaround \
+ --disable-dependency-tracking \
+ --disable-doc \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README ChangeLog NEWS AUTHORS unieject.conf.sample
+
+ # Symlink to eject to provide a good virtual/eject
+ dosym unieject.1.gz /usr/share/man/man1/eject.1.gz
+ dosym unieject /usr/bin/eject
+
+ # If we enable support for pmount, we need to change the installed
+ # configuration file to enable the unmount wrapper, and we also set the
+ # command setuid root but in group plugdev, so that it's inlined with pmount
+ # itself.
+ if use pmount; then
+ fowners root:plugdev /usr/bin/unieject
+ fperms 1710 /usr/bin/unieject
+ chmod +s "${D}/usr/bin/unieject"
+
+ dodir /etc
+ sed -e 's:^# \(unmount-wrapper = \):\1:' \
+ "${S}/unieject.conf.sample" \
+ > "${D}/etc/unieject.conf"
+ fi
+}