summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-24 13:48:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-24 13:48:01 +0000
commitee65b5d1cdf932f596ec9cc8a2025a2ea9eeff53 (patch)
treeae0c6c0b76bcb3122e2b119e7143aed29d852810 /sys-block
parentInitial commit (diff)
downloadgentoo-2-ee65b5d1cdf932f596ec9cc8a2025a2ea9eeff53.tar.gz
gentoo-2-ee65b5d1cdf932f596ec9cc8a2025a2ea9eeff53.tar.bz2
gentoo-2-ee65b5d1cdf932f596ec9cc8a2025a2ea9eeff53.zip
Fix building with recent glibc wrt #334077 by "fkhp".
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog6
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.871.3-glibc212.patch22
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index ad6a85108adc..3a95b906ced8 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.29 2010/03/31 23:19:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.30 2010/08/24 13:48:01 ssuominen Exp $
+
+ 24 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+ open-iscsi-2.0.871.3.ebuild, +files/open-iscsi-2.0.871.3-glibc212.patch:
+ Fix building with recent glibc wrt #334077 by "fkhp".
31 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
open-iscsi-2.0.871-r1.ebuild, open-iscsi-2.0.871.3.ebuild:
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.871.3-glibc212.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.871.3-glibc212.patch
new file mode 100644
index 000000000000..b6f752b3d2ca
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.871.3-glibc212.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/334077
+
+--- usr/iscsid.c
++++ usr/iscsid.c
+@@ -29,6 +29,7 @@
+ #include <signal.h>
+ #include <sys/mman.h>
+ #include <sys/utsname.h>
++#include <sys/stat.h>
+
+ #include "iscsid.h"
+ #include "mgmt_ipc.h"
+--- usr/iscsi_sysfs.c
++++ usr/iscsi_sysfs.c
+@@ -22,6 +22,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <dirent.h>
++#include <sys/stat.h>
+
+ #include "log.h"
+ #include "initiator.h"
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
index ad2f53306f6e..953611fcf31e 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.2 2010/03/31 23:19:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.3 2010/08/24 13:48:01 ssuominen Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -40,6 +40,7 @@ src_prepare() {
export EPATCH_OPTS="-d${S}"
epatch "${FILESDIR}"/CVE-2009-1297.patch
epatch "${FILESDIR}"/${PN}-2.0.871-makefile-cleanup.patch
+ epatch "${FILESDIR}"/${P}-glibc212.patch
}
src_compile() {