summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 21:39:48 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 21:39:48 +0000
commit4c5c7a0c085780f07e208658db3c4dce5ca032a5 (patch)
tree5afbfdd273edc0efb6c554a154672a6b59dda917 /sys-boot/grub/grub-0.97-r14.ebuild
parentRemoved vulnerable versions (diff)
downloadgentoo-2-4c5c7a0c085780f07e208658db3c4dce5ca032a5.tar.gz
gentoo-2-4c5c7a0c085780f07e208658db3c4dce5ca032a5.tar.bz2
gentoo-2-4c5c7a0c085780f07e208658db3c4dce5ca032a5.zip
Use new toolchain helpers for selecting the bfd linker #439082 by Ambroz Bizjak.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot/grub/grub-0.97-r14.ebuild')
-rw-r--r--sys-boot/grub/grub-0.97-r14.ebuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/sys-boot/grub/grub-0.97-r14.ebuild b/sys-boot/grub/grub-0.97-r14.ebuild
index aeb2fb745a92..592d40059041 100644
--- a/sys-boot/grub/grub-0.97-r14.ebuild
+++ b/sys-boot/grub/grub-0.97-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r14.ebuild,v 1.6 2015/02/16 18:06:05 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r14.ebuild,v 1.7 2015/03/16 21:39:48 vapier Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -44,18 +44,6 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)\]/} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- # Bugs 526348 , 466536
- if ! test-flags-CC -fuse-ld=bfd &>/dev/null &&
- $(tc-getLD) --version | grep -q "GNU gold"; then
- eerror "GRUB does not function correctly when built with the gold linker."
- eerror "Please select the bfd linker with binutils-config."
- die "GNU gold detected"
- fi
- fi
-}
-
pkg_setup() {
case $(tc-arch) in
amd64) CONFIG_CHECK='~IA32_EMULATION' check_extra_config ;;
@@ -110,8 +98,7 @@ src_configure() {
# -fno-stack-protector detected by configure, removed from netboot's emake.
use custom-cflags || unset CFLAGS
- # Force ld.bfd if we can set it, bug 466536
- append-ldflags $(test-flags-CC -fuse-ld=bfd)
+ tc-ld-disable-gold #439082 #466536 #526348
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static