summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-07 22:55:48 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-07 22:55:48 +0000
commit201148609da6b272c38f8004e3e91af4efcf1dfa (patch)
tree20313cd67bb13fabf42820f614fe30e4cc136693 /sys-boot/grub/grub-2.00.ebuild
parentVersion bump. Added examples flag (diff)
downloadgentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.tar.gz
gentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.tar.bz2
gentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.zip
Add additional fix for bug 424231.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/grub/grub-2.00.ebuild')
-rw-r--r--sys-boot/grub/grub-2.00.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 844e1620bdaf..4be1e7ce7305 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.11 2012/07/05 01:32:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.12 2012/07/07 22:55:48 floppym Exp $
EAPI=4
@@ -207,10 +207,8 @@ grub_src_install() {
}
src_prepare() {
- local i j
-
if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}/${P}-manpage-race.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
fi
@@ -238,6 +236,7 @@ src_prepare() {
# get enabled platforms
GRUB_ENABLED_PLATFORMS=""
+ local i
for i in ${GRUB_PLATFORMS[@]}; do
use grub_platforms_${i} && GRUB_ENABLED_PLATFORMS+=" ${i}"
done