summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-06 22:41:51 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-06 22:41:51 +0000
commit200c21f6a4acd17967ed6f352557ade0e898226d (patch)
tree592f735538b44b7d5ac9fca9389a8ac821f037a4 /sys-boot/grub
parentorphanize -- packages that require dietlibc do not go in base-system (diff)
downloadgentoo-2-200c21f6a4acd17967ed6f352557ade0e898226d.tar.gz
gentoo-2-200c21f6a4acd17967ed6f352557ade0e898226d.tar.bz2
gentoo-2-200c21f6a4acd17967ed6f352557ade0e898226d.zip
Create /boot/boot symlink for people #194201, and dont bother creating menu.lst symlink.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-0.97-r5.ebuild15
2 files changed, 10 insertions, 11 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index bfdc7f06f3dc..f7fff498d966 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.86 2008/03/30 17:20:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.87 2008/04/06 22:41:51 vapier Exp $
+
+ 06 Apr 2008; Mike Frysinger <vapier@gentoo.org> grub-0.97-r5.ebuild:
+ Create /boot/boot symlink for people #194201, and dont bother creating
+ menu.lst symlink.
30 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r5.ebuild:
Bring in the warning from bug #98768, as it's now important with the new
diff --git a/sys-boot/grub/grub-0.97-r5.ebuild b/sys-boot/grub/grub-0.97-r5.ebuild
index 2efeaecb9011..e05677716990 100644
--- a/sys-boot/grub/grub-0.97-r5.ebuild
+++ b/sys-boot/grub/grub-0.97-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r5.ebuild,v 1.6 2008/03/30 17:29:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r5.ebuild,v 1.7 2008/04/06 22:41:51 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
@@ -132,12 +132,11 @@ src_install() {
doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
fi
- insinto /boot/grub
- doins "${DISTDIR}"/splash.xpm.gz
- newins docs/menu.lst grub.conf.sample
-
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
+
+ insinto /boot/grub
+ doins "${DISTDIR}"/splash.xpm.gz
}
setup_boot_dir() {
@@ -145,6 +144,7 @@ setup_boot_dir() {
local dir=${boot_dir}
[[ ! -e ${dir} ]] && die "${dir} does not exist!"
+ [[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
dir="${dir}/grub"
if [[ ! -e ${dir} ]] ; then
mkdir "${dir}" || die "${dir} does not exist!"
@@ -158,11 +158,6 @@ setup_boot_dir() {
ewarn
fi
- if [[ ! -e ${dir}/menu.lst ]] ; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/menu.lst
- fi
-
if [[ -e ${dir}/stage2 ]] ; then
mv "${dir}"/stage2{,.old}
ewarn "*** IMPORTANT NOTE: you must run grub and install"