summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-02 15:09:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-02 15:09:11 +0000
commit63384b8c2262db5cfa01483c0c3f4461118e3e22 (patch)
treee7049298a5e158f71d06503f1c9ea43f9e519a5b /sys-boot/grub
parentversion bump (diff)
downloadgentoo-2-63384b8c2262db5cfa01483c0c3f4461118e3e22.tar.gz
gentoo-2-63384b8c2262db5cfa01483c0c3f4461118e3e22.tar.bz2
gentoo-2-63384b8c2262db5cfa01483c0c3f4461118e3e22.zip
Fix info manual (was referencing old name); factor out autoreconf handling if we were to execute that on a non-live ebuild.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-1.99-r2.ebuild19
-rw-r--r--sys-boot/grub/grub-9999.ebuild19
3 files changed, 34 insertions, 11 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 3165d221d9df..b79aa8fa9e61 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.169 2011/10/04 18:23:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.170 2011/11/02 15:09:11 flameeyes Exp $
+
+ 02 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> grub-1.99-r2.ebuild,
+ grub-9999.ebuild:
+ Fix info manual (was referencing old name); factor out autoreconf handling if
+ we were to execute that on a non-live ebuild.
04 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> grub-1.99-r2.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/grub-1.99-r2.ebuild b/sys-boot/grub/grub-1.99-r2.ebuild
index e83dd270524d..4133a4d176d2 100644
--- a/sys-boot/grub/grub-1.99-r2.ebuild
+++ b/sys-boot/grub/grub-1.99-r2.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.5 2011/10/04 18:23:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.6 2011/11/02 15:09:11 flameeyes Exp $
EAPI=4
if [[ ${PV} == "9999" ]] ; then
EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub/"
- LIVE_ECLASS="autotools bzr"
+ LIVE_ECLASS="bzr"
SRC_URI=""
+ DO_AUTORECONF="true"
else
MY_P=${P/_/\~}
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
@@ -15,7 +16,7 @@ else
S=${WORKDIR}/${MY_P}
fi
-inherit mount-boot eutils flag-o-matic pax-utils toolchain-funcs ${LIVE_ECLASS}
+inherit mount-boot eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -58,8 +59,9 @@ DEPEND="${RDEPEND}
>=dev-lang/python-2.5.2
sys-devel/flex
virtual/yacc
+ sys-apps/texinfo
"
-if [[ ${PV} == "9999" ]]; then
+if [[ -n ${DO_AUTORECONF} ]] ; then
DEPEND+=" >=sys-devel/autogen-5.10 sys-apps/help2man"
else
DEPEND+=" app-arch/xz-utils"
@@ -170,8 +172,15 @@ src_prepare() {
epatch_user
+ # fix texinfo file name, as otherwise the grub2.info file will be
+ # useless
+ sed -i \
+ -e '/setfilename/s:grub.info:grub2.info:' \
+ -e 's:(grub):(grub2):' \
+ "${S}"/docs/grub.texi
+
# autogen.sh does more than just run autotools
- if [[ ${PV} == "9999" ]] ; then
+ if [[ -n ${DO_AUTORECONF} ]] ; then
sed -i -e '/^autoreconf/s:^:set +e; e:' autogen.sh || die
(. ./autogen.sh) || die
fi
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index c5cc7d7a546a..b3b77b56ded6 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.44 2011/10/04 18:23:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.45 2011/11/02 15:09:11 flameeyes Exp $
EAPI=4
if [[ ${PV} == "9999" ]] ; then
EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub/"
- LIVE_ECLASS="autotools bzr"
+ LIVE_ECLASS="bzr"
SRC_URI=""
+ DO_AUTORECONF="true"
else
MY_P=${P/_/\~}
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
@@ -15,7 +16,7 @@ else
S=${WORKDIR}/${MY_P}
fi
-inherit mount-boot eutils flag-o-matic pax-utils toolchain-funcs ${LIVE_ECLASS}
+inherit mount-boot eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -58,8 +59,9 @@ DEPEND="${RDEPEND}
>=dev-lang/python-2.5.2
sys-devel/flex
virtual/yacc
+ sys-apps/texinfo
"
-if [[ ${PV} == "9999" ]]; then
+if [[ -n ${DO_AUTORECONF} ]] ; then
DEPEND+=" >=sys-devel/autogen-5.10 sys-apps/help2man"
else
DEPEND+=" app-arch/xz-utils"
@@ -166,8 +168,15 @@ src_prepare() {
epatch_user
+ # fix texinfo file name, as otherwise the grub2.info file will be
+ # useless
+ sed -i \
+ -e '/setfilename/s:grub.info:grub2.info:' \
+ -e 's:(grub):(grub2):' \
+ "${S}"/docs/grub.texi
+
# autogen.sh does more than just run autotools
- if [[ ${PV} == "9999" ]] ; then
+ if [[ -n ${DO_AUTORECONF} ]] ; then
sed -i -e '/^autoreconf/s:^:set +e; e:' autogen.sh || die
(. ./autogen.sh) || die
fi