summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-18 15:37:25 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-18 15:37:25 +0000
commitfd78a12f0a00e9790a08e7efaf7747669795cc6a (patch)
tree2abcae10e6307fba60543a6089633422db73e53d /sys-boot/palo
parentdev-python/mpmath: Backport compatibility for gmpy-2, #477098 (diff)
downloadgentoo-2-fd78a12f0a00e9790a08e7efaf7747669795cc6a.tar.gz
gentoo-2-fd78a12f0a00e9790a08e7efaf7747669795cc6a.tar.bz2
gentoo-2-fd78a12f0a00e9790a08e7efaf7747669795cc6a.zip
Version bump.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/palo-1.91.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 68933f7e4c50..a594fe79a478 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.37 2013/07/18 14:06:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.38 2013/07/18 15:37:25 jer Exp $
+
+*palo-1.91 (18 Jul 2013)
+
+ 18 Jul 2013; Jeroen Roovers <jer@gentoo.org> +palo-1.91.ebuild:
+ Version bump.
18 Jul 2013; Jeroen Roovers <jer@gentoo.org> palo-9999.ebuild:
Drop remove-HOME-TERM patch. README is gone.
diff --git a/sys-boot/palo/palo-1.91.ebuild b/sys-boot/palo/palo-1.91.ebuild
new file mode 100644
index 000000000000..823af8ed9396
--- /dev/null
+++ b/sys-boot/palo/palo-1.91.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.91.ebuild,v 1.1 2013/07/18 15:37:25 jer Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://dev.gentoo.org/~jer/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.18-include.patch \
+ "${FILESDIR}"/${PN}-9999-open.patch \
+ "${FILESDIR}"/${PN}-9999-toolchain.patch
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+ sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
+}
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'MACHINE=parisc iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dohtml README.html
+ dodoc palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ INSOPTIONS="-m 0744" doins "${FILESDIR}"/99palo
+}