summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-09-11 21:46:06 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-09-11 21:46:06 +0000
commit624a48c6d7ec0a4ea8210a582e4561fec62d0a67 (patch)
tree08f45a6c062dc1089fed41345cf0e647f152e05e /sys-boot/sgibootcd/sgibootcd-0.12.ebuild
parentRemoved junit from RDEPEND and moved the long description to metadata.xml. (diff)
downloadgentoo-2-624a48c6d7ec0a4ea8210a582e4561fec62d0a67.tar.gz
gentoo-2-624a48c6d7ec0a4ea8210a582e4561fec62d0a67.tar.bz2
gentoo-2-624a48c6d7ec0a4ea8210a582e4561fec62d0a67.zip
Initial import of sgibootcd for creating burnable CD images for SGI LiveCDs.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-boot/sgibootcd/sgibootcd-0.12.ebuild')
-rw-r--r--sys-boot/sgibootcd/sgibootcd-0.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-boot/sgibootcd/sgibootcd-0.12.ebuild b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
new file mode 100644
index 000000000000..c65c19943a1f
--- /dev/null
+++ b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/sgibootcd/sgibootcd-0.12.ebuild,v 1.1 2005/09/11 21:46:06 kumba Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
+HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
+SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* mips"
+IUSE=""
+DEPEND=""
+RESTRICT=""
+
+
+src_compile() {
+ cd ${S}
+ local mycc="$(tc-getCC) ${CFLAGS}"
+
+ [ -f "${S}/sgibootcd" ] && rm -f ${S}/sgibootcd
+ einfo "${mycc} sgibootcd.c -o sgibootcd"
+ ${mycc} sgibootcd.c -o sgibootcd
+}
+
+src_install() {
+ cd ${S}
+ dobin ${S}/sgibootcd
+}