summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-05-11 20:49:12 +0000
committerNed Ludd <solar@gentoo.org>2004-05-11 20:49:12 +0000
commitc7841e898885f7baf9e20a90547bcdf1a0e1ff64 (patch)
tree2246d24533c3d8e9ea1f255ccd7edbc881e94b43 /sys-boot/syslinux
parentAdd Version 0.4.1. (diff)
downloadgentoo-2-c7841e898885f7baf9e20a90547bcdf1a0e1ff64.tar.gz
gentoo-2-c7841e898885f7baf9e20a90547bcdf1a0e1ff64.tar.bz2
gentoo-2-c7841e898885f7baf9e20a90547bcdf1a0e1ff64.zip
add ssp check before patching in nossp patches. This prevents breakage if your gcc knows nothing about -fstack-protector
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog6
-rw-r--r--sys-boot/syslinux/Manifest6
-rw-r--r--sys-boot/syslinux/syslinux-2.06.ebuild7
-rw-r--r--sys-boot/syslinux/syslinux-2.09.ebuild7
4 files changed, 16 insertions, 10 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 4cdbda61520e..1f64c3c12432 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Id: ChangeLog,v 1.5 2004/04/29 03:53:12 solar Exp $
+# $Id: ChangeLog,v 1.6 2004/05/11 20:49:12 solar Exp $
+
+ 11 May 2004; <solar@gentoo.org> syslinux-2.06.ebuild, syslinux-2.09.ebuild:
+ add ssp check before patching in nossp patches. This prevents breakage if your
+ gcc knows nothing about -fstack-protector
*syslinux-2.09 (28 Apr 2004)
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index 8a2cf0f639fa..ac83fbb1e2e9 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -1,9 +1,9 @@
-MD5 c69ec4924ae2b1c623f1f56162688ee0 ChangeLog 2469
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 d7198b55f3f822dc53de23616ee54c4f syslinux-1.75.ebuild 609
MD5 7e1f16de0ad84d74e93c6b24012d0e79 syslinux-2.05.ebuild 761
-MD5 b68756e1a01e6152a5e76763d56afa78 syslinux-2.06.ebuild 876
-MD5 16dd82863e4e72d147feb72de9ae456e syslinux-2.09.ebuild 876
+MD5 4f548ac0a9d8eb79a0faf4e51fb5c369 syslinux-2.06.ebuild 964
+MD5 20a60f09c7255b7095dfd4874797e026 syslinux-2.09.ebuild 964
+MD5 c69ec4924ae2b1c623f1f56162688ee0 ChangeLog 2469
MD5 5c685d9bd473e15d95fd52707ff69cfa files/2.06-nasm.patch 1159
MD5 f1655e42e2fb00292a8887d6d3369ad5 files/digest-syslinux-1.75 65
MD5 cec0b5961400b850b9a5e42fac2e8a73 files/digest-syslinux-2.05 66
diff --git a/sys-boot/syslinux/syslinux-2.06.ebuild b/sys-boot/syslinux/syslinux-2.06.ebuild
index 88df4baa84cd..879a0b490b66 100644
--- a/sys-boot/syslinux/syslinux-2.06.ebuild
+++ b/sys-boot/syslinux/syslinux-2.06.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.06.ebuild,v 1.4 2004/04/29 03:53:12 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.06.ebuild,v 1.5 2004/05/11 20:49:12 solar Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -20,7 +20,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-nasm.patch
# -fstack-protector really does not play along well with any boot loader
- epatch ${FILESDIR}/${PN}-2.06-nossp.patch
+ $(gcc-getCC) -fstack-protector -S -o /dev/null -xc /dev/null >/dev/null 2>&1 && \
+ epatch ${FILESDIR}/${PN}-2.06-nossp.patch
sed -i 's:$(MAKE) -C win32 all::' Makefile
}
diff --git a/sys-boot/syslinux/syslinux-2.09.ebuild b/sys-boot/syslinux/syslinux-2.09.ebuild
index 2ebd0aa82c4e..f71a3649749f 100644
--- a/sys-boot/syslinux/syslinux-2.09.ebuild
+++ b/sys-boot/syslinux/syslinux-2.09.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.09.ebuild,v 1.1 2004/04/29 03:53:12 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.09.ebuild,v 1.2 2004/05/11 20:49:12 solar Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -20,7 +20,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/2.06-nasm.patch
# -fstack-protector really does not play along well with any boot loader
- epatch ${FILESDIR}/${PN}-2.09-nossp.patch
+ $(gcc-getCC) -fstack-protector -S -o /dev/null -xc /dev/null >/dev/null 2>&1 && \
+ epatch ${FILESDIR}/${PN}-2.09-nossp.patch
sed -i 's:$(MAKE) -C win32 all::' Makefile
}