summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-12 00:55:18 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-12 00:55:18 +0000
commit246056220342734b7f1b6c945a3b13e5bc158dd1 (patch)
tree208b20179823277f7885d0cb09a88c35ab4109df /sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
parentstable on mips (diff)
downloadgentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.tar.gz
gentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.tar.bz2
gentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.zip
Fixed MAKEOPTS mess for bug #98463 and removed kernel 2.6 check
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-boot/yaboot/yaboot-1.3.11-r1.ebuild')
-rw-r--r--sys-boot/yaboot/yaboot-1.3.11-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
index 51e20831308d..bf67a126528a 100644
--- a/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild,v 1.7 2005/07/03 13:14:24 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild,v 1.8 2005/07/12 00:55:18 josejx Exp $
inherit eutils toolchain-funcs
@@ -19,8 +19,6 @@ DEPEND="sys-apps/powerpc-utils
PROVIDE="virtual/bootloader"
-MAKEOPTS='PREFIX=/usr MANDIR=share/man'
-
src_compile() {
export -n CFLAGS
export -n CXXFLAGS
@@ -30,12 +28,13 @@ src_compile() {
epatch ${FILESDIR}/chrpfix.patch
#took from http://penguinppc.org/~eb/files/ofpath
epatch ${FILESDIR}/${P}-ofpath-fix.patch
- emake ${MAKEOPTS} CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+
}
src_install() {
cp etc/yaboot.conf etc/yaboot.conf.bak
sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
mv -f etc/yaboot.conf.edit etc/yaboot.conf
- make ROOT=${D} ${MAKEOPTS} install || die
+ make ROOT=${D} PREFIX=/usr MANDIR=share/man install || die
}