summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-10-12 20:04:54 +0000
committerMike Frysinger <vapier@gentoo.org>2013-10-12 20:04:54 +0000
commit1367a61bafac26ce76e939e7cf97ba3e0231e66b (patch)
tree576d2f2fb4121797a2c5563ae88ee46ba3ab9aff /sys-boot
parentstrip-flags: log changes when they happen for user to see #487104 (diff)
downloadgentoo-2-1367a61bafac26ce76e939e7cf97ba3e0231e66b.tar.gz
gentoo-2-1367a61bafac26ce76e939e7cf97ba3e0231e66b.tar.bz2
gentoo-2-1367a61bafac26ce76e939e7cf97ba3e0231e66b.zip
Move flag/toolchain setup to src_configure.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/efibootmgr/ChangeLog5
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-boot/efibootmgr/ChangeLog b/sys-boot/efibootmgr/ChangeLog
index df51585c946e..acf335e33a91 100644
--- a/sys-boot/efibootmgr/ChangeLog
+++ b/sys-boot/efibootmgr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/efibootmgr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.25 2013/09/30 17:16:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.26 2013/10/12 20:04:54 vapier Exp $
+
+ 12 Oct 2013; Mike Frysinger <vapier@gentoo.org> efibootmgr-0.5.4-r1.ebuild:
+ Move flag/toolchain setup to src_configure.
30 Sep 2013; Agostino Sarubbo <ago@gentoo.org> efibootmgr-0.5.4-r1.ebuild:
Stable for x86, wrt bug #485596
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild
index 0534181a80fc..4e7b0b16d83e 100644
--- a/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild,v 1.3 2013/09/30 17:16:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.4-r1.ebuild,v 1.4 2013/10/12 20:04:54 vapier Exp $
EAPI=5
@@ -27,9 +27,12 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-error-reporting.patch"
}
-src_compile() {
+src_configure() {
strip-flags
tc-export CC
+}
+
+src_compile() {
emake EXTRA_CFLAGS="${CFLAGS}"
}