summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 04:12:42 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 04:12:42 +0000
commit3ff53ba0742be59a10a82531ac038b24c125eb5a (patch)
tree47c71d1eac7c8937fe8b5e262b5b7f0409f732b2 /sys-boot
parentSwitch `export -n` to `unset`, and also clear CPPFLAGS & LDFLAGS. (diff)
downloadgentoo-2-3ff53ba0742be59a10a82531ac038b24c125eb5a.tar.gz
gentoo-2-3ff53ba0742be59a10a82531ac038b24c125eb5a.tar.bz2
gentoo-2-3ff53ba0742be59a10a82531ac038b24c125eb5a.zip
Remove legacy CC setup -- always use tc-getCC. Also make sure we respect LD.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot/ChangeLog6
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14-r2.ebuild5
-rw-r--r--sys-boot/yaboot/yaboot-1.3.16.ebuild5
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild5
4 files changed, 11 insertions, 10 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 2d56d0d55691..dd0fe91ecedd 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/yaboot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.45 2015/05/17 04:09:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.46 2015/05/17 04:12:42 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild,
+ yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
+ Remove legacy CC setup -- always use tc-getCC. Also make sure we respect LD.
17 May 2015; Mike Frysinger <vapier@gentoo.org> -yaboot-1.3.17-r1.ebuild,
-yaboot-1.3.17.ebuild, yaboot-1.3.14-r2.ebuild, yaboot-1.3.16.ebuild,
diff --git a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
index 3d452c60c35f..ddcf700c3c48 100644
--- a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.5 2015/05/17 04:09:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.6 2015/05/17 04:12:42 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,7 +19,6 @@ RDEPEND="!ibm? ( sys-fs/hfsutils
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- [ -n "$(tc-getCC)" ] || CC="gcc"
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
@@ -30,7 +29,7 @@ src_compile() {
epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
fi
epatch "${FILESDIR}/sysfs-ofpath.patch"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
}
src_install() {
diff --git a/sys-boot/yaboot/yaboot-1.3.16.ebuild b/sys-boot/yaboot/yaboot-1.3.16.ebuild
index 05b25ddd2f62..c53dada7f2e4 100644
--- a/sys-boot/yaboot/yaboot-1.3.16.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.6 2015/05/17 04:09:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.7 2015/05/17 04:12:42 vapier Exp $
inherit eutils toolchain-funcs
@@ -38,8 +38,7 @@ src_unpack() {
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- [ -n "$(tc-getCC)" ] || CC="gcc"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
}
src_install() {
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index 9c08768e3586..9fb9e07f27ba 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.3 2015/05/17 04:09:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.4 2015/05/17 04:12:42 vapier Exp $
EAPI=2
@@ -49,8 +49,7 @@ src_prepare() {
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- [ -n "$(tc-getCC)" ] || CC="gcc"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
}
src_install() {