summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-06-02 15:56:44 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-06-02 15:56:44 +0000
commit66831c2700bf453f5a13455c0bcd5dd64d997f6a (patch)
tree420532f9939175ceb8220ccfc62809aecb6df931 /sys-boot
parentVersion bump (diff)
downloadgentoo-2-66831c2700bf453f5a13455c0bcd5dd64d997f6a.tar.gz
gentoo-2-66831c2700bf453f5a13455c0bcd5dd64d997f6a.tar.bz2
gentoo-2-66831c2700bf453f5a13455c0bcd5dd64d997f6a.zip
Version bump
(Portage version: 2.1.6.11/cvs/Linux ia64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog7
-rw-r--r--sys-boot/elilo/elilo-3.10.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index 3e58bfef91be..13296aa03e1e 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/elilo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.22 2009/05/06 18:36:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.23 2009/06/02 15:56:44 armin76 Exp $
+
+*elilo-3.10 (02 Jun 2009)
+
+ 02 Jun 2009; Raúl Porcel <armin76@gentoo.org> +elilo-3.10.ebuild:
+ Version bump
06 May 2009; Markus Meier <maekke@gentoo.org> elilo-3.8.ebuild:
add ~amd64, bug #208639
diff --git a/sys-boot/elilo/elilo-3.10.ebuild b/sys-boot/elilo/elilo-3.10.ebuild
new file mode 100644
index 000000000000..0fd417707e0e
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.10.ebuild,v 1.1 2009/06/02 15:56:44 armin76 Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://elilo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elilo/${P}.tar.gz"
+SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.10-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86 ~amd64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ sys-devel/patch
+ dev-util/patchutils"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ebegin Applying ../*.diff
+ # Using epatch on this is annoying because it wants to create the elilo-3.6/
+ # directory. Since all the files are new, it doesn't know better.
+ filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
+ eend $? || return
+
+ # Now Gentooize it
+ sed -i "
+ 1s:/bin/sh:/bin/bash:;
+ s/##VERSION##/$PV/;
+ s/Debian GNU\//Gentoo /g;
+ s/Debian/Gentoo/g;
+ s/debian/gentoo/g;
+ s/dpkg --print-installation-architecture/uname -m/" debian/elilo.sh
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ newsbin debian/elilo.sh elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}