summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-08 14:09:57 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-08 14:09:57 +0000
commit6ce3d142cc7402dde4e16cbb2adc1019586e8278 (patch)
tree011f86dd4477b34f691223ffff2c032e0ebe0905 /sys-boot
parent[media-sound/amarok] Fix media-libs/liblastfm dependency - bug 423391. (diff)
downloadgentoo-2-6ce3d142cc7402dde4e16cbb2adc1019586e8278.tar.gz
gentoo-2-6ce3d142cc7402dde4e16cbb2adc1019586e8278.tar.bz2
gentoo-2-6ce3d142cc7402dde4e16cbb2adc1019586e8278.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-577.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 785a89696e0e..217c36200de1 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.81 2012/05/28 18:40:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.82 2012/07/08 14:09:57 jer Exp $
+
+*unetbootin-577 (08 Jul 2012)
+
+ 08 Jul 2012; Jeroen Roovers <jer@gentoo.org> +unetbootin-577.ebuild:
+ Version bump.
28 May 2012; Jeroen Roovers <jer@gentoo.org> -unetbootin-568.ebuild:
Old.
diff --git a/sys-boot/unetbootin/unetbootin-577.ebuild b/sys-boot/unetbootin/unetbootin-577.ebuild
new file mode 100644
index 000000000000..5d048205ff23
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-577.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-577.ebuild,v 1.1 2012/07/08 14:09:57 jer Exp $
+
+EAPI="4"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+UNETBOOTIN_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fi fo fr gl he hr hu id it ja lt
+ lv ml ms nan nb nl nn pl pt pt_BR ro ru sk sl sr sv sw tr uk ur vi zh_CN zh_TW
+"
+
+for lingua in ${UNETBOOTIN_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/applications
+ doins ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNETBOOTIN_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}