summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-05-14 17:43:27 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-05-14 17:43:27 +0000
commit7f7e72732a236a9a583408051f57f99db271c81e (patch)
tree6ab79d0b35e3cf4e9fde5d9042910882a154b6af /sys-boot
parentAdd missing dtd to DEPEND, bug #355505. (diff)
downloadgentoo-2-7f7e72732a236a9a583408051f57f99db271c81e.tar.gz
gentoo-2-7f7e72732a236a9a583408051f57f99db271c81e.tar.bz2
gentoo-2-7f7e72732a236a9a583408051f57f99db271c81e.zip
sys-boot/plymouth: revbump to 0.8.3-r2; fixed --localstatedir
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth/ChangeLog8
-rw-r--r--sys-boot/plymouth/Manifest1
-rw-r--r--sys-boot/plymouth/plymouth-0.8.3-r2.ebuild90
3 files changed, 98 insertions, 1 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index 73c6318d6f92..51d9f443a945 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/plymouth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.7 2011/04/07 23:31:10 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.8 2011/05/14 17:43:27 aidecoe Exp $
+
+*plymouth-0.8.3-r2 (14 May 2011)
+
+ 14 May 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +plymouth-0.8.3-r2.ebuild:
+ Fix --localstatedir
07 Apr 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
plymouth-0.8.3-r1.ebuild:
diff --git a/sys-boot/plymouth/Manifest b/sys-boot/plymouth/Manifest
index 3e0e735a3a32..0b6ecb0d866a 100644
--- a/sys-boot/plymouth/Manifest
+++ b/sys-boot/plymouth/Manifest
@@ -5,5 +5,6 @@ AUX plymouth.initd 503 RMD160 e4fa0045737592dbb839a869c4d82c3a186e57c6 SHA1 3ea4
DIST gentoo-logo.png 14501 RMD160 e4f33be3f763537242bcd47ea9e145e919152213 SHA1 42e22719c2aa24869c7c22ed06d398272404fd24 SHA256 79ebc1d66693371a90e218ad421cfed05066b51a6645bd967bb7da356a0881fa
DIST plymouth-0.8.3.tar.bz2 763575 RMD160 bb5c13e4eb48d8b881a4d2cc15190c377430f672 SHA1 30135d3b2db42778b32b6d2d9e7e0da90f0da599 SHA256 2e51abbc087228f7910302334755d0190fc9e923eae9992150adb0f6cccc9077
EBUILD plymouth-0.8.3-r1.ebuild 2665 RMD160 b1e71d8ed5fe5ec0a4d7205cfe1bc5f925dcfffe SHA1 cd88a6d8b9c9b6ccc751e79e9b6dc2a8be7b092f SHA256 6739922ca0b0ee399373b9bf6f9f3369e859f5cd6273e0ca2bddd84973b7accb
+EBUILD plymouth-0.8.3-r2.ebuild 2688 RMD160 a6f43c4606914cb677c1b2a10b34089d94bc43b3 SHA1 b73fd6fbf717a9585190926bea894063be7396e7 SHA256 72fe261e6d62c57e5aaf869e96a8b99e5b90a7cbff2d6d71e710c1260446d483
MISC ChangeLog 2747 RMD160 5e8af02c80aea9022af108797f287f72e1fecdcc SHA1 879eccc7304c45f9d8ae761e212af9bc93132483 SHA256 97f5273d9d185ff343d4663f879b6e5c930e8455ce0b9fa019d3dcfc46ca7dd4
MISC metadata.xml 934 RMD160 c4e613323d2fdcb37da960a70e8007f621175f9f SHA1 215e19611a27faac61e967abff864450f1a9ed85 SHA256 d05a2ceb21ed3d6c9854dbd15446555cdf1bba95622e86bae8c6550f314f8ce6
diff --git a/sys-boot/plymouth/plymouth-0.8.3-r2.ebuild b/sys-boot/plymouth/plymouth-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..06a41cf38e10
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.8.3-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3-r2.ebuild,v 1.1 2011/05/14 17:43:27 aidecoe Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/snapshot/${P}.tar.bz2
+ http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_nouveau video_cards_radeon"
+IUSE="${IUSE_VIDEO_CARDS} +branding gdm +pango static-libs"
+
+DEPEND=">=media-libs/libpng-1.2.16
+ >=x11-libs/gtk+-2.12:2
+ pango? ( >=x11-libs/pango-1.21 )
+ video_cards_intel? ( x11-libs/libdrm[video_cards_intel] )
+ video_cards_nouveau? ( x11-libs/libdrm[video_cards_nouveau] )
+ video_cards_radeon? ( x11-libs/libdrm[video_cards_radeon] )
+ "
+RDEPEND="${DEPEND}
+ >=sys-kernel/dracut-008-r1[dracut_modules_plymouth]
+ "
+
+DOCS=(AUTHORS ChangeLog NEWS README TODO)
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-drm-reduce-minimum-build-requirements.patch
+ "${FILESDIR}"/${PV}-image-replace-deprecated-libpng-function.patch
+ "${FILESDIR}"/${PV}-gentoo-fb-path.patch
+ )
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ $(use_enable video_cards_intel libdrm_intel)
+ $(use_enable video_cards_nouveau libdrm_nouveau)
+ $(use_enable video_cards_radeon libdrm_radeon)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use static-libs; then
+ mv "${D}/$(get_libdir)"/libply{,-splash-core}.{a,la} \
+ "${D}/usr/$(get_libdir)"/ || die 'mv *.{a,la} files failed'
+ gen_usr_ldscript libply.so libply-splash-core.so
+ else
+ einfo "Removing /usr/$(get_libdir)/plymouth/*.la"
+ rm "${D}/usr/$(get_libdir)"/plymouth/{*.la,renderers/*.la} \
+ || die 'rm *.la'
+ fi
+
+ newinitd "${FILESDIR}"/plymouth.initd plymouth || die 'initd failed'
+
+ if use branding ; then
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png || die 'branding failed'
+ fi
+}
+
+pkg_postinst() {
+ elog "Plymouth initramfs utilities scripts are located in"
+ elog "/usr/libexec/plymouth"
+ elog ""
+ elog "Follow instructions on"
+ elog ""
+ elog " http://dev.gentoo.org/~aidecoe/doc/en/plymouth.xml"
+ elog ""
+ elog "to setup Plymouth."
+ echo
+ ewarn "You need to disable 'interactive' feature either in /etc/conf.d/rc"
+ ewarn "(baselayout-1) or /etc/rc.conf (OpenRC) to make Plymouth work"
+ ewarn "properly with init system."
+}